Subject: [mpls] Comments please: I-D ACTION:draft-chen-mpls-ldpigp-syn-accurate-00.txt

From: Emily <[email-masked]>
Date: Mon, 25 Jun 2007 13:17:40 +0800

Hi,

I am writing to ask advices for the newly issued internet-draft "Explicit Notification for LDP-IGP Synchronization".

This document proposes a mechanism to affirm the switching time accurately by propagating a explicit notification from downstream. The proposed solution can be used in a MPLS L2VPN or L3VPN scenario, to prevent any traffic from being discarded, and avoid the important traffic from being forwarded through a non-optimal path in long time even if the optimal path is operational.

Any suggestion or opinion of the mechanism will be appreciated. Looking forward to your reply!

Details of the document is as follows: 

> Title : Explicit Notification for LDP-IGP Synchronization
> Author(s) : E. Chen
> Filename : draft-chen-mpls-ldpigp-syn-accurate-00.txt
> Pages : 10
> Date : 2007-6-18
> 
>  A fundamental concept in Label Distribution Protocol - Interior 
>  Gateway Protocol (LDP-IGP) Synchronization is that LDP is fully 
>  established before the IGP path is switched for IP forwarding. This 
>  document proposes a mechanism to affirm the switching time accurately 
>  by propagating a explicit notification from downstream. The 
>  interoperability with other Label Switched Routers (LSRs), which may 
>  not support the mechanism, is also considered. 
> 
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-chen-mpls-ldpigp-syn-accurate-00.txt

Best Regards,

Emily Chen 　　　　　
2007-06-25
_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: Leon <[email-masked]>
Date: Tue, 26 Jun 2007 10:11:50 +0800

Could you give the more information about detail scenarios to clarify the requirements for the explicit notification of ldp-idp synchronization.

Thanks
Leon
  ----- Original Message ----- 
  From: Emily 
  To: [email-masked] 
  Sent: Monday, June 25, 2007 1:17 PM
  Subject: [mpls] Comments please: I-DACTION:draft-chen-mpls-ldpigp-syn-accurate-00.txt

  Hi,

  Best Regards,

  Emily Chen 　　　　　
  2007-06-25

------------------------------------------------------------------------------

---

From: Emily <[email-masked]>
Date: Thu, 28 Jun 2007 20:04:15 +0800

As the figure below, MPLS traffic is forwarded from RTA to RTF. In this case, LDP-IGP synchronazation should be used on RTB. Once the optimal path changes, it is necessary for RTB to affirm the switching time accurately. Otherwise, the important packets (such as VPN traffic) would be discarded or forwarded through a non-optimal path in long time. 

                                       (Optimal Path)             
                                           +---+                                               
                      +--------------------|RTC|----------------------+                        
                      |                    +---+                      |                        
                      |                                               |                        
+---+               +---+                                           +---+               +---+  
|RTA|---------------|RTB|                                           |RTE|---------------|RTF|  
+---+               +---+                                           +---+               +---+  
                      |                                               |                        
                      |                    +---+                      |                        
                      +--------------------|RTD|----------------------+                        
                                           +---+                                               

  ----- Original Message ----- 
  From: Leon 
  To: Emily 
  Cc: [email-masked] 
  Sent: Tuesday, June 26, 2007 10:11 AM
  Subject: Re: [mpls] Comments please: I-DACTION:draft-chen-mpls-ldpigp-syn-accurate-00.txt

  Thanks
  Leon
    ----- Original Message ----- 
    From: Emily 
    To: [email-masked] 
    Sent: Monday, June 25, 2007 1:17 PM
    Subject: [mpls] Comments please: I-DACTION:draft-chen-mpls-ldpigp-syn-accurate-00.txt

    Hi,

    Best Regards,

    Emily Chen 　　　　　
    2007-06-25

----------------------------------------------------------------------------