Subject: [MPLS] One question about MAC Address Withdraw Message in RFC4762

From: vivienne <[email-masked]>
Date: Wed, 13 Jun 2007 09:26:55 +0800

空白Hi all,

I have one question about MAC Address Withdraw Message in RFC4762

RFC4762 say 

We introduce an optional MAC List TLV in LDP to specify a list of MAC  addresses that can be removed or unlearned using the LDP Address Withdraw Message.

And also say

The MAC Address Withdraw Message contains a FEC TLV (to identify the VPLS affected), a MAC Address TLV, and optional parameters.  No optional parameters have been defined for the MAC Address Withdraw signaling. 

This two segment is  contradiction.

The first  segment say that the MAC Address TLV is optional parameters. But the second segment impliedly say that the FEC TLV and the MAC Address TLV must be included .

Since the MAC Address Withdraw Message and Address Withdraw Message used the same message type (0x0301).

So my question is how to process the message which message type is 0x0301 and  which TLV is mandatory when we parse this message .

Further question is,

If Address list TLV is mandatory .Then how to fill the Address list TLV for L2VPN, since the ip address is not usefule for L2VPN.

If Address list TLV is not mandatory .Then how to fill MAC Address Withdraw Message and Address Withdraw Message  when this remote peer session is used not only for L2VPN but also for other application (for example TE). 

Thanks and Regards

Vivienne

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: "Asaf Henig" <[email-masked]>
Date: Wed, 13 Jun 2007 08:29:59 +0300

As I understand and according MRV implementation
both the FEC 128 or 129 and an Empty MAC list TLV are mandatory.

Attached is an ethereal file containing a single MAC withdraw message we send toward a PE-rs machine. 
Regards
Asaf Henig
MRV communications. 

-----Original Message-----
From: vivienne [mailto:[email-masked]]
Sent: Wed 6/13/2007 4:26 AM
To: [email-masked]
Subject: [MPLS] One question about MAC Address Withdraw Message in RFC4762
 
??Hi all,

RFC4762 say 

And also say

Further question is,

Thanks and Regards

Vivienne

---

From: Luca Martini <[email-masked]>
Date: Wed, 13 Jun 2007 16:24:58 -0600

There is a typo in the second statement .
"MAC Address TLV" should read "MAC List TLV"

So you can send a MAC Address Withdraw Message with an mac list TLV with 
an empty list, or a MAC Address Withdraw Message with an mac list TLV 
with a list of MACs. Either way the MAC List TLV must be present.

Luca

vivienne wrote:
> Hi all,
> We introduce an optional MAC List TLV in LDP to specify a list of MAC 
>  addresses that can be removed or unlearned using the LDP Address 
> Withdraw Message.
>
>  
>
> And also say
>
> The MAC Address Withdraw Message contains a FEC TLV (to identify the 
> VPLS affected), a MAC Address TLV, and optional parameters.  No 
> optional parameters have been defined for the MAC Address Withdraw 
> signaling.
>
>  
>
> The first  segment say that the MAC Address TLV is optional 
> parameters. But the second segment impliedly say that the FEC TLV and 
> the MAC Address TLV must be included .
>
>  
>
> So my question is how to process the message which message type is 
> 0x0301 and  which TLV is mandatory when we parse this message .
>
>  
>
> Further question is,
>
> If Address list TLV is mandatory .Then how to fill the Address list 
> TLV for L2VPN, since the ip address is not usefule for L2VPN.
>
> If Address list TLV is not mandatory .Then how to fill MAC Address 
> Withdraw Message and Address Withdraw Message  when this remote peer 
> session is used not only for L2VPN but also for other application (for 
> example TE).
>
>  
>
>  
>
> Thanks and Regards
>
> Vivienne
>
>  
>
> ------------------------------------------------------------------------
>

---

From: vivienne <[email-masked]>
Date: Thu, 14 Jun 2007 09:06:01 +0800

Dear Luca,
You mean that,
I should send a MAC Address Withdraw Message with an mac list TLV with an empty list ,even this is a local session.
Or I should send a MAC Address Withdraw Message with an Address list  TLV with an empty list ?

Actually I want to know whether I should fill the Address list  TLV and how to fill it  and whether the mac list TLV and FEC TLV is mandatory when this is remote session for L2VPN.
BTW, I think it should not be filled the mac list TLV in local session for nomal LDP based on the RFC 3036.

Thanks 
Vivienne

---

From: vivienne <[email-masked]>
Date: Mon, 18 Jun 2007 09:28:18 +0800

Hi all,