Subject: [mpls] error response to mpls data packets

From: "anshu " <[email-masked]>
Date: 10 Apr 2008 10:21:45 -0000

Hi,MPLS LSPs can span across different type of networks.Suppose LSP spans across R1,R2,R3 and R2 is not part of IP networks.
In that case how will the forwarding error is handled at R2 (incase its part of IP, ICMP errormessage can be sent to the source). I could not find any standard specs which talks about any genericimplementation.Regards,Anshu  
_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls

---

From: Nitin Bahadur <[email-masked]>
Date: Thu, 10 Apr 2008 07:58:46 -0700

> 
>> > MPLS LSPs can span across different type of networks.
>> > Suppose LSP spans across R1,R2,R3 and R2 is not part of IP networks.
>> > In that case how will the forwarding error is handled at R2 (incase its
>> part of IP, ICMP error
>> > message can be sent to the source).
> 
> If R2 is pure MPLS and there is a forwarding error, then the packet will
> likely get dropped.
> MPLS has no equivalent of ICMP error. For MPLS networks, it is important that
> one run MPLS-OAM tools to quickly detect forwarding plane errors and fix the
> same.

---

From: "Anup Kumar Vasudevan (anuvasud)" <[email-masked]>
Date: Thu, 10 Apr 2008 22:35:23 +0530

Hi 
 
Will RFC 4379 not suit your purpose? This is the RFC that defines MPLS
OAM - look at 4377 and 4378 for a framework and requirements of OAM.
However, if R2 is not part of the IP network, the MPLS n/w will
terminate at R2  i.e. the R1-R2 will be one LSP and R2-R3 will be a
different LSP? 
 
Also within the OAM RFC you might have to look more at the Downstream
Mapping TLV. However in case of a failure at R2, it should be able to
handle the MPLS Echo request packet which is a UDP packet, with the
Label stack of the LSP being used, and with a destination address in the
Local loopback region of IPv4/IPV6. 
 
Regards
Anup Vasudevan

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of
anshu 
Sent: Thursday, April 10, 2008 3:52 PM
To: [email-masked]; [email-masked]
Subject: [mpls] error response to mpls data packets

Hi,
MPLS LSPs can span across different type of networks.
Suppose LSP spans across R1,R2,R3 and R2 is not part of IP networks. 
In that case how will the forwarding error is handled at R2 (incase its
part of IP, ICMP error
message can be sent to the source). I could not find any standard specs
which talks about any generic
implementation.

Regards,
Anshu

<http://adworks.rediff.com/cgi-bin/AdWorks/click.cgi/www.rediff.com/sign
ature-home.htm/1050715198@Middle5/2087310_2079844/2087442/1?PARTNER=3&OA
S_QUERY=null> 	
_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls

---

From: <[email-masked]>
Date: Mon, 14 Apr 2008 15:02:17 +0200

Hi,
 
I personally agree with Anup.
 
Besides the implementation based insights of RFC's 4377, 4378, 4379
perhaps a browse through the following book can also be of assistance in
order to understand how MPLS-OAM can be used to detect failures that the
control plane is unaware of:
 
  "MPLS-Enabled Applications", Chapter 12.3.2 by Ina Minei and Julian
Lucek
 
Cheers
 
Santanu Ganguly

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Anup Kumar Vasudevan (anuvasud)
Sent: Thursday, April 10, 2008 7:05 PM
To: anshu ; [email-masked]; [email-masked]
Subject: Re: [mpls] error response to mpls data packets

Hi 

 
Regards
Anup Vasudevan

Hi,

Regards,
Anshu