Subject: [mpls] FW: *** Revised ID needed *** Last Call: draft-ietf-mpls-number-0-bw-te-lsps (ALink-Type sub-TLV to convey the number of Traffic EngineeringLabel Switched Paths signalled with zero reserved bandwidthacross a link) to Propose

From: JP Vasseur <[email-masked]>
Date: Tue, 19 Aug 2008 19:47:11 +0200

Dear WGs,

We just posted the new revision of draft-ietf-mpls-number-0-bw-te-lsps:
http://www.ietf.org/internet-drafts/draft-ietf-mpls-number-0-bw-te-lsps-11.t
xt 

The changes takes into account the comment received during WG LCs and are
summarized below:
>> 
>>>>  
>>>>  Here are some comments from various lists that I can find on the ISIS
>>>> aspects:
>>>>  
>>>>  
>>>>  -----------------------------------
>>>>  "Section 1:
>>>>  
>>>>  s/Constraint/Constrained
>>>>  
>>>>  Section 2 Paragraph 3 First Sentence
>>>>  
>>>>  s/assumption/assumptions
>>>>  
>>>>  s/unconstrained TE Label Switched Path/unconstrained TE Label Switched
>>>>  Paths
>>>>  (plural "paths")
>>>>  
>>>>  JP> Fixed.
>>>>  
>>>>  Section 3
>>>>  
>>>>  As the section is discussing two different sub-TLVs (one for IS-IS and
>>>>  one for OSPF) the first sentence should read:
>>>>  
>>>>  "Two Unconstrained TE LSP count sub-TLVs are defined that specify the
>>>>     number of TE LSPs signalled with zero bandwidth across a link.
>>>>  
>>>>  JP> Fixed.
>>>>  
>>>>  Section 3.1
>>>>  
>>>>  It might be worth mentioning that the new sub-TLV could also appear in
>>>>  the MT IS-Neighbor TLV (222) - but I won't insist on it as it is
>>>>  generally assumed that anything that appears in TLV 22 could also appear
>>>>  in TLV 222.
>>>>  "
>>>>  JP> OK I added a reference.
>>>>  ---------------------------------------
>>>>  
>>>>  "
>>>>  if a link flaps and a substantial number of tunnels are going through
>>>>  it, these tunnels will be re-routed through other links. This will
>>>>  trigger flooding of isis lsp's in order to advertise/update the
>>>>  te-lsp-count subtlv, right ? Do we need to specify anything in order to
>>>>  prevent storms ?
>>>>  "
>>>>  
>>>>  This last one is relevant to be addressed w/ some modified text in the
>>>> draft. More to come as I get it.
>>>>  
>>>>  JP> Which is no different than for any other TE-related TLVs. Even with
>>>> non-0 bw TE LSPs, if a link flaps they will get rerouted on other links,
>>>> which will change the reserved bandwidth and will trigger the flooding of
>>>> ISIS LSP or OSPF LSA to reflect the updated reserved bandwidth ? This is
>>>> why we added ³Similarly to other MPLS Traffic Engineering link
>>>> characteristics, LSA/LSP origination trigger mechanisms are outside the
>>>> scope of this document.²
>>>>  
>>>>  That being said, I added the following : ³care must be given to not
>>>> trigger the systematic flooding of a new IS-IS LSP or OSPF LSA with a too
>>>> high granularity in case of change of the number of unconstrained TE LSPs.²
>>>>  
>>>>  JP> Furthermore, I checked IANA actions, all correct.
>>>>  
>>>>  -Dward
>>>> 
>>>> 
>>>> Thanks.
>>>> 
>>>> JP.
>>>>  
>>>>  
>>>>  
 
_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls

---

From: JP Vasseur <[email-masked]>
Date: Tue, 19 Aug 2008 19:52:56 +0200

On 8/19/08 7:47 PM, "JP Vasseur" <[email-masked]> wrote:

> http://www.ietf.org/internet-drafts/draft-ietf-mpls-number-0-bw-te-lsps-11.txt
>