Subject: Re: [mpls] A Question on RFC 3815 when implementing the LDP remotesession configuration command

From: Tina TSOU <[email-masked]>
Date: Mon, 07 Jun 2010 12:07:26 +0800

Hi Vishwas et al,
I considered it carefully afterwards.

One ULONG index is to identify two entities, and one of them has to be set 
us ifindex.

The key issue is that each vendor implements ifindex differently, 
furthermore different version has difference. In the public MIB, there is no 
a ULONG space, for each vender each version to allocate it ifindex.

There are many approaches, I propose the following.

Use mplsLdpEntityTargetPeer as the index (There were 2 indexes, use this 
field as the 3nd index), and specify that when EntityIndex operates Local 
Entity, it is ifindex.

I’m open for other approaches. In this case, do we need a Errata, 3815bis, 
or a separate smallest RFC?

If the WG wants to refresh RFC 3815, I suggest to include the latest LDP 
feature by the way.

The original text is:

     mplsLdpEntityEntry OBJECT-TYPE

         SYNTAX      MplsLdpEntityEntry

         MAX-ACCESS  not-accessible

         STATUS      current

         DESCRIPTION

             "An entry in this table represents an LDP entity.

             An entry can be created by a network administrator

             or by an SNMP agent as instructed by LDP."

         INDEX       {  mplsLdpEntityLdpId, mplsLdpEntityIndex  }

         ::= { mplsLdpEntityTable 1 }

It could say:

     mplsLdpEntityEntry OBJECT-TYPE

         SYNTAX      MplsLdpEntityEntry

         MAX-ACCESS  not-accessible

         STATUS      current

         DESCRIPTION

             "An entry in this table represents an LDP entity.

             An entry can be created by a network administrator

             or by an SNMP agent as instructed by LDP."

         INDEX       {  mplsLdpEntityLdpId, mplsLdpEntityIndex, 
mplsLdpEntityTargetPeer  }

         ::= { mplsLdpEntityTable 1 }

B. R.
Tina
http://tinatsou.weebly.com/contact.html

----- Original Message ----- 
From: "Tina TSOU" <[email-masked]>
To: "Vishwas Manral" <[email-masked]>
Cc: <[email-masked]>; "Romascanu, Dan (Dan)" <[email-masked]>; 
<[email-masked]>; <[email-masked]>
Sent: Tuesday, May 25, 2010 6:15 PM
Subject: Re: [mpls] A Question on RFC 3815 when implementing the LDP 
remotesession configuration command

> Thanks Vishwas.
>
> B. R.
> Tina
> http://tinatsou.weebly.com/contact.html
> ----- Original Message ----- 
> From: "Vishwas Manral" <[email-masked]>
> To: "Tina TSOU" <[email-masked]>
> Cc: <[email-masked]>; "Romascanu, Dan (Dan)" <[email-masked]>; 
> <[email-masked]>; <[email-masked]>
> Sent: Tuesday, May 25, 2010 12:58 AM
> Subject: Re: [mpls] A Question on RFC 3815 when implementing the LDP 
> remotesession configuration command
>
>
> Hi Tina,
>
> You could use a mapping table to get the index. Another way you could
> do it is to use different ranges i.e. 0 - 2 ^24 for ifindex and rest
> for IP address which would never clash.
>
> Thanks,
> Vishwas
>
> On Sun, May 23, 2010 at 11:17 PM, Tina TSOU <[email-masked]> wrote:
>> Hi all,
>>
>> While designing the LDP MIB according to RFC 3815, I have one question.
>>
>> When I look at the following specification in RFC 3815, I found it 
>> difficult
>> to implement the LDP remote session configuration command. The reasons 
>> are
>> following.
>>
>> • “Another way to use this index is to give this the value of
>> ifIndex. However, this is dependant on the implementation.”----RFC 3815
>>
>>
>>
>> • “A Targeted Hello is sent to a specific address rather than to the
>> “all routers” group multicast address for the outgoing interface.”----RFC
>> 5036
>>
>>
>>
>> The Ifindex and IP address conflict/overlap at the value range. I couldn’t
>> find a technical way to elude it.
>>
>>
>>
>> Hints are appreciated.
>>
>>
>>
>> B. R.
>> Tina
>> http://tinatsou.weebly.com/contact.html
>> _______________________________________________
>> mpls mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/mpls
>>
>>
>

---

From: "t.petch" <[email-masked]>
Date: Tue, 8 Jun 2010 17:43:29 +0200

----- Original Message -----
From: "Tina TSOU" <[email-masked]>
To: "Vishwas Manral" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Monday, June 07, 2010 6:07 AM

Hi Vishwas et al,

<tp>
That would not be an acceptable change to SMI.  You would have to create a whole
new table with different named objects in it with three index values.

The scope for enhancing existing objects is limited - see RFC2578 s10 for
details.

Tom Petch
</tp>

The original text is:

It could say:

         STATUS      current

         DESCRIPTION

B. R.
Tina

---

From: "Joan Cucchiara" <[email-masked]>
Date: Thu, 10 Jun 2010 10:44:50 -0400

Tina,

If you are looking for a quick way to lookup
LdpEntities and their associated Target Addresses,  then you
can add a table in an enterprise MIB.  Note that the target information, 
should appear as
(InetAddressType, InetAddress), so there is some flexibility, i.e. IPv4 or 
IPv6.

I'm don't believe this would benefit the LdpMIB (RFC3815) because
not all applications use targeted hellos.

Thanks,
  -Joan

----- Original Message ----- 
From: "t.petch" <[email-masked]>
To: "Tina TSOU" <[email-masked]>; "Vishwas Manral" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; 
<[email-masked]>
Sent: Tuesday, June 08, 2010 11:43 AM
Subject: Re: [mpls] [OPSAWG] A Question on RFC 3815 when implementing theLDP 
remotesession configuration command

----- Original Message -----
From: "Tina TSOU" <[email-masked]>
To: "Vishwas Manral" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; 
<[email-masked]>

Hi Vishwas et al,

<tp>
That would not be an acceptable change to SMI.  You would have to create a 
whole
new table with different named objects in it with three index values.

Tom Petch
</tp>

The original text is:

It could say:

         STATUS      current

         DESCRIPTION

B. R.
Tina