Subject: Re: [mpls] Last Calls on P2MP LSP Ping and Enhanced DS Map

From: Shivakumar Channalli <[email-masked]>
Date: Tue, 1 Jun 2010 18:23:24 +0530

Hi shaleen,

I have one more suggestion

Section:
3.2.1. Egress Address P2MP Responder Identifier Sub-TLVs
"A node that receives an echo request with this Sub-TLV present MUST
   respond only if the node lies on the path to the address in the
   Sub-TLV."

The above statement hold goods only in case of traceroute mode of LSP
ping.

if we want to do a normal p2mp ping (just consider pinging a single p2mp
egress), and apply the above rule we'll end up in a wrong scenario.

consider:

         ttl-1        ttl-2       ttl-3      ttl-4      ttl-5
         Bud node    Bud node    Bud node    Bud node Pure-egress
A-----------B-----------C-----------D-----------E----------F
|-----------| lsp1
|-----------------------| lsp2
|-----------------------------------| lsp3
|-----------------------------------------------| lsp4
|----------------------------------------------------------| lsp5

The ping request sent from A will reach all the egress (including bud
nodes)
So as per the section 3.2.1 all the bud nodes are on the path to egress
and everybody will respond.

so i guess 3.2.1 section can be improved by mentioning that the rule is
applicable in case of traceroute mode of ping only and for normal ping
scenario a node must reply only if it the actual egress.

finding if a ping packets is for trace or not can be decided
1) examining if any down map tlvs are there.
2) may be add one more flag saying ++traceroute mode++ of LSP ping is
being done.

option 2 seems a cleaner way of handling this. As we may also need some
way of knowing , if the packet is for trace mode/ ping mode for some
other cases also.

in any case section 3.2.1 needs this updation.

...$hiv

---

From: "Shaleen Saxena (ssaxena)" <[email-masked]>
Date: Tue, 1 Jun 2010 08:59:16 -0500

Hi,

Can you do ping with Node Address P2MP Responder Identifier instead of
Egress Address P2MP Responder Identifier? Then no other node would
respond.

Thanks,
Shaleen

> -----Original Message-----
> From: Shivakumar Channalli [mailto:[email-masked]]
> Sent: Tuesday, June 01, 2010 8:53 AM
> To: Shaleen Saxena (ssaxena); Santiago Alvarez (saalvare); Nitin
> Bahadur
> Cc: [email-masked]
> Subject: RE: [mpls] Last Calls on P2MP LSP Ping and Enhanced DS Map
> 
> Hi shaleen,
>

---

From: Shivakumar Channalli <[email-masked]>
Date: Tue, 1 Jun 2010 21:15:52 +0530

Thanks shaleen,
That cleared my doubt.

...$hiv

|-----Original Message-----
|From: Shaleen Saxena (ssaxena) [mailto:[email-masked]]
|Sent: Tuesday, June 01, 2010 7:29 PM
|To: Shivakumar Channalli; Santiago Alvarez (saalvare); Nitin Bahadur
|Cc: [email-masked]; Shaleen Saxena (ssaxena)
|Subject: RE: [mpls] Last Calls on P2MP LSP Ping and Enhanced DS Map
|
|Hi,
|
|Can you do ping with Node Address P2MP Responder Identifier instead of
|Egress Address P2MP Responder Identifier? Then no other node would
|respond.
|
|Thanks,
|Shaleen
|
|
|> -----Original Message-----
|> From: Shivakumar Channalli [mailto:[email-masked]]
|> Sent: Tuesday, June 01, 2010 8:53 AM
|> To: Shaleen Saxena (ssaxena); Santiago Alvarez (saalvare); Nitin
|> Bahadur
|> Cc: [email-masked]
|> Subject: RE: [mpls] Last Calls on P2MP LSP Ping and Enhanced DS Map
|>
|> Hi shaleen,
|>
|> I have one more suggestion
|>
|> Section:
|> 3.2.1. Egress Address P2MP Responder Identifier Sub-TLVs
|> "A node that receives an echo request with this Sub-TLV present MUST
|>    respond only if the node lies on the path to the address in the
|>    Sub-TLV."
|>
|> The above statement hold goods only in case of traceroute mode of LSP
|> ping.
|>
|> if we want to do a normal p2mp ping (just consider pinging a single
|> p2mp
|> egress), and apply the above rule we'll end up in a wrong scenario.
|>
|> consider:
|>
|>
|>          ttl-1        ttl-2       ttl-3      ttl-4      ttl-5
|>          Bud node    Bud node    Bud node    Bud node Pure-egress
|> A-----------B-----------C-----------D-----------E----------F
|> |-----------| lsp1
|> |-----------------------| lsp2
|> |-----------------------------------| lsp3
|> |-----------------------------------------------| lsp4
|> |----------------------------------------------------------| lsp5
|>
|> The ping request sent from A will reach all the egress (including bud
|> nodes)
|> So as per the section 3.2.1 all the bud nodes are on the path to
|egress
|> and everybody will respond.
|>
|> so i guess 3.2.1 section can be improved by mentioning that the rule
|is
|> applicable in case of traceroute mode of ping only and for normal
ping
|> scenario a node must reply only if it the actual egress.
|>
|> finding if a ping packets is for trace or not can be decided
|> 1) examining if any down map tlvs are there.
|> 2) may be add one more flag saying ++traceroute mode++ of LSP ping is
|> being done.
|>
|> option 2 seems a cleaner way of handling this. As we may also need
|some
|> way of knowing , if the packet is for trace mode/ ping mode for some
|> other cases also.
|>
|> in any case section 3.2.1 needs this updation.
|>
|>
|>
|>
|>
|>
|>
|>
|>
|>
|>
|>
|>
|> ...$hiv
|>
|>