Subject: [mpls] Help with Erratum on RFC 3815

From: Adrian Farrel <[email-masked]>
Date: Sat, 21 Aug 2010 15:15:51 +0100

Hi,

Erratum 227 at http://www.rfc-editor.org/errata_search.php?eid=227 points 
out a real issue.

But I am not sure if it needs to be fixed or whether a resolution introduces 
a backwards compatibility issue.

Does it matter that the order of objects in the SEQUENCE do not match the 
order of the OIDs? Is there a need to reorder anything:
- the objects in the SEQUENCE
- the OIDs assigned.

I suspect that, although the current state of the module is "unusual", no 
fix is actually required.

Thanks for any thoughts.

Adrian

---

From: "Joan Cucchiara" <[email-masked]>
Date: Sun, 22 Aug 2010 21:19:26 -0400

Hi Adrian,

This issue was addressed by another MIB Dr. about the time
the Errata was filed on the mpls list.  To quote the response:

"While this may be a poor practice, I don't think it actually
violates RFC 2578.  As far as I can see, the only thing it actually
says is this:

7.10.  Mapping of the OBJECT-TYPE value
...
(2)  If the object corresponds to a conceptual row, then at least one
     assignment, one for each column in the conceptual row, is present
     beneath that object.  The administratively assigned name for each
     column is derived by appending a unique, positive sub-identifier to
     the administratively assigned name for the conceptual row.

which does not put any ordering constraints on the sub-identifiers.

Unless there is something that I have missed, it seems to me that
this is not actually an erratum.

Mike Heard"

I agree with Mike that this is not technically a mistake, so no fix is 
required.

What happens to this errata now?

Thanks,
   -Joan

----- Original Message ----- 
From: "Adrian Farrel" <[email-masked]>
To: <[email-masked]>
Cc: "Joan Cucchiara" <[email-masked]>; "Hans Sjöstrand" 
<[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Saturday, August 21, 2010 10:15 AM
Subject: Help with Erratum on RFC 3815

> But I am not sure if it needs to be fixed or whether a resolution 
> introduces a backwards compatibility issue.
>

---

From: Thomas Nadeau <[email-masked]>
Date: Mon, 23 Aug 2010 07:51:01 -0400

Yes, Joan is correct (and Mike); no error here. It is just perhaps aesthetically not pretty.  We in fact discussed this with Bert when we were wrapping up the original "MPLS pack" of MIBs (3811, 12, 13, 14, and 15) and it was agreed to just leave things alone.

	--Tom

> I agree with Mike that this is not technically a mistake, so no fix is required.
> 
> ----- Original Message ----- From: "Adrian Farrel" <[email-masked]>
> To: <[email-masked]>
> Cc: "Joan Cucchiara" <[email-masked]>; "Hans Sjöstrand" <[email-masked]>; <[email-masked]>; <[email-masked]>
>> Erratum 227 at http://www.rfc-editor.org/errata_search.php?eid=227 points out a real issue.
>> 
>> But I am not sure if it needs to be fixed or whether a resolution introduces a backwards compatibility issue.
>> 
>> Does it matter that the order of objects in the SEQUENCE do not match the order of the OIDs? Is there a need to reorder anything:
>> I suspect that, although the current state of the module is "unusual", no fix is actually required.
>> 
>> Thanks for any thoughts.
>> 
>> Adrian 
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 23 Aug 2010 12:55:16 +0100

Joan,

Thanks for access to your commodious email archive :-)

Since that:
- looks to be the general view of the MIB doctoring world
- is consistent with what I guessed
- didn't get any screams on the list at the time
I will add notes to the Erratum and close it down.

Cheers,
Adrian
----- Original Message ----- 
From: "Joan Cucchiara" <[email-masked]>
To: "Adrian Farrel" <[email-masked]>; <[email-masked]>
Cc: "Hans Sjöstrand" <[email-masked]>; <[email-masked]>; 
<[email-masked]>
Sent: Monday, August 23, 2010 2:19 AM
Subject: Re: [mpls] Help with Erratum on RFC 3815

Hi Adrian,

Mike Heard"

Thanks,
   -Joan