Subject: [mpls] poll on draft-asati-pignataro-mpls-ldp-iana

From: Loa Andersson <[email-masked]>
Date: Fri, 22 Apr 2011 20:11:23 +0800

Working Group,

this is to start a two week poll on making

draft-asati-pignataro-mpls-ldp-iana-01

an mpls working group document.

If you support the document becoming a working group document
please respond to this poll with "yes/support"

If you do not support the document becoming a working group
document please respond to this poll with "no/do not support"
and at the same time give the technical reasons why you are
not supporting the document.

If you have technical comments or in any other way want to
discuss the document, please send these comments to the mpls
working group mailing list, but with another subject than what
is on this mail.

The poll ends May 8th.

/Loa
-- 

Loa Andersson                         email: [email-masked]
Sr Strategy and Standards Manager            [email-masked]
Ericsson Inc                          phone: +46 10 717 52 13
                                              +46 767 72 92 13

---

From: "Eric Osborne (eosborne)" <[email-masked]>
Date: Fri, 22 Apr 2011 08:17:56 -0500

yes/support

eric

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Loa Andersson
> Sent: Friday, April 22, 2011 8:11 AM
> To: [email-masked]
> Cc: Ross Callon
> Subject: [mpls] poll on draft-asati-pignataro-mpls-ldp-iana
> 
> Working Group,
> 
> If you support the document becoming a working group document please
> respond to this poll with "yes/support"
> 
> If you do not support the document becoming a working group document
> please respond to this poll with "no/do not support"
> and at the same time give the technical reasons why you are not
supporting
> the document.
> 
> If you have technical comments or in any other way want to discuss the
> document, please send these comments to the mpls working group mailing
> list, but with another subject than what is on this mail.
> 
> The poll ends May 8th.
> 
> /Loa
> --
> 
> 
> Loa Andersson                         email:
[email-masked]
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

---

From: Thomas Nadeau <[email-masked]>
Date: Fri, 22 Apr 2011 09:26:55 -0400

Support.

---

From: "Mallette, Edwin" <[email-masked]>
Date: Fri, 22 Apr 2011 09:33:39 -0400

Yes/support.

>working group mailing list, but with another subject than what

CONFIDENTIALITY NOTICE: This e-mail may contain information that is privileged, confidential or otherwise protected from disclosure. If you are not the intended recipient of this e-mail, please notify the sender immediately by return e-mail, purge it and do not disseminate or copy it.

---

From: Jeff Tantsura <[email-masked]>
Date: Mon, 25 Apr 2011 03:29:54 -0400

Yes/support

Regards,
Jeff  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Loa Andersson
Sent: Friday, April 22, 2011 05:11
To: [email-masked]
Cc: Ross Callon
Subject: [mpls] poll on draft-asati-pignataro-mpls-ldp-iana

Working Group,

The poll ends May 8th.

/Loa
--

---

From: [email-masked]
Date: Mon, 25 Apr 2011 16:08:21 +0800

Yes/Support.

- Xiao Min

Loa Andersson <[email-masked]> 
发件人:  [email-masked]
2011/04/22 20:11

收件人
"[email-masked]" <[email-masked]>
抄送
Ross Callon <[email-masked]>
主题
[mpls] poll on draft-asati-pignataro-mpls-ldp-iana

Working Group,

The poll ends May 8th.

/Loa
--

---

From: Giles Heron <[email-masked]>
Date: Tue, 26 Apr 2011 14:45:55 +0100

support

---

From: Autumn Liu <[email-masked]>
Date: Tue, 26 Apr 2011 20:22:23 -0400

Support

-Autumn

> supporting the document.

---

From: Daniele Ceccarelli <[email-masked]>
Date: Wed, 27 Apr 2011 09:00:20 +0200

Yes/Support

BR
Daniele

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: lunedì 25 aprile 2011 10.08
To: Loa Andersson
Cc: Ross Callon; [email-masked]; [email-masked]
Subject: Re: [mpls] poll on draft-asati-pignataro-mpls-ldp-iana

Yes/Support.

- Xiao Min

2011/04/22 20:11

收件人

Working Group,

The poll ends May 8th.

/Loa
--

---

From: Yaakov Stein <[email-masked]>
Date: Wed, 27 Apr 2011 12:59:32 +0000

While I agree in principle that IANA needs well-defined policies,
do we really need an RFC saying that unallocated bits are to be allocated via "IETF Review".

Perhaps an IESG clarification statement would suffice. 
... and if not, why only the ATM Label TLV, FR Label TLV, ... ?

I am sure that there are plenty of underspecified IANA registries.
Are we going to issue RFCs for every underspecified field in every registry ?
It would seem that an IAB document giving guidelines for all such cases
would be a much more efficient route.

Y(J)S

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Loa Andersson
Sent: Friday, April 22, 2011 15:11
To: [email-masked]
Cc: Ross Callon
Subject: [mpls] poll on draft-asati-pignataro-mpls-ldp-iana

Working Group,

The poll ends May 8th.

/Loa
--

---

From: Carlos Pignataro <[email-masked]>
Date: Wed, 27 Apr 2011 09:56:15 -0400

Hi Yaakov,

Please see inline.

On 4/27/2011 8:59 AM, Yaakov Stein wrote:

> While I agree in principle that IANA needs well-defined policies,

This is not a theoretical principle-driven exercise, but a practical
one, as draft-asati-pignataro-mpls-ldp-gtsm [1] [2] needs to allocate a
bit (for GTSM negotiation) for which there is no allocation policies.

> do we really need an RFC 

This is what RFC 5226 specifies. Most allocation policies for LDP are
included already in RFC 5036 [the why need an RFC applies here too],
just not the one we now need.

> saying that unallocated bits are to be allocated via "IETF Review".

"IETF Review" is the new name for "IETF Consensus", which is the
Well-Known IANA policy used in RFC 5036, and hence we think the most
direct path forward.

> Perhaps an IESG clarification statement would suffice. 

I apologize I do not understand this. But IETF Review includes WG
Review, IESG Review, etc.

> ... and if not, why only the ATM Label TLV, FR Label TLV, ... ?

We only need, right now, bits in the Common Hello Parameters TLV. But
since we are undertaking this work, we chose to comb through RFC 5036
and include all number spaces with undefined policies.

> Are we going to issue RFCs for every underspecified field in every registry ?

I hope not -- personally, I am inclusive of all number spaces when
writing a protocol RFC. However, when something was not specified at the
time, I think that a need-basis is the right approach.

> would be a much more efficient route.

I also do not parse this -- but RFC 5226 is what gives guidelines
currently, and beyond guidelines we need the actual doc to define how to
allocate the bit we are after.

Hope these responses clarify.

Thanks,

-- Carlos.

[1]
<http://tools.ietf.org/html/draft-asati-pignataro-mpls-ldp-gtsm-01#section-2.1>

[2]
<http://tools.ietf.org/html/draft-asati-pignataro-mpls-ldp-gtsm-01#section-3>

---

From: Yaakov Stein <[email-masked]>
Date: Thu, 28 Apr 2011 07:52:51 +0000

based on Carlos' answers, I change my position to "support".

Y(J)S

-----Original Message-----
From: Carlos Pignataro [mailto:[email-masked]] 
Sent: Wednesday, April 27, 2011 16:56
To: Yaakov Stein
Cc: Loa Andersson; [email-masked]; Ross Callon
Subject: Re: [mpls] poll on draft-asati-pignataro-mpls-ldp-iana

Hi Yaakov,

Please see inline.

Thanks,

-- Carlos.

[1]

[2]