Subject: [mpls] Whether T-LDP is part of the MPLS-TP control plane

From: Mach Chen <[email-masked]>
Date: Fri, 15 Apr 2011 02:35:17 +0000

Hi Luca,

You said T-LDP is not part of the MPLS-TP control plane.

IMHO, this is not right, according to Section 4.4.1 of RFC5921, there is figure about "MPLS-TP layer boundary", it shows that PW belongs to MPLS-TP layer.

In addition, in the abstract of MPLS-TP control plane (http://tools.ietf.org/html/draft-ietf-ccamp-mpls-tp-cp-framework-06), it says:
"...MPLS-TP uses GMPLS as the control plane for MPLS-TP Label Switched Paths (LSPs). MPLS-TP also uses the Pseudowire (PW) control plane for Pseudowires (PWs)..."

Best regards,
Mach

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Luca Martini
> Sent: Friday, April 15, 2011 2:11 AM
> To: Greg Mirsky
> Cc: [email-masked]
> Subject: Re: [PWE3] PWE3 working group poll for
> draft-cao-pwe3-mpls-tp-pw-over-bidir-lsp-02.txt
> 
> On 04/14/11 00:09, Greg Mirsky wrote:
> > Luca,
> > you've asked
> > How would LDP , which is IP based , even run on an MPLS-TP network ?
> > but isn't T-LDP part of MPLS-TP control plane? Control plane assumes
> > IP addressing thus use of T-LDP is plausible.
> >
> No T-LDP is not  part of the MPLS-TP control plane.
> It could be , but i think folks are more leaning toward GMPLS instead.
> 
> Note that the problem described in this document exists for MPLS. So in
> that case LDP is certainly used. But the document appears to only care
> about MPLS-TP.
> 
> Luca
> 
> 
> 
> > Regards,
> > Greg
> >

---

From: Alexander Vainshtein <[email-masked]>
Date: Fri, 15 Apr 2011 07:45:10 +0300

Mach, Luca, Greg and all,
I concur with Mach on this point.

Regards,
     Sasha

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Mach Chen [[email-masked]]
Sent: Friday, April 15, 2011 5:35 AM
To: Luca Martini; Greg Mirsky
Cc: [email-masked]; [email-masked]
Subject: [PWE3] Whether T-LDP is part of the MPLS-TP control plane

Hi Luca,

Best regards,
Mach

> that case LDP is certainly used. But the document appears to only care
_______________________________________________
pwe3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pwe3

This e-mail message is intended for the recipient only and contains information which is CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this transmission in error, please inform us by e-mail, phone or fax, and then delete the original and all copies thereof.

---

From: <[email-masked]>
Date: Fri, 15 Apr 2011 08:12:59 +0100

Luca is actually correct in that PWs are NOT part of the MPLS-TP CP.  This follows from the simple (obvious?) observation that MS PWs represent a different layer network to MPLS-TP.  The fact PWs should not exist in MPLS-TP is a different issue...but given they do then their functional layer network specification has to be addressed.

Aside=> I asked Stewart (Bryant) many months ago on a call (in the early ITU/IETF discussion days) as to why we don't simply use the same GMPLS-based signalling protocol for setting up PW connections as we do for MPLS-TP connections, ie why reinvent the wheel?  I also had a secondary point that the PW layer CP/MP also needs to be logically OOB like the MPLS-TP CP/MP.  I was told for the 1st point that it was because RSVP-TE does not support the specific type of addressing that PWs use.  [Note that access point addressing is probably THE most definitive component of defining a layer network and one has to take great care with it.  Get it wrong or do it badly at the outset (I can think of some examples ;-)) and it is very hard to change later.]  Wrt to the 2nd point Stewart had already realised there was also an OOB issue for the PW layer network CP/MP, but had no answer at that time.

regards, Neil

This email contains BT information, which may be privileged or confidential.
It's meant only for the individual(s) or entity named above. If you're not the intended
recipient, note that disclosing, copying, distributing or using this information
is prohibited. If you've received this email in error, please let me know immediately
on the email address above. Thank you.
We monitor our email system, and may record your emails.
British Telecommunications plc
Registered office: 81 Newgate Street London EC1A 7AJ
Registered in England no: 1800000

> Alexander Vainshtein
> Sent: 15 April 2011 05:45
> To: Mach Chen; Luca Martini; Greg Mirsky
> Subject: Re: [PWE3] Whether T-LDP is part of the MPLS-TP control plane
> 
> IMHO, this is not right, according to Section 4.4.1 of RFC5921, there
> is figure about "MPLS-TP layer boundary", it shows that PW belongs to
> MPLS-TP layer.
> 
> In addition, in the abstract of MPLS-TP control plane
> (http://tools.ietf.org/html/draft-ietf-ccamp-mpls-tp-cp-framework-06),
> it says:
> "...MPLS-TP uses GMPLS as the control plane for MPLS-TP Label Switched
> Paths (LSPs). MPLS-TP also uses the Pseudowire (PW) control plane for
> Pseudowires (PWs)..."
> 
> Best regards,
> Mach
> 
> This e-mail message is intended for the recipient only and contains
> information which is CONFIDENTIAL and which may be proprietary to ECI
> Telecom. If you have received this transmission in error, please inform
> us by e-mail, phone or fax, and then delete the original and all copies
> thereof.
>

---

From: Luca Martini <[email-masked]>
Date: Wed, 20 Apr 2011 16:18:27 -0600

> "...MPLS-TP uses GMPLS as the control plane for MPLS-TP Label Switched Paths (LSPs). MPLS-TP also uses the Pseudowire (PW) control plane for Pseudowires (PWs)..."
Mach,
The point is not about running LDP over an MPLS-TP LSP. Today you simply
cannot control or provision an MPLS-TP LSP using LDP. You can Provision
a PW using LDP, but not an MPLS-TP LSP.

There are several ways to run LDP over an MPLS -TP LSP, as well, but I
cannot find an explicit indication of a standard way.

In any case the problem you are proposing is not specific to MPLS-TP, so
solution must be general enough to apply to MPLS.

Luca

---

From: Mach Chen <[email-masked]>
Date: Thu, 21 Apr 2011 02:18:17 +0000

Hi Luca,

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Luca Martini
> Sent: Thursday, April 21, 2011 6:18 AM
> To: Mach Chen
> Cc: [email-masked]; [email-masked]
> Subject: Re: [mpls] Whether T-LDP is part of the MPLS-TP control plane
> 
> 
> > IMHO, this is not right, according to Section 4.4.1 of RFC5921, there is figure
> about "MPLS-TP layer boundary", it shows that PW belongs to MPLS-TP layer.
> >
> (http://tools.ietf.org/html/draft-ietf-ccamp-mpls-tp-cp-framework-06), it says:

But noting that we are talking about whether LDP is "PART" of the MPLS-TP control plane :-)

> solution must be general enough to apply to MPLS.

Agree!

Best regards,
Mach

> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls