Subject: [mpls] Question about MEG numbers for an associated bi-directional LSP

From: Mach Chen <[email-masked]>
Date: Wed, 13 Apr 2011 07:20:52 +0000

Hi,

In Section 3.1. of "http://tools.ietf.org/html/draft-ietf-mpls-tp-oam-framework-11", it says:

"An MPLS-TP Maintenance Entity Group may be defined to monitor the transport path for fault and/or performance management."

and 

"In case of associated bi-directional point-to-point transport paths, two independent unidirectional Maintenance Entities are defined to independently monitor each direction. This has implications for transactions that terminate at or query a MIP, as a return path from MIP to originating MEP does not necessarily exist in the MEG."

Could someone clarify that how many MEGs should be there for an associated bidirectional LSP?

Many thanks,
Mach

---

From: Greg Mirsky <[email-masked]>
Date: Wed, 13 Apr 2011 10:12:30 -0700

Hi Mach,
I'll offer my opinion.
If bi-directional associated LSP is monitored in coordinated fashion, then
one MEG exists.
If bi-directional associated LSP is monitored in independent fashion - two
MEGs defined.

Regards,
Greg

On Wed, Apr 13, 2011 at 12:20 AM, Mach Chen <[email-masked]> wrote:

> Hi,
>
> In Section 3.1. of "
> http://tools.ietf.org/html/draft-ietf-mpls-tp-oam-framework-11", it says:
>
> "An MPLS-TP Maintenance Entity Group may be defined to monitor the
> transport path for fault and/or performance management."
>
> and
>
> "In case of associated bi-directional point-to-point transport paths, two
> independent unidirectional Maintenance Entities are defined to independently
> monitor each direction. This has implications for transactions that
> terminate at or query a MIP, as a return path from MIP to originating MEP
> does not necessarily exist in the MEG."
>
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>

---

From: Sam Aldrin <[email-masked]>
Date: Wed, 13 Apr 2011 10:40:53 -0700

Mach,

IMHO, If the associated bi-dir lsp's are monitored in a coordinated fashion, then one MEG ID is required. Else two MEG ID's are needed, in order to monitor them independently.

Cheers
Sam

Sent from my iPad

---

From: Mach Chen <[email-masked]>
Date: Thu, 14 Apr 2011 01:34:50 +0000

Thanks Greg and Sam,

So, from the view of implementation, does it mean that both ways should be supported?

Best regards,
Mach

From: Greg Mirsky [mailto:[email-masked]]
Sent: Thursday, April 14, 2011 1:12 AM
To: Mach Chen
Cc: [email-masked]
Subject: Re: [mpls] Question about MEG numbers for an associated bi-directional LSP

Hi Mach,
I'll offer my opinion.
If bi-directional associated LSP is monitored in coordinated fashion, then one MEG exists.
If bi-directional associated LSP is monitored in independent fashion - two MEGs defined.

Regards,
Greg
On Wed, Apr 13, 2011 at 12:20 AM, Mach Chen <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

and

Many thanks,
Mach

_______________________________________________
mpls mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mpls

---

From: Sam Aldrin <[email-masked]>
Date: Wed, 13 Apr 2011 19:07:49 -0700

Mach,

Yes.

Sam

Sent from my iPhone