Subject: Re: [mpls] Generic Connection Admission Control (GCAC) Algorithm Specification for IP/MPLS Networks

From: "Azinger, Marla" <[email-masked]>
Date: Wed, 1 Jun 2011 11:38:26 -0400

Jerry-

Did you get a response from anyone on this yet?

Cheers
Marla

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Gerald Ash
Sent: Thursday, May 26, 2011 9:51 AM
To: [email-masked]
Cc: [email-masked]
Subject: Generic Connection Admission Control (GCAC) Algorithm Specification for IP/MPLS Networks

Hi,

Adrian has suggested that the RTGWG and the MPLS WG review the draft "Generic Connection Admission Control (GCAC) Algorithm Specification for IP/MPLS Networks", available at  http://www.ietf.org/id/draft-ash-gcac-algorithm-spec-00.txt (abstract below).
The underlying goal of the work is to specify an optional GCAC algorithm for IP/MPLS networks, to be adopted and implemented by vendors and service providers, that interoperates between vendor equipment and across multiple service provider domains.  This would be analogous to the PNNI GCAC that was widely adopted and helped promote interoperability of ATM networks.  In addition, the approach:
o is based on CSPF, widely implemented by vendors
o does NOT include aspects of CAC that might be considered vendor proprietary implementations, such as detailed path selection mechanisms
o relies on available standard mechanisms for MPLS based networks, such as RSVP, DSTE, PCE...

Comments appreciated.

Thanks,
Jerry

From: [email-masked]
To: [email-masked]
Reply-to: [email-masked]
Subject: I-D ACTION:draft-ash-gcac-algorithm-spec-00.txt
X-RSN: 1/0/935/34473/37870

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

Title : Generic Connection Admission Control (GCAC) Algorithm Specification for IP/MPLS Networks
Author(s) : G. Ash, D. McDysan
Filename : draft-ash-gcac-algorithm-spec-00.txt
Pages : 23
Date : 2011-1-11

This document presents a generic connection admission control (GCAC)
reference model and algorithm for IP/MPLS-based networks. Service
provider (SP) IP/MPLS networks need an MPLS GCAC mechanism, for
example, to reject voice over Internet Protocol (VoIP) calls when
additional calls would adversely affect calls already in progress.

Without MPLS GCAC, connections on congested links will suffer
degraded quality. The MPLS GCAC algorithm can be optionally
implemented in vendor equipment and deployed by service providers.
MPLS GCAC interoperates between vendor equipment and across multiple
service provider domains. The MPLS GCAC algorithm uses available
standard mechanisms for MPLS based networks, such as RSVP, DSTE, PCE,
NSIS, DiffServ, and OSPF. The MPLS GCAC algorithm does not include
aspects of CAC that might be considered vendor proprietary
implementations, such as detailed path selection mechanisms. MPLS
GCAC functions are implemented in a distributed manner to deliver the
objective QoS for specified QoS constraints. The source is able to
compute a source route with high likelihood that MPLS GCAC via
elements along the selected path will in fact admit the request.
MPLS GCAC is applicable to any service or flow that must meet an
objective QoS (delay, jitter, packet loss rate) for a specified
quantity of traffic.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ash-gcac-algorithm-spec-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

*****
Click below to download the attachment(s) in this message:
<A HREF="http://www.ietf.org/ibin/c5i?mid=6&gid=0&rid=8&k1=935&file=i-d-announce.37870.1.txt">Attachment: draft_ash_gcac_algorithm_spec_00.txt</A> (1K)

________________________________
This communication is confidential. Frontier only sends and receives email on the basis of the terms set out at http://www.frontier.com/email_disclaimer.

---

From: Gerald Ash <[email-masked]>
Date: Mon, 6 Jun 2011 12:14:39 -0700 (PDT)

Hi Marla,
 
Thanks for your email.  Please see responses below.

Regards,
Jerry

> 
> 
> --- On Wed, 6/1/11, Azinger, Marla <[email-masked]> wrote:
> 
> 
>  From: Azinger, Marla <[email-masked]>
>  Subject: RE: Generic Connection Admission Control (GCAC) Algorithm 
> Specification for IP/MPLS Networks
>  To: "Gerald Ash" <[email-masked]>, "[email-masked]" <[email-masked]>
>  Cc: "[email-masked]" <[email-masked]>
>  Date: Wednesday, June 1, 2011, 11:38 AM
> 
> 
>  Jerry-
> 
 
I got one off-line comment 
"this work looks good to me and seems somewhat over due..."
 
Given all the experts on this topic in the MPLS WG & RTGWG, it's a bit surprising there hasn't been more response.  Not that long ago this topic would probably have generated strong reaction.

> 
>  Cheers
>  Marla
> 
> 
> 
> ------------------------------------------------------------------------------
>        Adrian has suggested that the RTGWG and the MPLS WG review the draft 
> "Generic Connection Admission Control (GCAC) Algorithm Specification for 
> IP/MPLS Networks", available at 
> http://www.ietf.org/id/draft-ash-gcac-algorithm-spec-00.txt (abstract 
> below).
> 
>        The underlying goal of the work is to specify an optional GCAC 
> algorithm for IP/MPLS networks, to be adopted and implemented by vendors and 
> service providers, that interoperates between vendor equipment and across 
> multiple service provider domains.  This would be analogous to the PNNI GCAC 
> that was widely adopted and helped promote interoperability of ATM networks. 
> In addition, the approach:
>        o does NOT include aspects of CAC that might be considered vendor 
> proprietary implementations, such as detailed path selection mechanisms
>        <A 
> HREF="http://www.ietf.org/ibin/c5i?mid=6&gid=0&rid=8&k1=935&file=i-d-announce.37870.1.txt">Attachment: 
> draft_ash_gcac_algorithm_spec_00.txt</A> (1K)
> 
>