Subject: [mpls] I-D Action: draft-ietf-mpls-tp-itu-t-identifiers-02.txt

From: [email-masked]
Date: Mon, 31 Oct 2011 03:31:45 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Multiprotocol Label Switching Working Group of the IETF.

	Title           : MPLS-TP Identifiers Following ITU-T Conventions
	Author(s)       : Rolf Winter
                          Eric Gray
                          Huub van Helvoort
                          Malcolm Betts
	Filename        : draft-ietf-mpls-tp-itu-t-identifiers-02.txt
	Pages           : 7
	Date            : 2011-10-31

   This document specifies an extension to the identifiers to be used in
   the Transport Profile of Multiprotocol Label Switching (MPLS-TP).
   Identifiers that follow IP/MPLS conventions have already been
   defined.  This memo augments that set of identifiers for MPLS-TP
   management and OAM functions to include identifier information in a
   format typically used by the ITU-T.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-mpls-tp-itu-t-identifiers-02.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-mpls-tp-itu-t-identifiers-02.txt

---

From: "Weingarten, Yaacov (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Mon, 31 Oct 2011 13:47:24 +0100

Hi

Question for my clarification about the MEG-ID format:  

When defining the MEG-ID the draft states - "followed by a Unique MEG ID
Code (UMC) as defined in [Y.1731_cor1]" 

The Corrigendum does not specify what the character set that is used for
the UMC is.  Could you please clarify what is the character set that is
used for the UMC?

Assuming a ICC of 6 characters - what is the maximum number of MEG-IDs
supported by this format (dependent upon the character set)?

Thank you,
yaacov

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
ext [email-masked]
Sent: Monday, October 31, 2011 12:32 PM
To: [email-masked]
Cc: [email-masked]
Subject: [mpls] I-D Action: draft-ietf-mpls-tp-itu-t-identifiers-02.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories. This draft is a work item of the Multiprotocol Label
Switching Working Group of the IETF.

	Title           : MPLS-TP Identifiers Following ITU-T
Conventions
	Author(s)       : Rolf Winter
                          Eric Gray
                          Huub van Helvoort
                          Malcolm Betts
	Filename        : draft-ietf-mpls-tp-itu-t-identifiers-02.txt
	Pages           : 7
	Date            : 2011-10-31

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-mpls-tp-itu-t-identifiers
-02.txt

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-mpls-tp-itu-t-identifiers-
02.txt
_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls

---

From: Huub van Helvoort <[email-masked]>
Date: Mon, 31 Oct 2011 14:59:39 +0100

Yaacov, hi

You wondered:

> When defining the MEG-ID the draft states - "followed by a
 > Unique MEG ID Code (UMC) as defined in [Y.1731_cor1]"
>
> The Corrigendum does not specify what the character set that
 > is used for the UMC is.  Could you please clarify what is the
 > character set that is used for the UMC?

The Corrigendum contains the following text:

"A.2 Global MEG ID format based on CC and ICC
Figure A-4 shows the format that uses the ITU Carrier Code (ICC)
with Country Code (CC). The MEG ID Value is identified by Type 33
and consists of 15 characters coded according to [ITU  T.50]."

and:

"The UMC code immediately follows the ICC and shall consist of
7-12 characters, with trailing NULLs, completing the 15-character
MEG ID Value."

So the UMC is part of the MEG ID which consists of 15 T.50 coded
characters.
T.50 describes a set of 128 characters (i.e. 7 bits per character)

> Assuming a ICC of 6 characters - what is the maximum number of
 > MEG-IDs supported by this format (dependent upon the character
 > set)?

In figure A-5 of the corrigendum you have seen that in case of a
6 character ICC the UMC consists of up to 7 characters.
The maximum number is then 7 characters of 7 bits = 2^49 MEG-IDs
per service provider.

> Thank you,

You're welcome, Huub.

---

From: "Kyung-Yeop Hong (hongk)" <[email-masked]>
Date: Mon, 31 Oct 2011 09:50:37 -0500

per service provider.

Y.1731 is using either an alphabetic (A-Z) or numeric (0-9) for MEG IDs
as per M.1400, and thus you have 36 states per character. 
So the maximum number is 36^7, not 2^49.

KY

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Huub van Helvoort
Sent: Monday, October 31, 2011 10:00 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [mpls] Question for clarification
ondraft-ietf-mpls-tp-itu-t-identifiers-02.txt

Yaacov, hi

and:

You're welcome, Huub.

---

From: Huub van Helvoort <[email-masked]>
Date: Mon, 31 Oct 2011 16:28:13 +0100

Hello KY,

> So the maximum number is 36^7, not 2^49.

The alphabetic/numeric is for CC and ICC.
Y.1731 states: "The UMC shall be a matter for the organization to
which the ICC has been assigned, provided that uniqueness is guaranteed"

Even in case the SP follows M.1400 36^7 is still a large number.
A single SP can assign 11 MEG_IDs to every human living on our planet.

https://www.census.gov/population/popclockworld.html

Best reagrds, Huub.

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 31 Oct 2011 16:32:54 +0000

>> The maximum number is then 7 characters of 7 bits = 2^49 MEG-IDs

Yes, but the Ethernet people will tell you that a lot a grains of sand
will be feeling cut off from the net ;)

Stewart