Subject: [mpls] Comments to draft-ietf-mpls-lsp-ping-ttl-tlv-01

From: Gregory Mirsky <[email-masked]>
Date: Thu, 10 Nov 2011 12:53:37 -0500

Dear Authors, et al.,
Please find my comments to draft-ietf-mpls-lsp-ping-ttl-tlv-01 below:
*       Introduction considers scenario when an intermediate S-PE originates LSP Ping and may address an S-PE. Is that valid scenario for on-demand OAM? If S-PE can generate OAM message, can LSR generate it too? AFAIK, SPME must be used for Segment LSP OAM but the document assumes that for MS-PW S-PE may generate LSP Ping addressed to another S- or T-PE.
*       Perhaps TTL is not the best method to be used in S-PE to S-PE OAM (LSP Ping). I think that Sender's MIP ID can be used to determine correct TTL value for LSP Echo Reply.

        Regards,
                Greg

---

From: binny jeshan <[email-masked]>
Date: Fri, 11 Nov 2011 09:48:29 +0530

I second Greg to his first point, with some understanding i have about the
roles of maintenance points in OAM. Ideally for a MSPW case, having two
MEPs at the ends of the MSPW, and MIPs at the intermediate stitching
locations could possibly be easily maintainable. In such a architecture,
MIPs are expected to respond to requests addressed to it (or likely when it
needs to process a OAM packet) and its not expected to 'originate' a
packet. http://tools.ietf.org/html/draft-ietf-mpls-tp-oam-framework-11

IMHO, Segments should be monitored independently, and MEPs at the end of
such segments (those are the LSRs in a MSPW)  can originate this LSP Ping..

Please correct in case i missed anything.

Regards,
Binny J

On 10 November 2011 23:23, Gregory Mirsky <[email-masked]>wrote:

> •       Introduction considers scenario when an intermediate S-PE
> originates LSP Ping and may address an S-PE. Is that valid scenario for
> on-demand OAM? If S-PE can generate OAM message, can LSR generate it too?
> AFAIK, SPME must be used for Segment LSP OAM but the document assumes that
> for MS-PW S-PE may generate LSP Ping addressed to another S- or T-PE.
> •       Perhaps TTL is not the best method to be used in S-PE to S-PE OAM
> (LSP Ping). I think that Sender’s MIP ID can be used to determine correct
> TTL value for LSP Echo Reply.
>
>         Regards,
>                 Greg
>
>
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3
>
>

---

From: Sam Aldrin <[email-masked]>
Date: Thu, 10 Nov 2011 23:57:36 -0800

Greg,

See inline for my comments
On Nov 10, 2011, at 9:53 AM, Gregory Mirsky wrote:

> •       Introduction considers scenario when an intermediate S-PE originates LSP Ping and may address an S-PE. Is that valid scenario for on-demand OAM?
%SAM - Yes. We do that already. For ex: interAS optionB.
> If S-PE can generate OAM message, can LSR generate it too?
%SAM- If it can, why not? But in the case of LSR, it doesn't have info of PW's.
> AFAIK, SPME must be used for Segment LSP OAM but the document assumes that for MS-PW S-PE may generate LSP Ping addressed to another S- or T-PE.
> •       Perhaps TTL is not the best method to be used in S-PE to S-PE OAM (LSP Ping). I think that Sender’s MIP ID can be used to determine correct TTL value for LSP Echo Reply.
%SAM - It doesn't work in non-TP cases, where MIP ID doesn't exist. This draft do not just address TP networks.

HTH.
-sam

---

From: Sam Aldrin <[email-masked]>
Date: Fri, 11 Nov 2011 00:04:01 -0800

See inline for my comments.
On Nov 10, 2011, at 8:18 PM, binny jeshan wrote:

> I second Greg to his first point, with some understanding i have about the roles of maintenance points in OAM. Ideally for a MSPW case, having two MEPs at the ends of the MSPW, and MIPs at the intermediate stitching locations could possibly be easily maintainable.
%SAM - Not necessarily true. One would want to perform OAM operations between SPE's itself. There is no restriction to do that.
> In such a architecture, MIPs are expected to respond to requests addressed to it (or likely when it needs to process a OAM packet) and its not expected to 'originate' a packet. http://tools.ietf.org/html/draft-ietf-mpls-tp-oam-framework-11
%SAM - This draft is not just for TP networks.

-sam
> 
> IMHO, Segments should be monitored independently, and MEPs at the end of such segments (those are the LSRs in a MSPW)  can originate this LSP Ping..
> 
> On 10 November 2011 23:23, Gregory Mirsky <[email-masked]> wrote:
> Dear Authors, et al.,
> •       Introduction considers scenario when an intermediate S-PE originates LSP Ping and may address an S-PE. Is that valid scenario for on-demand OAM? If S-PE can generate OAM message, can LSR generate it too? AFAIK, SPME must be used for Segment LSP OAM but the document assumes that for MS-PW S-PE may generate LSP Ping addressed to another S- or T-PE.

---

From: Gregory Mirsky <[email-masked]>
Date: Sun, 13 Nov 2011 17:49:30 -0500

Dear Sam,
apologies for delayed response. Please find my notes in-lined tagged GIM>>

    Regards,
        Greg

________________________________
From: Sam Aldrin [mailto:[email-masked]]
Sent: Thursday, November 10, 2011 11:58 PM
To: Gregory Mirsky
Cc: [email-masked]; [email-masked]; George Swallow; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: Comments to draft-ietf-mpls-lsp-ping-ttl-tlv-01

Greg,

Dear Authors, et al.,
Please find my comments to draft-ietf-mpls-lsp-ping-ttl-tlv-01 below:
*       Introduction considers scenario when an intermediate S-PE originates LSP Ping and may address an S-PE. Is that valid scenario for on-demand OAM?
%SAM - Yes. We do that already. For ex: interAS optionB.
GIM>> AFAIK, MIP is not to originate OAM packets but only to reply. An S-PE is a MIP in MS-PW and thus ismy question. SPME removes such restriction for an LSR but I don't know if itcan beremoved for an S-PE.
If S-PE can generate OAM message, can LSR generate it too?
%SAM- If it can, why not? But in the case of LSR, it doesn't have info of PW's.
GIM>> Because of restriction on MIP generating OAM packets that isimposed in MPLS-TP.
AFAIK, SPME must be used for Segment LSP OAM but the document assumes that for MS-PW S-PE may generate LSP Ping addressed to another S- or T-PE.
*       Perhaps TTL is not the best method to be used in S-PE to S-PE OAM (LSP Ping). I think that Sender's MIP ID can be used to determine correct TTL value for LSP Echo Reply.
%SAM - It doesn't work in non-TP cases, where MIP ID doesn't exist.
GIM>> I believe that MIP does exist in non-MPLS-TP PSN.

  This draft do not just address TP networks.
G IM>> I didn't find this being explicitly stated.
HTH.
-sam

        Regards,
                Greg

---

From: Sami Boutros <[email-masked]>
Date: Sun, 13 Nov 2011 15:45:45 -0800

At 02:49 PM 11/13/2011, Gregory Mirsky wrote:
>----------
>Cc: [email-masked]; [email-masked]; George 
>Swallow; [email-masked]; 
>[email-masked]; [email-masked]; [email-masked]
>>•       Introduction considers scenario when an 
>>intermediate S-PE originates LSP Ping and may 
>>address an S-PE. Is that valid scenario for on-demand OAM?
>GIM>> AFAIK, MIP is not to originate OAM packets 
>but only to reply. An S-PE is a MIP in MS-PW and 
>thus ismy question. SPME removes such 
>restriction for an LSR but I don't know if itcan beremoved for an S-PE.

Sami: This would be fine to use SPME for MPLS-TP.

>>AFAIK, SPME must be used for Segment LSP OAM 
>>but the document assumes that for MS-PW S-PE 
>>may generate LSP Ping addressed to another S- or T-PE.
>>•       Perhaps TTL is not the best method to 
>>be used in S-PE to S-PE OAM (LSP Ping). I think 
>>that Sender’s MIP ID can be used to determine 
>>correct TTL value for LSP Echo Reply.

Sami: The tool is useful to debug issues on a segment of a multisegment PWs.

>G IM>> I didn't find this being explicitly stated.

Thanks,

Sami

---

From: Sam Aldrin <[email-masked]>
Date: Sun, 13 Nov 2011 18:33:27 -0800

Hi Greg,

Thanks for your reply. Please see my replies inline with %SAM2.

Sent from my iPad

> GIM>> AFAIK, MIP is not to originate OAM packets but only to reply. An S-PE is a MIP in MS-PW and thus ismy question. SPME removes such restriction for an LSR but I don't know if itcan beremoved fo…
%SAM2- AFAIK, MIP not originating OAM packets is applicable for TP networks. SPE originating OAM packet, for ex: lsp ping, was implemented much earlier to the TP OAM framework came into being. Could you point to any reference, why the same restriction is applicable to non TP as well?
> GIM>> Because of restriction on MIP generating OAM packets that isimposed in MPLS-TP. 
%SAM2- what about Non-TP networks?  Having OAM from SPE to SPE/TPE is very useful for debugging.
> G IM>> I didn't find this being explicitly stated.
%Text could be added if needed. My understanding is, unless explicitly mentioned as 'TP', it is applicable for all of MPLS, not just TP. But, point taken.

Sam
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls