Subject: [mpls] Comments of draft-ietf-mpls-return-path-specified-lsp-ping-04

From: Lizhong Jin <[email-masked]>
Date: Mon, 14 Nov 2011 09:36:35 +0800

Hi Mach,
Because of time limited at the session, I need some clarification on the
list.
Both draft-ietf-mpls-return-path-specified-lsp-ping section 3.2 and
draft-ietf-mpls-tp-on-demand-cv-07 section 3.4.1 provide the feature of
"the Responder SHOULD return reverse path FEC information".
What's the difference between the two drafts? It seems they provide the
same feature with different way.

Thank you.
Lizhong

---

From: Mach Chen <[email-masked]>
Date: Mon, 14 Nov 2011 01:57:10 +0000

Hi Lizhong,

Thanks for your comments.

I see the difference is that draft-mpls-return-path-specified-lsp-ping mainly applies to IP/MPLS scenario, and it may be apply to MPLS-TP scenario; and draft-ietf-mpls-tp-on-demand-cv-07 applies to MPLS-TP scenarios.

The return path validation was firstly proposed in draft-mpls-return-path-specified-lsp-ping draft, and it's only one of the fuctions of return-path-specified-lsp-ping.

Best regards,
Mach
________________________________________
发件人: [email-masked] [[email-masked]] 代表 Lizhong Jin [[email-masked]]
发送时间: 2011年11月14日 9:36
到: Mach Chen
Cc: [email-masked]
主题: [mpls] Comments of draft-ietf-mpls-return-path-specified-lsp-ping-04

Hi Mach,
Because of time limited at the session, I need some clarification on the list.
Both draft-ietf-mpls-return-path-specified-lsp-ping section 3.2 and draft-ietf-mpls-tp-on-demand-cv-07 section 3.4.1 provide the feature of "the Responder SHOULD return reverse path FEC information".
What's the difference between the two drafts? It seems they provide the same feature with different way.

Thank you.
Lizhong

---

From: Lizhong Jin <[email-masked]>
Date: Mon, 14 Nov 2011 13:42:40 +0800

Thanks Mach. Then could I understand the two drafts define the same feature
with different way? This really confuses me.

Regards
Lizhong

在 2011年11月14日 上午9:57，Mach Chen <[email-masked]>写道：

> I see the difference is that draft-mpls-return-path-specified-lsp-ping
> mainly applies to IP/MPLS scenario, and it may be apply to MPLS-TP
> scenario; and draft-ietf-mpls-tp-on-demand-cv-07 applies to MPLS-TP
> scenarios.
>
> The return path validation was firstly proposed in
> draft-mpls-return-path-specified-lsp-ping draft, and it's only one of the
> fuctions of return-path-specified-lsp-ping.
>
> Best regards,
> Mach

---

From: Sriganesh Kini <[email-masked]>
Date: Mon, 14 Nov 2011 01:38:38 -0500

Mach

Your draft refers to mpls-TP requirements rfc in problem stmt. Your applicability stmt below doesn't seem inline with that.

- Sri

Sent from my iPad

On Nov 14, 2011, at 9:57 AM, Mach Chen <[email-masked]> wrote:

> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

---

From: Mach Chen <[email-masked]>
Date: Mon, 14 Nov 2011 06:38:01 +0000

Hi Lizhong,

Not accurately, the two drafts define their own fucnions to solve their own issues. Return path validation is just one of the fuctions. In addtion, as I said in the previous email, return-path-specified-lsp-ping draft mainly apply to IP/MPLS network. And the mpls-tp-on-demand-cv draft is designed for MPLS-TP network.

Best regards,
Mach
________________________________________
发件人: Lizhong Jin [[email-masked]]
发送时间: 2011年11月14日 13:42
到: Mach Chen
Cc: [email-masked]
主题: Re: [mpls] Comments of draft-ietf-mpls-return-path-specified-lsp-ping-04

Thanks Mach. Then could I understand the two drafts define the same feature with different way? This really confuses me.

Regards
Lizhong

在 2011年11月14日 上午9:57，Mach Chen <[email-masked]<mailto:[email-masked]>>写道：
Hi Lizhong,

Best regards,
Mach
________________________________________
发件人: [email-masked]<mailto:[email-masked]> [[email-masked]<mailto:[email-masked]>] 代表 Lizhong Jin [[email-masked]<mailto:[email-masked]>]
发送时间: 2011年11月14日 9:36
到: Mach Chen
Cc: [email-masked]<mailto:[email-masked]>
主题: [mpls] Comments of draft-ietf-mpls-return-path-specified-lsp-ping-04

Hi Mach,

Thank you.
Lizhong

---

From: Lizhong Jin <[email-masked]>
Date: Mon, 14 Nov 2011 17:24:29 +0800

Hi Mach,
Accurately saying is:  the two drafts define the same feature of "reponse
should return via reverse path" with different way. I think the WG should
define only one way.
During the meeting, you said, draft-return-path-specified-lsp-ping also
applies to MPLS-TP. The draft should explicitly say whether it is for MPLS
or both MPLS and MPLS-TP.

Thanks
Lizhong

在 2011年11月14日 下午2:38，Mach Chen <[email-masked]>写道：

> Hi Lizhong,
>
> Not accurately, the two drafts define their own fucnions to solve their
> own issues. Return path validation is just one of the fuctions. In addtion,
> as I said in the previous email, return-path-specified-lsp-ping draft
> mainly apply to IP/MPLS network. And the mpls-tp-on-demand-cv draft is
> designed for MPLS-TP network.
>
> Best regards,
> Mach
> 主题: Re: [mpls] Comments of
> draft-ietf-mpls-return-path-specified-lsp-ping-04
>
> Thanks Mach. Then could I understand the two drafts define the same
> feature with different way? This really confuses me.
>
> Regards
> Lizhong
>
> 发件人: [email-masked]<mailto:[email-masked]> [
> [email-masked]<mailto:[email-masked]>] 代表 Lizhong Jin [
> [email-masked]<mailto:[email-masked]>]
> 发送时间: 2011年11月14日 9:36
> 到: Mach Chen

---

From: Mach Chen <[email-masked]>
Date: Mon, 14 Nov 2011 09:38:19 +0000

Sri，

Refer to the MPLS-TP requirement rfc is mainly for referring to the defiinetion of associated bidirectional LSP and IMHO the associated bidirectional LSP should not only belong to MPLS-TP.  Of cause, I am not saying return-path-specified-lsp-ping can not be used for MPLS-TP network. If it is used in MPLS-TP scenario, yes, for the return path validation, the two drafts overlap on the function. But suppose that of the return-path-specified-lsp-ping can apply to more general scenarios while the other cannot, so in some how they may complement each other.

Best regard,
Mach
________________________________________
发件人: Sriganesh Kini [[email-masked]]
发送时间: 2011年11月14日 14:38
到: Mach Chen
Cc: Lizhong Jin; [email-masked]
主题: Re: [mpls] 答复:  Comments of draft-ietf-mpls-return-path-specified-lsp-ping-04

Mach

- Sri

Sent from my iPad

---

From: Mach Chen <[email-masked]>
Date: Mon, 14 Nov 2011 10:02:34 +0000

Lizhong,

As I replied to Sri in the previous email, the overlap is only on the "reverse/return path validation", and they only overlap when the return path is the reverse path of a bidirectional LSP. Other scenarios, e.g., unidirectional LSP, return path is not the reverse path of the bidirectional LSP, the tp-on-demand draft can not be applied any more, because it explicitly requires the echo reply must send along the reverse path of the bidirectional LSP. So, I say they are sometimes complementary. 

Best regard,
Mach
________________________________________
发件人: Lizhong Jin [[email-masked]]
发送时间: 2011年11月14日 17:24
到: Mach Chen
Cc: [email-masked]
主题: Re: 答复: [mpls] Comments of draft-ietf-mpls-return-path-specified-lsp-ping-04

Hi Mach,
Accurately saying is:  the two drafts define the same feature of "reponse should return via reverse path" with different way. I think the WG should define only one way.
During the meeting, you said, draft-return-path-specified-lsp-ping also applies to MPLS-TP. The draft should explicitly say whether it is for MPLS or both MPLS and MPLS-TP.

Thanks
Lizhong

在 2011年11月14日 下午2:38，Mach Chen <[email-masked]<mailto:[email-masked]>>写道：
Hi Lizhong,

Best regards,
Mach
________________________________________
发件人: Lizhong Jin [[email-masked]<mailto:[email-masked]>]
发送时间: 2011年11月14日 13:42
到: Mach Chen
Cc: [email-masked]<mailto:[email-masked]>
主题: Re: [mpls] Comments of draft-ietf-mpls-return-path-specified-lsp-ping-04

Regards
Lizhong

在 2011年11月14日 上午9:57，Mach Chen <[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>>写道：
Hi Lizhong,

Best regards,
Mach
________________________________________
发件人: [email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>> [[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>] 代表 Lizhong Jin [[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>]
发送时间: 2011年11月14日 9:36
到: Mach Chen
Cc: [email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>
主题: [mpls] Comments of draft-ietf-mpls-return-path-specified-lsp-ping-04

Hi Mach,

Thank you.
Lizhong