Subject: [mpls] Comments to draft-ietf-mpls-tp-itu-t-identifiers-02

From: Gregory Mirsky <[email-masked]>
Date: Thu, 10 Nov 2011 14:03:07 -0500

Dear Authors, et al.,
I have a question about the scope of the document. Introduction references only bi-directional LSPs in "RFC 6370 [RFC6370] defines a set of MPLS-TP transport and management entity identifiers to support bidirectional (co-routed and associated) point-to-point MPLS-TP LSPs ..." I think that RFC 6370 implicitly defines ID for p2p unidirectional LSP as well in the following format:
A1-Node_ID::A1-Tunnel_Num::Z9-LSP_Num::Z9-Node_ID
or if globally unique LSP ID required
A1-{Global_ID::Node_ID::Tunnel_Num}::Z9-{Global_ID::Node_ID::Tunnel_Num}::LSP_Num

        Regards,
                Greg

---

From: Eric Gray <[email-masked]>
Date: Fri, 11 Nov 2011 06:31:58 -0500

Greg,

        This draft is only interested in addressing identifiers associated with bi-directional
LSP - at least at present.  RFC 6370 does define identifiers that can be used for this case,
that are based on IP/MPLS conventions.  So the statement is accurate.

        However, we could try to make it clearer that we're not saying that RFC 6370 is
limited to the bi-directional case.  The difficulty lies in trying to make this clearer without
complicating the text with information that is not relevant to this draft.

        For example, if we explicily state that RFC 6370 includes support for IP/MPLS
based identifiers for unidirectional LSPs, we would also need to explicitly state that this
type of identifier either doesn't apply to this dcoument, or is out of scope.  In general, I
don't think it is necessarily a good idea to add text to a document that then makes it
necessary to add additional text to clarify that the previously added text is out of scope
in the document.

        Perhaps you can suggest wording that makes the fact that RFC 6370 does not
limit identifiers to the bi-directional case clearer, without making it necessary to then add
that this document is limited in this respect?

--
Eric
_____________________________________________
From:   Gregory Mirsky
Sent:   Thursday, November 10, 2011 2:03 PM
To:     [email-masked]; Eric Gray; [email-masked]; [email-masked]; [email-masked]
Subject:        Comments to draft-ietf-mpls-tp-itu-t-identifiers-02
Importance:     High

Dear Authors, et al.,

        Regards,
                Greg

---

From: Loa Andersson <[email-masked]>
Date: Sat, 12 Nov 2011 02:30:48 +0900

Eric,

<chair hat off>

throughout the mpls-tp project it has been said that mpls-tp includes
the LSP topology constructs as defined in RFC5654 2.1 General
Requirements.

"7   MPLS-TP MUST support unidirectional, co-routed bidirectional,
      and associated bidirectional point-to-point transport paths."

"8   MPLS-TP MUST support unidirectional point-to-multipoint transport
      paths."

I think that should be the scope of this (mpls-tp) draft also,
alternatively if we make applicable to co-routed bidirectional LSP only,
the reason for this needs to be very clearly stated in the draft.

/Loa

On 2011-11-11 20:31, Eric Gray wrote:
> LSP - at least at present. RFC 6370 *does* define identifiers that can
> be used for this case,
> *From: *Gregory Mirsky
> *Sent: *Thursday, November 10, 2011 2:03 PM
> *To: [email-masked]; Eric Gray; [email-masked];
> [email-masked]; [email-masked]
> *Subject: *Comments to draft-ietf-mpls-tp-itu-t-identifiers-02
> *Importance: *High
> Dear Authors, et al.,
> I have a question about the scope of the document. Introduction
> references only bi-directional LSPs in “RFC 6370 [RFC6370] defines a set
> of MPLS-TP transport and management entity identifiers to support
> bidirectional (co-routed and associated) point-to-point MPLS-TP LSPs …”
> I think that RFC 6370 implicitly defines ID for p2p unidirectional LSP
> as well in the following format:
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

-- 

Loa Andersson                         email: [email-masked]
Sr Strategy and Standards Manager            [email-masked]
Ericsson Inc                          phone: +46 10 717 52 13
                                              +46 767 72 92 13