Subject: [mpls] FW: FW: New Liaison Statement, "LS331 - Corrigendum 1 to Recommendation ITU-T G.8013/Y.1731: Global MEG_ID"

From: Scott Mansfield <[email-masked]>
Date: Sun, 13 Nov 2011 20:52:20 -0500

Greg and Huub,

Looking at the text of liaison, the actual text of the corrigendum 1 is not attached to the liaison.  Currently the document is only available to ITU-T TIES members since the document is still "pre-published".

Can you please provide the document?

Regards,
-scott. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Scott Mansfield
> Sent: Sunday, November 13, 2011 8:36 PM
> To: [email-masked]
> Subject: [mpls] FW: New Liaison Statement, "LS331 - 
> Corrigendum 1 to Recommendation ITU-T G.8013/Y.1731: Global MEG_ID"
> 
> This is the liaison from the ITU-T that includes information 
> about the Global MEG ID.  Uses the Country Code and the ICC 
> to make the MEG ID globally unique.
> 
> Regards,
> -scott. 
> 
> > -----Original Message-----
> > From: Liaison Statement Management Tool [mailto:[email-masked]]
> > Sent: Thursday, October 06, 2011 4:52 PM
> > To: [email-masked]; [email-masked]; [email-masked]
> > Cc: [email-masked];
> > [email-masked]; [email-masked]; [email-masked]; 
> > Scott Mansfield; [email-masked]; [email-masked]; 
> > [email-masked]; [email-masked]
> > Subject: New Liaison Statement, "LS331 - Corrigendum 1 to 
> > Recommendation ITU-T G.8013/Y.1731: Global MEG_ID"
> > 
> > Title: LS331 - Corrigendum 1 to Recommendation ITU-T
> > G.8013/Y.1731: Global MEG_ID Submission Date: 2011-10-06 URL of the 
> > IETF Web page: /liaison/1100/
> > 
> > From: ITU-T SG 15  (Greg Jones <[email-masked]>)
> > To: Multiprotocol Label Switching ([email-masked], 
> > [email-masked], [email-masked])
> > Cc: 
> > [email-masked],[email-masked],mpl
> > [email-masked],[email-masked],[email-masked]
> > Reponse Contact: 
> > [email-masked],[email-masked],[email-masked]
> > Technical Contact: [email-masked]
> > Purpose: For information
> > 
> > Body: The experts of Q10/15 would like to inform you that they have 
> > agreed to a corrigendum for Recommendation ITU-T
> > G.8013/Y.1731 "OAM functions and mechanisms for Ethernet based 
> > networks."
> > This corrigendum provides the definition of a globally 
> unique MEG-ID 
> > by using the Country Code (CC) and ITU-T Carrier Code (ICC).
> > Attach: TD477/PLEN, "Corrigendum 1 to Recommendation ITU-T 
> > G.8013/Y.1731".
> > Attachment(s):
> > 
> >     LS331 - Corrigendum 1 to Recommendation ITU-T
> > G.8013/Y.1731: Global MEG_ID - pdf body 
> > https://datatracker.ietf.org/documents/LIAISON/file1279.pdf
> > 
> > 
> > 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>

---

From: Lou Berger <[email-masked]>
Date: Mon, 14 Nov 2011 10:35:31 +0800

Huub,

As the scope of this document (ITU-T G.8013/Y.1731) is just MEG IDs, I
guess this means that draft-ietf-mpls-tp-itu-t-identifiers will need to
explicitly define how to go from ICC-based MEG IDs to ICC_based
LSPs&Tunnels, right?

Lou

On 11/14/2011 9:52 AM, Scott Mansfield wrote:
> Greg and Huub,
> 
> Looking at the text of liaison, the actual text of the corrigendum 1
> is not attached to the liaison.  Currently the document is only
> available to ITU-T TIES members since the document is still
> "pre-published".
>

---

From: Huub van Helvoort <[email-masked]>
Date: Mon, 14 Nov 2011 04:16:37 +0100

Hello Lou,

> explicitly define how to go from ICC-based MEG IDs to ICC_based

The draft-ietf-mpls-tp-itu-t-identifiers described how the
Global_ID can be based on CC and ICC.
RFC6370 defines how LSPs&Tunnels use the Global_ID to provide
a global unique number.

Regards, huub.

>>>> From: ITU-T SG 15  (Greg Jones<[email-masked]>)

-- 
*****************************************************************
                          我爱外点一七三一

---

From: "Kyung-Yeop Hong (hongk)" <[email-masked]>
Date: Mon, 14 Nov 2011 00:56:51 -0600

In draft-ietf-mpls-tp-itu-t-identifiers:
.....
3.  Use of the ICC_Operator_ID

As an example, an Interface Identifier (IF_ID) in RFC 6370 [RFC6370]
   is specified as the concatenation of the Node_ID (a unique 32-bit
   value assigned by the operator) and the Interface Number (IF_Num, a
   32-bit unsigned integer assigned by the operator that is unique
   within the scope of a Node_ID).  
.....

RFC 6370 defines an IF_ID to be a 64-bit identifier formed by concatenating a 32-bit of Node ID and a 32-bit of IF_Num.

The UMC used in draft-ietf-mpls-tp-itu-t-identifiers has a maximum number of 7 characters of 7 bits.

How can IF_ID be formed with 7 characters of 7 bits?

KY

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Huub van Helvoort
Sent: Sunday, November 13, 2011 10:17 PM
To: Lou Berger
Cc: [email-masked]
Subject: Re: [mpls] FW: FW: New Liaison Statement, "LS331 - Corrigendum 1 to Recommendation ITU-T G.8013/Y.1731: Global MEG_ID"

Hello Lou,

Regards, huub.

---

From: Lou Berger <[email-masked]>
Date: Tue, 15 Nov 2011 09:16:08 +0800

Huub,
	I guess I didn't make my self sufficiently clear.  Let me try again. If
I understood the comments made in the meeting correctly, the
statement made is that the usage of CC:ICC (ICC_GLOBAL_ID) is defined by
the ITU-T and that the liaison referenced by Scott identifies the
reference for this definition.  Is this correct?

Assuming this is correct, the referenced ITU-T document only covers
usage of CC:ICC within the scope of a MEG_ID. So this raises the
question of where is the ITU-T definition for usage of CC:ICC for MPLS
LSPs & tunnels.  I surmised that such a definition does not exist, and
therefor postulated that draft-ietf-mpls-tp-itu-t-identifiers will
provide an LSP/Tunnel definition based on the ITU-T MEG_ID.

So, is this conclusion correct?

Much thanks,
Lou

---

From: Rolf Winter <[email-masked]>
Date: Tue, 15 Nov 2011 02:54:33 +0000

Hi,

the ITU-T ID draft does that this already, although well hidden. That is what I referred to as "formula" during my presentation. At the end of section 3 is says:

"The same substitution procedure applies to all identifiers specified
in RFC 6370 [RFC6370] except for the other alternatives mentioned in
this document."

But as announced, we'll spell this out in the next version of the document. 

Best,

Rolf

NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014 

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Lou Berger
> Sent: Dienstag, 15. November 2011 02:16
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [mpls] FW: FW: New Liaison Statement, "LS331 - Corrigendum
> 1 to Recommendation ITU-T G.8013/Y.1731: Global MEG_ID"
> 
> Huub,
> 	I guess I didn't make my self sufficiently clear.  Let me try
> again. If I understood the comments made in the meeting correctly, the
> statement made is that the usage of CC:ICC (ICC_GLOBAL_ID) is defined
> by the ITU-T and that the liaison referenced by Scott identifies the
> >> As the scope of this document (ITU-T G.8013/Y.1731) is just MEG IDs,
> >> I guess this means that draft-ietf-mpls-tp-itu-t-identifiers will
> >> need to explicitly define how to go from ICC-based MEG IDs to
> >> ICC_based LSPs&Tunnels, right?
> >
> > The draft-ietf-mpls-tp-itu-t-identifiers described how the Global_ID
> > can be based on CC and ICC.
> > RFC6370 defines how LSPs&Tunnels use the Global_ID to provide a
> global
> > unique number.
> >
> > Regards, huub.
> >
> >
> >
> >>>> Subject: [mpls] FW: New Liaison Statement, "LS331 - Corrigendum 1
> >>>> to Recommendation ITU-T G.8013/Y.1731: Global MEG_ID"
> >>>>
> >>>> This is the liaison from the ITU-T that includes information about
> >>>> the Global MEG ID.  Uses the Country Code and the ICC to make the
> >>>> MEG ID globally unique.
> >>>>
> >>>> Regards,
> >>>> -scott.
> >>>>
> >>>>> [email-masked]; [email-masked];
> >>>>> [email-masked]; Scott Mansfield; [email-masked];
> >>>>> [email-masked]; [email-masked]; [email-masked]
> >>>>> G.8013/Y.1731: Global MEG_ID Submission Date: 2011-10-06 URL of
> >>>>> the IETF Web page: /liaison/1100/
> >>>>>
> >>>>> Body: The experts of Q10/15 would like to inform you that they
> >>>>> have agreed to a corrigendum for Recommendation ITU-T