Subject: [mpls] Comments to draft-chen-mpls-p2mp-egress-protection-04

From: Gregory Mirsky <[email-masked]>
Date: Sun, 13 Nov 2011 20:13:28 -0500

Dear Authors, et al.,
Please kindly consider my comments:
*       Section 4.1 Figure 1 I think that presented scenario is scenario more suitable for PWE3 WG
*       Section 4.1 "The backup sub LSP used to protect the primary egress node L1 is from its previous hop node R3 to the backup egress node La." I'd note that there might be situation when R3, as characterized in the document, can not be connected by sub-LSP to the particular node La.
*       Section 4.4 "Destination node" is usually referred as CE in PWE3 Reference model.
*       Section 4.4 I think that OAM (BFD) between CE and "previous hop" is not realistic as it crosses administration domain's border.
*       Section 5. IMO, protection of PE and CE-PE link is outside of scope of the MPLS WG.

        Regards,
                Greg

---

From: Huaimo Chen <[email-masked]>
Date: Tue, 15 Nov 2011 16:05:23 +0000

Hi Greg,

Thanks for your comments!
Please see my answers inline below.

Best Regards,
Huaimo
________________________________
From: Gregory Mirsky [mailto:[email-masked]]
Sent: Sunday, November 13, 2011 8:13 PM
To: Huaimo Chen; [email-masked]; Autumn Liu; [email-masked]
Subject: Comments to draft-chen-mpls-p2mp-egress-protection-04

Dear Authors, et al.,

[[Chen,Huaimo]]
LSP and PW are at different levels. PW is above LSP. Our egress protection provides protection for LSP against egress failures.

An LSP can be used as a transport for a PW; it can also be used as a transport for other traffic. Thus our egress protection for LSP can provide protection for the traffic transported over the LSP, which include PW and other traffic against egress failures.

[[Chen,Huaimo]] If there is not any protection path in the network, what should we do?

[[Chen,Huaimo]]
LSP may cross multiple domains as long as policies allow. LSP with BFD between CE and "previous hop" may be one of approaches as long as polices allow.

[[Chen,Huaimo]]
It seems that Section 5 in your statement above should be Section 4.4 since Section 5 "Egress Local Protection with FRR" does not mention CE-PE link.

Do you mean "protection of CE and CE-PE link is outside of scope of the MPLS WG."? It seems that PE should be CE in your statement.

        Regards,
                Greg

---

From: Gregory Mirsky <[email-masked]>
Date: Tue, 15 Nov 2011 20:27:20 -0500

Dear Huaimo,
thank you for your response and clarifications you've provided. Please find my notes in-lened under GIM>> tag.

    Regards,
        Greg

________________________________
From: Huaimo Chen [mailto:[email-masked]]
Sent: Tuesday, November 15, 2011 8:05 AM
To: Gregory Mirsky
Cc: [email-masked]; Autumn Liu; [email-masked]
Subject: RE: Comments to draft-chen-mpls-p2mp-egress-protection-04

Hi Greg,

Best Regards,
Huaimo

Dear Authors, et al.,

[[Chen,Huaimo]]

 GIM>> As mentioned earlier, it might be IP or MPLS payload over MPLS p2mp tunnel. If former, IMHO, model of CE CE still applies as in l3vpn. If the latter, this is MPLS-TE local protection.

[[Chen,Huaimo]]

GIM>> I'd add that CC/CV monitoring between, e.g. R3 and CE1 makes CC/CV session between R3 and L1 unneccessary.
*       Section 5. IMO, protection of PE and CE-PE link is outside of scope of the MPLS WG.

[[Chen,Huaimo]]

Do you mean "protection of CE and CE-PE link is outside of scope of the MPLS WG."? It seems that PE should be CE in your statement.
GIM>> I think that reference to Section 5 was correct. The egress node is the PE in case of IP payload.

        Regards,
                Greg