Subject: [mpls] MPLS-RT review of draft-rhd-mpls-tp-psc-priority

From: Yaacov Weingarten <[email-masked]>
Date: Thu, 15 Aug 2013 22:39:52 +0300

Hi,

I was requested to conduct an initial review of
draft-rhd-mpls-tp-psc-priority-01 as part of the effort to determine if the
draft is suited for a WG adoption poll. I have read the draft and have the
following notes:

1. I find it rather disconcerting that the draft is referencing a LS that
was received from the ITU. While I am sure that the points rasied in the LS
as very well thought out and pertinent, I cannot see that the LS should be
considered a "standards document" that could be referenced by a future RFC.
At best, the LS could be considered a "contribution" at an ITU meeting, and
I do not believe that an ITU document would reference a contribution! I
therefore think that the authors should transfer into the draft whatever
information they feel is appropriate from said LS.

2. In general, the draft is addressing itself to two topics regarding
RFC6378,
a. Change of relative priority between SF-P and FS - the suggestion is
essentially to rollback the relevant changes that were made to the RFC
during the final IESG review to the version previous to that review.

b. Change of relative priority between ClearSF and SF/SD. This is based on
a particular use-case that is mentioned in the referenced LS, and that I
suggested be explicitly explained in the draft.

c. Introduce (in an appendix) the use of a Freeze command. Not sure what
the motivation for this in this context is.

In my opinion, all three of the points are valid for work by the WG and
should be fully discussed in the WG prior to publication of the draft - but
could be discussed as part of a WG draft.

3. The format of the draft is also rather interesting - it seems to be
presenting an errata note to RFC6378 rather than describing the desired
behavior. I leave it to the WG Chairs to decide what is the best format for
the draft moving forward.

4. One other note regarding this draft in the context of several other
drafts that are proposing changes to the PSC protocol for MPLS-TP Linear
Protection. I think that some of these should be combined into a more
robust proposal for the sake of the implementers. Otherwise, there may be a
need for a future "reader's guide" for an implementer to figure out what is
in PSC and what is no longer there!

Bottom line - I think that this draft presents valid points, it should be
corrected to not reference the ITU LS prior to acceptance as a WG draft.
And the WG should strongly consider consolidating this work with some of
the other drafts to make a more complete and consistent definition of PSC
available.

Hope this helps,

-- 
Thanx and BR,
yaacov

*Still looking for new opportunity*

---

From: 류정동 <[email-masked]>
Date: Wed, 21 Aug 2013 09:01:03 +0000

Yaacov, thank you for providing the comments.

I discussed your comments with the other co-authors of this draft, and the revised draft that has been uploaded just a few minutes ago contains the updates reflecting your comments.
http://www.ietf.org/internet-drafts/draft-rhd-mpls-tp-psc-priority-01.txt

The followings are the resolution of the comments, and incorporated in the new draft:
Comment 1: All the LSs have been removed from the references, and any necessary materials have been transferred into the draft.
Comment 2: The particular example related to the priority level of Clear SF is moved from the LS to the draft. The motivation of Freeze has been explained in the context of priority modification.
Comment 3: This comment was not for the authors of this draft.
Comment 4: I am not sure if you are aware of the result of discussions in the last IETF meeting. There was a general agreement on the need of a new draft to provide a method to integrate all the drafts into PSC in a backward compatible manner and to provide the state machine description when all the features are enabled to satisfy the ITU-T transport requirements. This new draft is now being prepared.

If there is any misunderstanding on your comments or any question on the updates, please let me know.

I appreciate your help and support on this draft.

Best regards,

Jeong-dong

________________________________
From : "Yaacov Weingarten" <[email-masked]>
Sent : 2013-08-16 04:40:34 ( +09:00 )
To : [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
Cc :
Subject : [mpls] MPLS-RT review of draft-rhd-mpls-tp-psc-priority

Hi,

I was requested to conduct an initial review of draft-rhd-mpls-tp-psc-priority-01 as part of the effort to determine if the draft is suited for a WG adoption poll. I have read the draft and have the following notes:

1. I find it rather disconcerting that the draft is referencing a LS that was received from the ITU. While I am sure that the points rasied in the LS as very well thought out and pertinent, I cannot see that the LS should be considered a "standards document" that could be referenced by a future RFC. At best, the LS could be considered a "contribution" at an ITU meeting, and I do not believe that an ITU document would reference a contribution! I therefore think that the authors should transfer into the draft whatever information they feel is appropriate from said LS.

2. In general, the draft is addressing itself to two topics regarding RFC6378,
a. Change of relative priority between SF-P and FS - the suggestion is essentially to rollback the relevant changes that were made to the RFC during the final IESG review to the version previous to that review.

b. Change of relative priority between ClearSF and SF/SD. This is based on a particular use-case that is mentioned in the referenced LS, and that I suggested be explicitly explained in the draft.

c. Introduce (in an appendix) the use of a Freeze command. Not sure what the motivation for this in this context is.

In my opinion, all three of the points are valid for work by the WG and should be fully discussed in the WG prior to publication of the draft - but could be discussed as part of a WG draft.

3. The format of the draft is also rather interesting - it seems to be presenting an errata note to RFC6378 rather than describing the desired behavior. I leave it to the WG Chairs to decide what is the best format for the draft moving forward.

4. One other note regarding this draft in the context of several other drafts that are proposing changes to the PSC protocol for MPLS-TP Linear Protection. I think that some of these should be combined into a more robust proposal for the sake of the implementers. Otherwise, there may be a need for a future "reader's guide" for an implementer to figure out what is in PSC and what is no longer there!

Bottom line - I think that this draft presents valid points, it should be corrected to not reference the ITU LS prior to acceptance as a WG draft. And the WG should strongly consider consolidating this work with some of the other drafts to make a more complete and consistent definition of PSC available.

Hope this helps,

--
Thanx and BR,
yaacov

Still looking for new opportunity

---

From: "Ryoo, Jeong-dong" <[email-masked]>
Date: Wed, 21 Aug 2013 09:53:03 +0000

Loa,

After uploading a new version, I realized that I was not supposed to update the document during the MPLS-RT review period.
Since this particular draft was supposed to expire tomorrow, I needed to upload a new version and just happend to incorporate the comments from Yaacov. Sorry about this.

Best regards,

Jeong-dong

________________________________
From : "Ryoo, Jeong-dong" <[email-masked]>
Sent : 2013-08-21 18:01:03 ( +09:00 )
To : Yaacov Weingarten <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
Cc :
Subject : 회신: [mpls] MPLS-RT review of draft-rhd-mpls-tp-psc-priority

Best regards,

Jeong-dong

Hi,

Hope this helps,

--
Thanx and BR,
yaacov

---

From: Loa Andersson <[email-masked]>
Date: Wed, 21 Aug 2013 12:05:09 +0200

Jeong-dong,

I think this is OK - I'll ask the mpls-rt reviewers to be explicit about
which version of the draft they reviewed.

/Loa

On 2013-08-21 11:53, Ryoo, Jeong-dong wrote:
> Loa,
> After uploading a new version, I realized that I was not supposed to
> update the document during the MPLS-RT review period.
> Since this particular draft was supposed to expire tomorrow, I needed to
> upload a new version and just happend to incorporate the comments from
> Yaacov. Sorry about this.
> Best regards,
> Jeong-dong
>
>
>
> ------------------------------------------------------------------------
> *From : *"Ryoo, Jeong-dong" <[email-masked]>
> *Sent : *2013-08-21 18:01:03 ( +09:00 )
> *To : *Yaacov Weingarten <[email-masked]>, [email-masked] <[email-masked]>,
> [email-masked] <[email-masked]>,
> [email-masked]
> <[email-masked]>,
> [email-masked] <[email-masked]>,
> [email-masked] <[email-masked]>
> *Cc : *
> *Subject : *회신: [mpls] MPLS-RT review of draft-rhd-mpls-tp-psc-priority
>
>
> I discussed your comments with the other co-authors of this draft, and
> the revised draft that has been uploaded just a few minutes ago contains
> the updates reflecting your comments.
>
> Comment 1: All the LSs have been removed from the references, and any
> necessary materials have been transferred into the draft.
>
> Comment 2: The particular example related to the priority level of Clear
> SF is moved from the LS to the draft. The motivation of Freeze has been
> explained in the context of priority modification.
>
> Comment 4: I am not sure if you are aware of the result of discussions
> in the last IETF meeting. There was a general agreement on the need of a
> new draft to provide a method to integrate all the drafts into PSC in a
> backward compatible manner and to provide the state machine description
> when all the features are enabled to satisfy the ITU-T transport
> requirements. This new draft is now being prepared.
>
> ------------------------------------------------------------------------
> *From : *"Yaacov Weingarten" <[email-masked]>
> *Sent : *2013-08-16 04:40:34 ( +09:00 )
> *To : [email-masked] <[email-masked]>, [email-masked] <[email-masked]>,
> [email-masked]
> <[email-masked]>,
> [email-masked] <[email-masked]>,
> [email-masked] <[email-masked]>
> *Cc : *
> *Subject : *[mpls] MPLS-RT review of draft-rhd-mpls-tp-psc-priority
>
> Hi,
> draft-rhd-mpls-tp-psc-priority-01 as part of the effort to determine if
> the draft is suited for a WG adoption poll. I have read the draft and
> have the following notes:
> 1. I find it rather disconcerting that the draft is referencing a LS
> that was received from the ITU. While I am sure that the points rasied
> in the LS as very well thought out and pertinent, I cannot see that the
> LS should be considered a "standards document" that could be referenced
> by a future RFC. At best, the LS could be considered a "contribution" at
> an ITU meeting, and I do not believe that an ITU document would
> reference a contribution! I therefore think that the authors should
> transfer into the draft whatever information they feel is appropriate
> from said LS.
> b. Change of relative priority between ClearSF and SF/SD. This is based
> on a particular use-case that is mentioned in the referenced LS, and
> that I suggested be explicitly explained in the draft.
> should be fully discussed in the WG prior to publication of the draft -
> but could be discussed as part of a WG draft.
> behavior. I leave it to the WG Chairs to decide what is the best format
> for the draft moving forward.
> robust proposal for the sake of the implementers. Otherwise, there may
> be a need for a future "reader's guide" for an implementer to figure out
> what is in PSC and what is no longer there!
> Bottom line - I think that this draft presents valid points, it should
> be corrected to not reference the ITU LS prior to acceptance as a WG
> draft. And the WG should strongly consider consolidating this work with
> some of the other drafts to make a more complete and consistent
> definition of PSC available.
> Hope this helps,
>
> --
> Thanx and BR,
> yaacov
>
> /Still looking for new opportunity/

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64