Subject: Re: [mpls] draft-ietf-mpls-special-purpose-labels-01

From: Kireeti Kompella <[email-masked]>
Date: Sat, 10 Aug 2013 08:34:17 -0700

On Jul 9, 2013, at 05:29 , Alia Atlas <[email-masked]> wrote:

> I think it makes sense and helps clarify the reasoning.  It would be useful to have a sentence or two in the draft changing:
> 
> "Label 7 (when received) retains its meaning as ELI whether a regular
> or an extended special purpose label; this is to simplify the logic
> for transit LSRs looking for entropy labels."
> 
> to
> 
> "Label 7 (when received) retains its meaning as ELI whether a regular or an extended special purpose label; this simplifies a transit LSR's task of looking for entropy labels since it may just look for label 7 and need not verify that the previous label in the stack is not the Extension Label 15.

Will do.  Thanks for the wording.

> Alia

---

From: Kireeti Kompella <[email-masked]>
Date: Sat, 10 Aug 2013 08:59:23 -0700

Hi Maria,

On Jul 13, 2013, at 16:50 , "NAPIERALA, MARIA H" <[email-masked]> wrote:

(wow -- only a month later :))

> Hi Kireeti,
>  
> A comment on the ranges of Extended Special Purpose MPLS Labels:
> (1)   Shouldn’t there be a larger Unassigned range (using terminology of RFC 5226)?

As I understand, the Unassigned tag is used by IANA to say that the values in a certain allocation range have not yet been assigned.  If a registry is created as requested, labels 16-239 will be marked Unassigned (until some are allocated).

> (2)   Why is Reserved range so large? What is the purpose?

The Reserved range says two things:
a) all labels following an extension label should be treated as extended special purpose labels; and
b) we don't think we need so many, but we don't know what the allocation policy should be if we would need more, so we won't say anything right now.

> Maria

Kireeti.