Subject: [mpls] FW: New Version Notification for draft-ietf-mpls-ldp-multi-topology-09.txt

From: Quintin zhao <[email-masked]>
Date: Mon, 14 Oct 2013 21:57:40 +0000

Hello Adrian, Alia,

Included here is the new version we come up based on your comments. 

(1) For the MT-ID numbers' assignment, based your recommendations, we updated the assignments as below:

o  New registry "LDP Multi-Topology (MT) ID Name Space" under "LDP
        Parameter" namespace.  The allocation policies for this registry
        are:

        Range/Value  Purpose                                Reference
        -----------  -------------------------------------  ---------
        0            Default/standard topology
        1            IPv4 in-band management
        2            IPv6 routing topology
        3            IPv4 multicast topology
        4            IPv6 multicast topology
        5            IPv6 in-band management
        6-3995       Reserved for future IGP topologies
        3996-4095    Reserved for IGP experimental topologies

        4096-4127    Reserved for LDP topologies
        4128-65534   Reserved for LDP experimental topologies

        65535        Wildcard Topology

For the reserved number assignments, the reserved ranges are a little different from what you have suggested and we also have reserved 65535 for the Wildcard Topology

(2) We added one section to address your comments regarding to the OAM.

(3) We addressed your editorial comments in this version in this version too.

Please let us know if your comments are addressed correctly or not and also you have any further comments, please let us know. 

Thanks,

Quintin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: 2013年10月14日 17:49
To: Lianyuan Li; Quintin zhao; Luyuan Fang; Kamran Raza; Chao Zhou
Subject: New Version Notification for draft-ietf-mpls-ldp-multi-topology-09.txt

A new version of I-D, draft-ietf-mpls-ldp-multi-topology-09.txt
has been successfully submitted by Quintin Zhao and posted to the IETF repository.

Filename:	 draft-ietf-mpls-ldp-multi-topology
Revision:	 09
Title:		 LDP Extensions for Multi Topology Routing
Creation date:	 2013-10-14
Group:		 mpls
Number of pages: 20
URL:             http://www.ietf.org/internet-drafts/draft-ietf-mpls-ldp-multi-topology-09.txt
Status:          http://datatracker.ietf.org/doc/draft-ietf-mpls-ldp-multi-topology
Htmlized:        http://tools.ietf.org/html/draft-ietf-mpls-ldp-multi-topology-09
Diff:            http://www.ietf.org/rfcdiff?url2=draft-ietf-mpls-ldp-multi-topology-09

Abstract:
   Multi-Topology (MT) routing is supported in IP networks with the use
   of MT aware IGPs.  In order to provide MT routing within
   Multiprotocol Label Switching (MPLS) Label Distribution Protocol
   (LDP) networks new extensions are required.

   This document describes the LDP protocol extensions required to
   support MT routing in an MPLS environment.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 16 Oct 2013 21:20:56 +0100

Hello Quintin,

Thanks for this.

I only have one concern that needs to be thought about...

Your new registry "LDP Multi-Topology (MT) ID Name Space" under "LDP Parameter" namespace will be confusing to IANA I think. The four ranges that are marked as "Reserved" for different purposes will cause IANA to ask you what the rules are for allocation from those ranges. You need to work out what your answer is.

I am going to start the IETF last call, and I expect the question will come up during that time.

Thanks,
Adrian

> From: Quintin zhao [mailto:[email-masked]]
> Sent: 14 October 2013 22:58
> To: 'Adrian Farrel'; Alia Atlas
> Cc: [email-masked]
> Subject: FW: New Version Notification for draft-ietf-mpls-ldp-multi-topology-
> 09.txt
> 
> Hello Adrian, Alia,
> 
> For the reserved number assignments, the reserved ranges are a little different
> from what you have suggested and we also have reserved 65535 for the Wildcard
> Topology
> 
> Please let us know if your comments are addressed correctly or not and also you
> have any further comments, please let us know.
> 
> Thanks,
> 
> Quintin
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat