Subject: Re: [mpls] MPLS-RT review on draft-osborne-mpls-psc-updates-01

From: "Eric Osborne (eosborne)" <[email-masked]>
Date: Thu, 3 Oct 2013 14:40:49 +0000

Hi Kenji-

  Sorry for the very late reply.  I'd missed all the [email-masked]' emails.  See inline.

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]
> Sent: Friday, August 23, 2013 6:59 AM
> To: [email-masked]; mpls-
> [email-masked]
> Cc: [email-masked]
> Subject: MPLS-RT review on draft-osborne-mpls-psc-updates-01
> 
> Hi,
> 
> I've reviewed draft-osborne-mpls-psc-updates-01 as the MPLS-RT process.
> 
> a. Is the document coherent?
> It's almost coherent. I need just one clarification about section 4.
>    "When L(SF-W) is removed but R(SF-W)
>    remains, what does PSC do?  A strict reading of the FSM would suggest
>    that PSC transition from PA:F:L into N, and at some future time
>    (perhaps after the remote request refreshes) PSC would transition
>    from N to PA:F:R."
> PA:F:L/R is Protecting administrative state due to local or Remote FS
> operator command,
> so it doesn't match in this context. In my understanding, the strict
> reading of the FSM
> leads the following transition.
>    PF:W:L -> DNR -> PF:W:R (for non-revertive operation)
>    PF:W:L -> WTR (for revertive operation)
> 

Yeah, I have a typo in there.  I suspect I mashed up SF and FS when writing the example.  I do this far more than I'd like to admit.

Your understanding about the FSM behavior in the face of SF-W is correct.  My text was going for the easiest example, and it seems much easier to explain it with FS so I don't have to cover both NR/R cases.  It's just an example, after all.

I'll rewrite section 4 example 1 with FS rather than SF-W; this leaves the reading of the FSM correct.  I will resubmit this as -03 and then ask Loa to proceed with WG adoption.

Thanks!

eric

> b. Is it useful (ie, is it likely to be actually useful in operational
> networks)?
> I believe it's useful.
> 
> c. Is the document technically sound?
> Yes, the described mechanism and objective are clear to me.
> 
> d. Is the document ready to be considered for WG adoption?
> I hope the comment above is closed before WG adoption.
> 
> Best Regards,
> Kenji.

---

From: <[email-masked]>
Date: Fri, 4 Oct 2013 14:28:51 +0900

Hi, Eric.

Thanks. See inline.

>Your understanding about the FSM behavior in the face of SF-W is correct.  My text was going for the easiest example, and it seems much easier to explain it with FS so I don't have to cover both NR/…

Yes, I understand.
If it's a multiple input example of Local FS and Remote FS, the sentence in the draft "A strict reading of the FSM would suggest..." is correct.

>I'll rewrite section 4 example 1 with FS rather than SF-W; this leaves the reading of the FSM correct.  I will resubmit this as -03 and then ask Loa to proceed with WG adoption.

OK. I agree with you. FS is a better example than SF-W to make it simple.

B.R.
Kenji.