Subject: [mpls] Note on p2mp ingress and egress protection proposals

From: Gregory Mirsky <[email-masked]>
Date: Tue, 17 Dec 2013 17:11:13 +0000

Dear All,
I've been following these proposals for a quite some time and actively participated in the discussion with authors. I do believe that both scenarios represent use of redundancy and hence explicit coordination of Active/Standby roles is required. That certainly would simplify OAM for both cases. And I believe that ICCP is good candidate for coordination within Redundancy Group. Though it would hardly be "fast protection" then.
Hence I believe that all pieces needed to address both scenarios already exist and Informational documents may be needed if anything at all.

                Regards,
                                Greg

---

From: Alia Atlas <[email-masked]>
Date: Wed, 18 Dec 2013 12:17:38 -0500

Hi Greg,

Can you briefly summarize what part of the problem ICCP is solving and why
you think it can be improved to offer fast protection?  From a quick glance
at the first couple pages, it looks like it does the state coordination for
the service - but not setting up the transport LSPs??

The RSVP-TE ingress protection draft describes different failure detection
modes so that the appropriate action on detecting a failure is clearly
agreed before the failure occurs.

Handling a failure in a non fast fashion is fairly rivial; for instance,
the backup ingress could run BFD to the ingress node's loopback and see if
it fails after the network has converged.

I do think that there are basic RSVP-TE mechanisms required to set up the
backup LSPs, indicate the traffic to insert, and what type of failure
detection will be used.  Those seem to require standardization for
interoperability - not just informational.

Perhaps you can more clearly describe what you are proposing?  Of course,
if you already have a draft written, please just point me at it.

Regards,
Alia

On Tue, Dec 17, 2013 at 12:11 PM, Gregory Mirsky <
[email-masked]> wrote:

>  Dear All,
>
> I’ve been following these proposals for a quite some time and actively
> participated in the discussion with authors. I do believe that both
> scenarios represent use of redundancy and hence explicit coordination of
> Active/Standby roles is required. That certainly would simplify OAM for
> both cases. And I believe that ICCP is good candidate for coordination
> within Redundancy Group. Though it would hardly be “fast protection” then.
>
> Hence I believe that all pieces needed to address both scenarios already
> exist and Informational documents may be needed if anything at all.
>
>
>
>                 Regards,
>
>                                 Greg
>
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>
>

---

From: Gregory Mirsky <[email-masked]>
Date: Wed, 18 Dec 2013 21:29:57 +0000

Hi Alia,
yes, I'd consider using the ICCP, Inter-Chassis Communication Protocol, in cases of LSP ingress and egress protection to synchronize state. I agree with your analysis that ICCP unlikely to support fast protection switchover but I'm not certain that such is required because we don't have any use case and/or requirements for LSP ingress and/or egress protection scenarios. As I can see and was commenting, proposed application of OAM monitoring does create likely positive negative scenarios. The ICCP will address them, I believe. Is that required? We can determine that if we have agreed upon requirements but until then that is matter of personal opinion.
I think that both scenarios present cases of LSP redundancy that are similar to PW redundancy where ICCP plays integral and important role. Hence my recommendation to discuss applicability of ICCP. But even more stronger I'd encourage and would gladly cooperate on requirements towards LSP ingress and egress protection.

                Regards,
                                Greg

From: Alia Atlas [mailto:[email-masked]]
Sent: Wednesday, December 18, 2013 9:18 AM
To: Gregory Mirsky
Cc: [email-masked]
Subject: Re: [mpls] Note on p2mp ingress and egress protection proposals

Hi Greg,

Can you briefly summarize what part of the problem ICCP is solving and why you think it can be improved to offer fast protection?  From a quick glance at the first couple pages, it looks like it does the state coordination for the service - but not setting up the transport LSPs??

The RSVP-TE ingress protection draft describes different failure detection modes so that the appropriate action on detecting a failure is clearly agreed before the failure occurs.

Handling a failure in a non fast fashion is fairly rivial; for instance, the backup ingress could run BFD to the ingress node's loopback and see if it fails after the network has converged.

I do think that there are basic RSVP-TE mechanisms required to set up the backup LSPs, indicate the traffic to insert, and what type of failure detection will be used.  Those seem to require standardization for interoperability - not just informational.

Perhaps you can more clearly describe what you are proposing?  Of course, if you already have a draft written, please just point me at it.

Regards,
Alia

On Tue, Dec 17, 2013 at 12:11 PM, Gregory Mirsky <[email-masked]<mailto:[email-masked]>> wrote:
Dear All,
I've been following these proposals for a quite some time and actively participated in the discussion with authors. I do believe that both scenarios represent use of redundancy and hence explicit coordination of Active/Standby roles is required. That certainly would simplify OAM for both cases. And I believe that ICCP is good candidate for coordination within Redundancy Group. Though it would hardly be "fast protection" then.
Hence I believe that all pieces needed to address both scenarios already exist and Informational documents may be needed if anything at all.

                Regards,
                                Greg

_______________________________________________
mpls mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mpls