Subject: Re: [mpls] Last Call: <draft-ietf-mpls-in-udp-04.txt> (Encapsulating MPLS in UDP) to Proposed Standard

From: [email-masked] (Noel Chiappa)
Date: Thu, 30 Jan 2014 14:32:00 -0500 (EST)

> From: Joe Touch <[email-masked]>

    > Simple solution -- don't use UDP.

Yes, because if we use a different protocol, any potential congestion will
magically disappear!

	Noel

---

From: Greg Daley <[email-masked]>
Date: Thu, 30 Jan 2014 22:44:54 +0000

> Yes, because if we use a different protocol, any potential congestion will

Isn't that protocol called DCCP? (per RFC 4340 and 5348)

It would be interesting and potentially feasible to outline MPLS over DCCP (given a solid use case), but it would be one of the few (9) named application bindings for this protocol today:

http://www.iana.org/assignments/service-names-port-numbers/service-names-port-numbers.txt

Of course, in order to get the protocols to pass legacy firewall inspection, UDP encapsulation may be required, and companies would have to actually implement the protocol...

Greg Daley
[email-masked]

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 31 Jan 2014 10:50:54 +0000

On 30/01/2014 22:44, Greg Daley wrote:
> Of course, in order to get the protocols to pass legacy firewall 
> inspection, UDP encapsulation may be required, and companies would 
> have to actually implement the protocol... Greg Daley 
> [email-masked] 
So UDP/DCCP/MPLS ?

Stewart

---

From: <[email-masked]>
Date: Fri, 31 Jan 2014 11:32:31 +0000

RFC 6773. which requires a full udp checksum for nat traversal.

Lloyd Wood
http://about.me/lloydwood
________________________________________
From: ietf [[email-masked]] On Behalf Of Stewart Bryant [[email-masked]]
Sent: 31 January 2014 10:50
To: Greg Daley; 'Noel Chiappa'; [email-masked]; [email-masked]
Subject: Re: [mpls] Last Call: <draft-ietf-mpls-in-udp-04.txt> (Encapsulating MPLS in UDP) to Proposed Standard

So UDP/DCCP/MPLS ?

Stewart