Subject: [mpls] draft-wijnands-mpls-mldp-in-band-wildcard-encoding-02

From: Chris Roberts <[email-masked]>
Date: Wed, 8 Jan 2014 11:11:38 +0000

Hi Authors,

I have a query about this draft relating to the use case of (Source,
Wildcard Group) as the opaque value TLV.

Section 3.2 Wildcard Semantics states the this should be treated this as
"the TLV identifies the collection of PIM-SSM trees that have the source
address as their root.".

However, Section 6 Procedures for Wildcard Group Usage states "the Ingress
LSR examines its IP multicast routing table, to find all the IP multicast
streams whose IP source address is the address specified in the IP Source
Address sub-field of the TLV. All these streams SHOULD be forwarded down
the MP-LSP identified by the Opaque Value TLV. Note that some of these
streams may have SSM group addresses, while some may have ASM group
addresses."

This seems to conflict....so an Egress-LSR sending this TLV - should it
expect to see just SSM groups or both ASM and SSM?  Presumably the latter
if no group can be specified?

Regards,

Chris

---

From: IJsbrand Wijnands <[email-masked]>
Date: Wed, 8 Jan 2014 14:44:37 +0100

Hi Chris,

> I have a query about this draft relating to the use case of (Source, Wildcard Group) as the opaque value TLV.
> 
> Section 3.2 Wildcard Semantics states the this should be treated this as "the TLV identifies the collection of PIM-SSM trees that have the source address as their root.".
> 
> However, Section 6 Procedures for Wildcard Group Usage states "the Ingress LSR examines its IP multicast routing table, to find all the IP multicast streams whose IP source address is the address specified in the IP Source Address sub-field of the TLV. All these streams SHOULD be forwarded down the MP-LSP identified by the Opaque Value TLV. Note that some of these streams may have SSM group addresses, while some may have ASM group addresses."
> 
> This seems to conflict....so an Egress-LSR sending this TLV - should it expect to see just SSM groups or both ASM and SSM?  Presumably the latter if no group can be specified?

Correct. The statement in section 3.2 should not limit this behaviour to PIM SSM trees. We'll clarify it in the next revision.

Thx,

Ice.