Subject: [mpls] Alia Atlas' Discuss on draft-ietf-mpls-in-udp-10: (with DISCUSS)

From: "Alia Atlas" <[email-masked]>
Date: Tue, 20 Jan 2015 12:40:41 -0800

Alia Atlas has entered the following ballot position for
draft-ietf-mpls-in-udp-10: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to http://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
http://datatracker.ietf.org/doc/draft-ietf-mpls-in-udp/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

I am still waiting for this review comment to be resolved.

In Sec 4, it says:
"That is to say, if the destination IP address is a multicast address,
the top label SHOULD be upstream-assigned, otherwise if the destination
IP address is a ..."   This seems to require that the IP network is
capable of supporting multicast where one can easily see using
MPLS-in-UDP tunnels to provide point-to-point tunnels.  Is there a reason
that the negotiation mechanism to set up the MPLS-in-UDP tunnel wouldn't
also be able to specify alternate destination IP addresses for
upstrteam-assigned?  How much discussion and agreement has this
limitation had??

---

From: Xuxiaohu <[email-masked]>
Date: Wed, 21 Jan 2015 03:12:27 +0000

Hi Alia,

Thanks a lot for your AD review of this new revision. Please see my explanation inline.

> -----Original Message-----
> From: Alia Atlas [mailto:[email-masked]]
> Sent: Wednesday, January 21, 2015 4:41 AM
> To: The IESG
> Cc: [email-masked]; [email-masked]; Loa
> Andersson; [email-masked]
> Subject: Alia Atlas' Discuss on draft-ietf-mpls-in-udp-10: (with DISCUSS)
> 
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 
> "That is to say, if the destination IP address is a multicast address, the top label
> SHOULD be upstream-assigned, otherwise if the destination
> capable of supporting multicast where one can easily see using MPLS-in-UDP
> tunnels to provide point-to-point tunnels.  Is there a reason that the

P2P MPLS-in-UDP tunnels could be used to carry multicast IP or Ethernet traffic as well (e.g., in the ingress replication mode). In this case, the MPLS labels should be downstream-assigned. Although it's possible to use upstream-assigned labels in theory, it brings no value in practice since it's more complex compared to the usage of downstream-assigned labels from the implementation perspective. In other words, it doesn't require that the IP network is capable of supporting multicast in order to transport multicast IP or Ethernet traffic over MPLS-in-UDP tunnels. 

> negotiation mechanism to set up the MPLS-in-UDP tunnel wouldn't also be able
> to specify alternate destination IP addresses for upstrteam-assigned?  How

In my understanding, the only real use case of upstream-assigned labels is multicast service up till now. If multicast traffic is transported over P2MP MPLS-in-UDP tunnels, the MPLS label MUST be upstream-assigned. Otherwise, the MPLS label should be downstream-assigned as said above.

> much discussion and agreement has this limitation had??

Maybe my points as mentioned above are incorrect. Therefore, I'm looking forward to seeing further comments and suggestions on this point, especially from those people who are knowledgeable about the usage of upstream-assigned labels.

Best regards,
Xiaohu

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 21 Jan 2015 11:09:27 -0000

[co-author hat - not being an AD]

In a separate private reply to Alia I just suggested that the text about upstream assigned labels is overly optimistic.

I'm not sure when it crept in.

The assumption is that a multi-access link is being replaced with a UDP multicast tunnel. I suspect this is unlikely and I have no idea why it would be necessary unless:
- the IP/UDP network supports multicast
- the traffic being distributed is multicast
- there are more than two sites being connected
- the volume of traffic is more than moderate
Otherwise, p2p UDP tunnels would be enough.

My suggestion to Alia is to make upstream assigned labels for future study. That way this I-D can move forward (at last!) and if anyone is interested in the multicast work they can write a short additional document.

The fix would be to remove the offending text from section 4 and to add a note to the Abstract and Introduction that this document is limited to downstream assigned labels.

Adrian

> From: iesg [mailto:[email-masked]] On Behalf Of Xuxiaohu
> Sent: 21 January 2015 03:12
> To: Alia Atlas; The IESG
> Cc: [email-masked]; [email-masked];
> [email-masked]; Loa Andersson
> Subject: RE: Alia Atlas' Discuss on draft-ietf-mpls-in-udp-10: (with DISCUSS)
> 
> Hi Alia,
> 
> P2P MPLS-in-UDP tunnels could be used to carry multicast IP or Ethernet traffic as
> well (e.g., in the ingress replication mode). In this case, the MPLS labels should be
> downstream-assigned. Although it's possible to use upstream-assigned labels in
> theory, it brings no value in practice since it's more complex compared to the
> usage of downstream-assigned labels from the implementation perspective. In
> other words, it doesn't require that the IP network is capable of supporting
> multicast in order to transport multicast IP or Ethernet traffic over MPLS-in-UDP
> tunnels.
> 
> In my understanding, the only real use case of upstream-assigned labels is
> multicast service up till now. If multicast traffic is transported over P2MP MPLS-in-
> UDP tunnels, the MPLS label MUST be upstream-assigned. Otherwise, the MPLS
> label should be downstream-assigned as said above.
> 
> Maybe my points as mentioned above are incorrect. Therefore, I'm looking
> forward to seeing further comments and suggestions on this point, especially
> from those people who are knowledgeable about the usage of upstream-
> assigned labels.
> 
> Best regards,
> Xiaohu
> >
> >
> >

---

From: Loa Andersson <[email-masked]>
Date: Wed, 21 Jan 2015 20:44:24 +0800

Adrian,

If I understand you correctly you say that the current text makes a
general statement that UDP multicast tunnels are needed and if they
are we need the upstream assigned labels; yuo on the other hand say
that this is a corner case that we can (for the time being) live with
the  multi-access link and UDP point to point links are enough.

If this is correct, I support scoping the document as you proposed.

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Alia Atlas <[email-masked]>
Date: Wed, 21 Jan 2015 09:23:32 -0500

Loa & Adrian,

My concern was that requiring the underlay to support multicast routing
might be too
restrictive in a data center.  However, if you are comfortable that
upstream labels only
make sense if the link technology is multi-access (so a multicast UDP
tunnel is the
equivalent), then I am ok with the text as is.

I was concerned that we were not missing a case that would be hard to fix
later and
wanted to have that double-checked.

Thanks,
Alia

On Wed, Jan 21, 2015 at 7:44 AM, Loa Andersson <[email-masked]> wrote:

>> In a separate private reply to Alia I just suggested that the text about
>> upstream assigned labels is overly optimistic.
>>
>> The assumption is that a multi-access link is being replaced with a UDP
>> multicast tunnel. I suspect this is unlikely and I have no idea why it
>> would be necessary unless:
>> My suggestion to Alia is to make upstream assigned labels for future
>> study. That way this I-D can move forward (at last!) and if anyone is
>> interested in the multicast work they can write a short additional document.
>>
>> The fix would be to remove the offending text from section 4 and to add a
>> note to the Abstract and Introduction that this document is limited to
>> downstream assigned labels.
>>
>> Adrian
>>
>>> Thanks a lot for your AD review of this new revision. Please see my
>>> explanation
>>> inline.
>>>
>>>> email
>>>> the top label
>>>> MPLS-in-UDP

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 21 Jan 2015 15:18:38 -0000

No, it is not "if the link technology is multi-access".
It is if the virtual link is multi-access.
I.e. if the UDP tunnel is p2mp
Such as, for example, connecting a set of distributed DC sites for the purpose of distributing multicast data.
 
A
 
From: Alia Atlas [mailto:[email-masked]] 
Sent: 21 January 2015 14:24
To: Loa Andersson
Cc: Adrian Farrel; Xuxiaohu; The IESG; [email-masked]; [email-masked]; [email-masked]
Subject: Re: Alia Atlas' Discuss on draft-ietf-mpls-in-udp-10: (with DISCUSS)
 
Loa & Adrian,
 
My concern was that requiring the underlay to support multicast routing might be too
restrictive in a data center.  However, if you are comfortable that upstream labels only
make sense if the link technology is multi-access (so a multicast UDP tunnel is the
equivalent), then I am ok with the text as is.
 
I was concerned that we were not missing a case that would be hard to fix later and
wanted to have that double-checked.
 
Thanks,
Alia

/Loa

Adrian
-----Original Message-----
From: iesg [mailto:[email-masked]] On Behalf Of Xuxiaohu
Sent: 21 January 2015 03:12
To: Alia Atlas; The IESG
Cc: [email-masked]; [email-masked];

Hi Alia,

Thanks a lot for your AD review of this new revision. Please see my explanation
inline.
-----Original Message-----
From: Alia Atlas [mailto:[email-masked]]
Sent: Wednesday, January 21, 2015 4:41 AM
To: The IESG
Cc: [email-masked]; [email-masked]; Loa
Andersson; [email-masked]

In Sec 4, it says:

Best regards,
Xiaohu

 
-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64 <tel:%2B46%20739%2081%2021%2064>

---

From: Alia Atlas <[email-masked]>
Date: Wed, 21 Jan 2015 10:21:30 -0500

Adrian,

> No, it is not "if the link technology is multi-access".

That is what the upstream label assignment was developed for.

> I.e. if the UDP tunnel is p2mp

Right - and that is the parallel for the MPLS-in-UDP case - that the UDP
tunnel is p2mp.

> purpose of distributing multicast data.

Exactly.  I may have phrased it badly, but I think we are on the same page.

Alia

> A
>
>
>
> *From:* Alia Atlas [mailto:[email-masked]]
> *Sent:* 21 January 2015 14:24
> *To:* Loa Andersson
> *Cc:* Adrian Farrel; Xuxiaohu; The IESG;
> [email-masked]; [email-masked];
> [email-masked]
> *Subject:* Re: Alia Atlas' Discuss on draft-ietf-mpls-in-udp-10: (with
> DISCUSS)
>
>
>
> Loa & Adrian,
>
>
>