Subject: Re: [mpls] Missing RFC in draft-ietf-mpls-ipv6-only-gap?

From: "Aissaoui, Mustapha (Mustapha)" <[email-masked]>
Date: Wed, 4 Feb 2015 23:15:26 +0000

Dear all,
I appreciate if the authors provided some input on this question.

Regards,
Mustapha.

> -----Original Message-----
> From: mpls [mailto:[email-masked]] On Behalf Of Aissaoui, Mustapha
> (Mustapha)
> Sent: Tuesday, December 16, 2014 12:17 PM
> To: [email-masked]
> Subject: [mpls] Missing RFC in draft-ietf-mpls-ipv6-only-gap?
> 
> Dear all,
> I recently was made aware of RFC 5549 which seems to cover a couple of the
> gaps in draft-ietf-mpls-ipv6-only-gap:
> https://tools.ietf.org/html/rfc5549
> 
> RFC 5549 extends MP-BGP with the ability for an IPv4 NLRI (AFI=1, SAFI=1),
> labeled IPv4 NLRI (AFI=1, SAFI=4), and VPN-IPv4 NLRI (AFI=1, SAFI=128) to use
> an IPv6 next-hop. This would I believe cover scenario 2 in sections 3.3.2, 3.3.2.1,
> and 3.3.2.1 for the above types of routes.
> 
> I missed this during the MPLS-RT review and I appreciate if the authors could
> confirm my observation.
> 
> I apologize if this was already discussed.
> 
> Regards,
> Mustapha.
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 5 Feb 2015 11:09:51 -0000

Hmmm,

There was a thread between the authors and chairs discussing this, but it wasn't
summarised back to the list.

Could someone do that, please.

Adrian

> Sent: 04 February 2015 23:15
> To: [email-masked]
> Subject: Re: [mpls] Missing RFC in draft-ietf-mpls-ipv6-only-gap?
> 
> Dear all,

---

From: "George, Wes" <[email-masked]>
Date: Thu, 5 Feb 2015 08:58:22 -0500

The discussion went like this:

By the time we were made aware of this, the document was already in
auth48, and we did not think that the addition of an informational
reference was something that we could credibly do during auth48, which is
intended for minor wording and formatting tweaks only. This would have
required recalling the document and putting it back through the process,
and we didn't see this update as being critical to the document's quality.

The way that we left it was that this could certainly be filed via the
errata process if the WG thinks that it is important, but it could also be
tracked via whatever means we decide to track the gaps (see other thread).

Thanks,

Wes

On 2/5/15, 6:09 AM, "Adrian Farrel" <[email-masked]> wrote:

>> > labeled IPv4 NLRI (AFI=1, SAFI=4), and VPN-IPv4 NLRI (AFI=1,
>>SAFI=128) to
>use
>> > an IPv6 next-hop. This would I believe cover scenario 2 in sections
>>3.3.2,
>3.3.2.1,
>> > I missed this during the MPLS-RT review and I appreciate if the
>>authors
>could
>> > confirm my observation.
>> >

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Loa Andersson <[email-masked]>
Date: Thu, 05 Feb 2015 22:10:00 +0800

Wes,

Tnx - I was about to sit down and write pretty much the same mail, a
further comment would be that doing a gap analysis is always at risk of
not cover 100%, but that that on the other hand is not a real problem.
what we need now is some way of following how the gaps evolves/closes
and this could be handle as part of that.

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64