Subject: Re: [mpls] RtgDir review: draft-ietf-mpls-lsp-ping-reply-mode-simple-03.txt

From: Dan Frost <[email-masked]>
Date: Tue, 01 Sep 2015 12:23:54 +0100

On Sun, Aug 30, 2015, at 09:19, Nobo Akiya wrote:
> [...]
> Again, thanks for reviewing the document Dan. Please let me know what
> you would like for the Sub-TLV preference within the Reply Path TLV ... 
> which is really an issue with RFC 7110.

Many thanks for your updates, Nobo!  Regarding the preference issue,
yes, I think this is a good place to clarify it, as this document
already updates 7110.

-d

---

From: Mach Chen <[email-masked]>
Date: Mon, 7 Sep 2015 08:50:32 +0000

Hi Dan, 

Thanks for your comments!

Regarding to the preference issue, after the discussion among the authors, we think that the Reply Path TLV was originally designed to identify a single path even if it may include multiple sub-TLVs. Similar to FEC Stack TLV, multiple sub-TLVs are mainly used to express a VPN path where it may have tunnel FEC and VPN prefix FEC but both FECs used for expressing the single VPN "path".  So when multiple ordered return paths are required, multiple Reply Path TLVs (each for a single path) should be used. We have updated the draft accordingly, hope this resolve your comment, attachment shows the diff between the old version and the update.

Best regards,
Mach

> -----Original Message-----
> From: mpls [mailto:[email-masked]] On Behalf Of Dan Frost
> Sent: Tuesday, September 01, 2015 7:24 PM
> To: Nobo Akiya
> Cc: [email-masked]; mpls;
> [email-masked];
> [email-masked]
> Subject: Re: [mpls] RtgDir review:
> draft-ietf-mpls-lsp-ping-reply-mode-simple-03.txt
> 
> Many thanks for your updates, Nobo!  Regarding the preference issue, yes, I
> think this is a good place to clarify it, as this document already updates 7110.
> 
> -d
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls