Subject: Re: [mpls] Should we split draft-bryant-mpls-synonymous-flow-labels into arch and application

From: Loa Andersson <[email-masked]>
Date: Sat, 19 Sep 2015 18:07:46 +0200

Working Group,

I have not seen any responses to this mail from Stewart! Take a look
and see if you have an opinion.

/Loa

On 2015-08-17 17:50, Stewart Bryant wrote:
> At the last IETF the question arose as to what the correct
> document structure should be for the synonymous
> label work.
>
> The core draft is: draft-bryant-mpls-synonymous-flow-labels
> which is a mixture pure SFL work and RFC6374 applications
> work.
>
> My inclination is to split the draft in two to separate the
> SFL architecture from the RFC6374 application. However I
> would like to take the sense of the WG on this.
>
> I know that there needs to be more work on requirements
> and will do a word by word review of that text and make proposals
> and of course review comments on any of these texts are
> always welcome.
>
> - Stewart
>
>
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Sat, 19 Sep 2015 12:28:36 -0400

Loa,

If this was a big effort, I'd say go for the split, but it's a short draft
so I don't really see the need to double the overhead work for the WG,
chairs, ADs, and RFC Editor for what would be two very short drafts!

Cheers,
Andy

---

From: Loa Andersson <[email-masked]>
Date: Sun, 20 Sep 2015 11:15:56 +0200

Andy,

I tend to agree.

Authors,

This is still an individual document, so this is not a wg/wg chair 
directive, but I think that if no further need for a split arises,
then you should go ahead with one document.

/Loa

On 2015-09-19 18:28, Andrew G. Malis wrote:
> Loa,
>
> If this was a big effort, I'd say go for the split, but it's a short
> draft so I don't really see the need to double the overhead work for the
> WG, chairs, ADs, and RFC Editor for what would be two very short drafts!
>
> Cheers,
> Andy
>
>
> On Sat, Sep 19, 2015 at 12:07 PM, Loa Andersson <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     Working Group,
>
>         [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 21 Sep 2015 10:32:48 +0100

Andy

Worrying about the work needed to process the drafts (which will be 
quite small) is putting
the cart before the horse.

What is important is clarity of ideas and clarity of understanding by 
the reader. The IETF
is somewhat unique in it's production of micro specs that provide 
separation of ideas
and this has served us well over the years.

Whilst the draft started out as an RFC6374 solution, the technology 
proposed has a
more universal application.

It therefore makes sense to me to produce a description of base 
technology uncluttered
by a detailed solution to an application, and a separate text on the 
application.

- Stewart

On 19/09/2015 17:28, Andrew G. Malis wrote:
> draft so I don't really see the need to double the overhead work for 
> the WG, chairs, ADs, and RFC Editor for what would be two very short 
> drafts!
>
> Cheers,
> Andy
>
>

-- 
For corporate legal information go to:

http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 21 Sep 2015 06:11:58 -0400

Stewart,

As Loa said, it's still an individual draft, so it's up to you!

Cheers,
Andy

On Mon, Sep 21, 2015 at 5:32 AM, Stewart Bryant <[email-masked]> wrote:

> Andy
>
> Worrying about the work needed to process the drafts (which will be quite
> small) is putting
> What is important is clarity of ideas and clarity of understanding by the
> reader. The IETF
> It therefore makes sense to me to produce a description of base technology
> uncluttered

---

From: Gregory Mirsky <[email-masked]>
Date: Mon, 21 Sep 2015 18:00:49 +0000

Dear All,
I agree with Stewart that extracting architectural part of the synonymous labels discussion would improve the clarity and may add new use cases in addition to RFC 6374. As co-author I support the split and will be glad to work on that.

                Regards,
                                Greg

From: mpls [mailto:[email-masked]] On Behalf Of Stewart Bryant
Sent: Monday, September 21, 2015 2:33 AM
To: Andrew G. Malis; Loa Andersson
Cc: [email-masked]; [email-masked]
Subject: Re: [mpls] Should we split draft-bryant-mpls-synonymous-flow-labels into arch and application

Andy

Worrying about the work needed to process the drafts (which will be quite small) is putting
the cart before the horse.

What is important is clarity of ideas and clarity of understanding by the reader. The IETF
is somewhat unique in it's production of micro specs that provide separation of ideas
and this has served us well over the years.

Whilst the draft started out as an RFC6374 solution, the technology proposed has a
more universal application.

It therefore makes sense to me to produce a description of base technology uncluttered
by a detailed solution to an application, and a separate text on the application.

- Stewart

If this was a big effort, I'd say go for the split, but it's a short draft so I don't really see the need to double the overhead work for the WG, chairs, ADs, and RFC Editor for what would be two very short drafts!

Cheers,
Andy

On Sat, Sep 19, 2015 at 12:07 PM, Loa Andersson <[email-masked]<mailto:[email-masked]>> wrote:
Working Group,

/Loa

- Stewart

_______________________________________________
mpls mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mpls

_______________________________________________
mpls mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mpls

--

---

From: Loa Andersson <[email-masked]>
Date: Wed, 23 Sep 2015 11:17:29 +0200

Greg and Stewart,

This is an individual document, if the co-authors have consensus on
splitting the document, please go ahead and do so.

My personal opinion is that extracting the architecture is fine as
long as we will have two viable documents.

/Loa

On 2015-09-21 20:00, Gregory Mirsky wrote:
> Dear All,
>
> I agree with Stewart that extracting architectural part of the
> synonymous labels discussion would improve the clarity and may add new
> use cases in addition to RFC 6374. As co-author I support the split and
> will be glad to work on that.
>
>                  Regards,
>
>                                  Greg
>
> *From:*mpls [mailto:[email-masked]] *On Behalf Of *Stewart Bryant
> *Sent:* Monday, September 21, 2015 2:33 AM
> *To:* Andrew G. Malis; Loa Andersson
> *Cc:* [email-masked]; [email-masked]
> *Subject:* Re: [mpls] Should we split
> draft-bryant-mpls-synonymous-flow-labels into arch and application
>
> Andy
>

---

From: Lizhenbin <[email-masked]>
Date: Mon, 28 Sep 2015 03:19:51 +0000

Hi all,
I think that there will be much work for the SFL to be done. Besides RFC6374 related work, the issues proposed here will be related with MP2P LSP such as LDP LSP and L3VPN LSP.
So there may be extensions of LDP/BGP to be defined. In fact, we have ever proposed the drafts of L3VPN OAM for the purpose which should be enhanced according to the arch of
SFL. As co-author I also support the split and will be glad to work on that.

Best Regards,
Zhenbin (Robin)

-----邮件原件-----
发件人: mpls [mailto:[email-masked]] 代表 Loa Andersson
发送时间: 2015年9月23日 17:17
收件人: Gregory Mirsky; [email-masked]; Andrew G. Malis
抄送: [email-masked]; [email-masked]
主题: Re: [mpls] Should we split draft-bryant-mpls-synonymous-flow-labels into arch and application

Greg and Stewart,

This is an individual document, if the co-authors have consensus on splitting the document, please go ahead and do so.

My personal opinion is that extracting the architecture is fine as long as we will have two viable documents.

/Loa

On 2015-09-21 20:00, Gregory Mirsky wrote:
> use cases in addition to RFC 6374. As co-author I support the split 
> and will be glad to work on that.
>
>                  Regards,
>
>                                  Greg
>
> *Cc:* [email-masked]; 
> [email-masked]
> quite small) is putting the cart before the horse.
>
> the reader. The IETF is somewhat unique in it's production of micro 
> specs that provide separation of ideas and this has served us well 
> over the years.
>
> proposed has a more universal application.
>
> technology uncluttered by a detailed solution to an application, and a 
> separate text on the application.
>
> - Stewart
>
>
>

---

From: Loa Andersson <[email-masked]>
Date: Mon, 28 Sep 2015 12:15:20 +0800

Authors,

Again not giving a wg chair directive, merely my own personal advice.
This is still an individual draft.

IF you have author consensus to split the draft, go ahead and do so.

/Loa