Subject: [mpls] Ben Campbell's No Objection on draft-ietf-mpls-lsp-ping-reply-mode-simple-04: (with COMMENT)

From: "Ben Campbell" <[email-masked]>
Date: Tue, 29 Sep 2015 13:36:51 -0700

Ben Campbell has entered the following ballot position for
draft-ietf-mpls-lsp-ping-reply-mode-simple-04: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-mpls-lsp-ping-reply-mode-simple/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

The security considerations say "no further considerations required"
without further explanation. While I don't doubt that is true (except for
those mentioned in Kathleen's DISCUSS), it would be helpful to mention
the new protocol elements and procedures added, and why the wg believes
they don't add any considerations beyond those in the referenced drafts.

---

From: Mach Chen <[email-masked]>
Date: Wed, 30 Sep 2015 02:20:38 +0000

Hi Ben,

Thanks for your comments!

The following text is to resolve Kathleen's DISCUSS, hope this also resolves your comments. 

Those security considerations specified in RFC4379 and RFC7110 apply for this document.
In addition, this document introduces the Reply Mode Order TLV. It provides a new way for an unauthorized source to gather more network information, especially the potential return path(s) information of an LSP. To protect against unauthorized sources using MPLS echo request messages with the Reply Mode Order TLV to obtain network information, similar to RFC4379, it is RECOMMENDED that implementations provide a means of checking the source addresses of MPLS echo request messages against an access list before accepting the message.

Best regards,
Mach

> -----Original Message-----
> From: mpls [mailto:[email-masked]] On Behalf Of Ben Campbell
> Sent: Wednesday, September 30, 2015 4:37 AM
> To: The IESG
> Cc: [email-masked];
> [email-masked];
> [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: [mpls] Ben Campbell's No Objection on
> draft-ietf-mpls-lsp-ping-reply-mode-simple-04: (with COMMENT)
> 
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 
> without further explanation. While I don't doubt that is true (except for those
> mentioned in Kathleen's DISCUSS), it would be helpful to mention the new
> protocol elements and procedures added, and why the wg believes they don't
> add any considerations beyond those in the referenced drafts.
> 
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

---

From: "Ben Campbell" <[email-masked]>
Date: Tue, 29 Sep 2015 22:54:52 -0500

> The following text is to resolve Kathleen's DISCUSS, hope this also 

Yes it does, thanks!

> In addition, this document introduces the Reply Mode Order TLV. It 
> provides a new way for an unauthorized source to gather more network 
> information, especially the potential return path(s) information of an 
> LSP. To protect against unauthorized sources using MPLS echo request 
> messages with the Reply Mode Order TLV to obtain network information, 
> similar to RFC4379, it is RECOMMENDED that implementations provide a 
> means of checking the source addresses of MPLS echo request messages 
> against an access list before accepting the message.
>
> Best regards,
> Mach
>
>> [email-masked]; 
>> [email-masked];
>> email
>> Please refer to 
>> https://www.ietf.org/iesg/statement/discuss-criteria.html