Subject: [mpls] New Liaison Statement, "LS on work on MPLS-TP protection"

From: Liaison Statement Management Tool <[email-masked]>
Date: Tue, 08 Mar 2016 10:48:03 -0800

Title: LS on work on MPLS-TP protection
Submission Date: 2016-03-08
URL of the IETF Web page: https://datatracker.ietf.org/liaison/1462/
Please reply by 2016-05-16
From: "Hiroshi Ota" <[email-masked]>
To: Loa Andersson <[email-masked]>,George Swallow <[email-masked]>,Ross Callon <[email-masked]>
Cc: Alvaro Retana <[email-masked]>,Deborah Brungard <[email-masked]>,Multiprotocol Label Switching Discussion List <[email-masked]>,Scott Mansfield <[email-masked]>,George Swallow <[email-masked]>,John Drake <[email-masked]>,Alia Atlas <[email-masked]>,Ross Callon <[email-masked]>,Loa Andersson <[email-masked]>,[email-masked],
Response Contacts: [email-masked], [email-masked]
Technical Contacts: 
Purpose: For comment

Body: ITU-T SG15 wishes to inform the IETF mpls WG of an update to the ITU-T Q9/15 work programme to include a second amendment to Recommendation ITU-T G.8131/Y.1382 Linear protection switching for MPLS transport profile. This amendment will cover pseudowire protection based on Appendix A of IETF RFC 7771. The amendment is targeted for consent at the September 2016 plenary meeting of SG15.

ITU-T Q9/15 has also been made aware of the initiation of work on MPLS-TP Shared-Ring protection (MSRP) mechanism for ring topology in draft-ietf-mpls-tp-shared-ring-protection-00, and has consequently re-initiated work on draft Recommendation ITU-T G.8132/Y.1383 Ring protection switching for MPLS transport profile. As ITU-T Q9/15 intends to reference and be aligned with corresponding normative RFCs, we would appreciate your assessment of the anticipated completion date for draft-ietf-mpls-tp-shared-ring-protection as the target consent date for draft Recommendation ITU-T G.8132/Y.1383 depends on it.
Attachments:

    Liaison
    https://www.ietf.org/lib/dt/documents/LIAISON/liaison-2016-03-08-itu-t-sg-15-mpls-ls-on-work-on-mpls-tp-protection-attachment-1.pdf

---

From: Loa Andersson <[email-masked]>
Date: Fri, 25 Mar 2016 14:28:14 +0800

All,

I've added the pals chairs, since pseudowire protection is mentioned.

Scott,

I think a and polite polite response for information is needed,
including:

- thank them for the information,
- if there is anything we need to say on pals work on (linear)
   protection (Stewart and Andy need to input
- acknowledge that we will complete the work on mpls ring protection
   (mention MSRP and RMR)
- wish good luck at the meeting in September

Can you compile this.

/Loa

---

From: Scott Mansfield <[email-masked]>
Date: Fri, 25 Mar 2016 13:44:05 +0000

No problem.

I can fill in the boiler plate.  Can the experts/leaders for the MSPR and RMR provide some text as outlined by Loa below?  Also please let me know what PALS wants to say.

Regards,
-scott.

-----Original Message-----
From: Loa Andersson [mailto:[email-masked]] 
Sent: Friday, March 25, 2016 2:28 AM
To: Ross Callon; George Swallow
Cc: Alia Atlas; [email-masked]; Scott Mansfield; [email-masked]; John Drake; Multiprotocol Label Switching Discussion List; Deborah Brungard; Alvaro Retana; [email-masked]
Subject: Re: New Liaison Statement, "LS on work on MPLS-TP protection"

All,

Scott,

Can you compile this.

/Loa

On 2016-03-09 02:48, Liaison Statement Management Tool wrote:
> Title: LS on work on MPLS-TP protection Submission Date: 2016-03-08 
> To: Loa Andersson <[email-masked]>,George Swallow 
> <[email-masked]>,Ross Callon <[email-masked]>
> Cc: Alvaro Retana <[email-masked]>,Deborah Brungard 
> <[email-masked]>,Multiprotocol Label Switching Discussion List 
> <[email-masked]>,Scott Mansfield <[email-masked]>,George 
> Swallow <[email-masked]>,John Drake <[email-masked]>,Alia 
> Atlas <[email-masked]>,Ross Callon <[email-masked]>,Loa 
> Andersson <[email-masked]>,[email-masked],

---

From: "Andrew G. Malis" <[email-masked]>
Date: Fri, 25 Mar 2016 14:05:36 -0400

Scott,

PALS currently has two drafts in progress that are relevant to MPLS-TP PW
linear protection:

https://datatracker.ietf.org/doc/draft-ietf-pals-mpls-tp-dual-homing-coordination/
https://datatracker.ietf.org/doc/draft-ietf-pals-mpls-tp-dual-homing-protection/

These drafts provide a fast protection mechanism for MPLS-TP PWs to protect
dual-homed CEs against failures of their attachment circuits or PE routers.
The drafts are ongoing work and were very recently updated. We hope to
forward the drafts to the IESG perhaps by the Berlin IETF meeting, and
would very much appreciate SG15’s review and comments.

Cheers,
Andy

On Fri, Mar 25, 2016 at 9:44 AM, Scott Mansfield <
[email-masked]> wrote:

> No problem.
>
> I can fill in the boiler plate.  Can the experts/leaders for the MSPR and
> RMR provide some text as outlined by Loa below?  Also please let me know
> what PALS wants to say.
>
> Regards,
> -scott.
>
> Cc: Alia Atlas; [email-masked]; Scott Mansfield;
> [email-masked]; John Drake; Multiprotocol Label Switching
> Discussion List; Deborah Brungard; Alvaro Retana; [email-masked]
> > Body: ITU-T SG15 wishes to inform the IETF mpls WG of an update to the
> ITU-T Q9/15 work programme to include a second amendment to Recommendation
> ITU-T G.8131/Y.1382 Linear protection switching for MPLS transport profile.
> This amendment will cover pseudowire protection based on Appendix A of IETF
> RFC 7771. The amendment is targeted for consent at the September 2016
> plenary meeting of SG15.
> >
> > ITU-T Q9/15 has also been made aware of the initiation of work on
> MPLS-TP Shared-Ring protection (MSRP) mechanism for ring topology in
> draft-ietf-mpls-tp-shared-ring-protection-00, and has consequently
> re-initiated work on draft Recommendation ITU-T G.8132/Y.1383 Ring
> protection switching for MPLS transport profile. As ITU-T Q9/15 intends to
> reference and be aligned with corresponding normative RFCs, we would
> appreciate your assessment of the anticipated completion date for
> draft-ietf-mpls-tp-shared-ring-protection as the target consent date for
> draft Recommendation ITU-T G.8132/Y.1383 depends on it.
> > Attachments:
> >
> >      Liaison
> >
> >