Subject: Re: [mpls] [Bier] problem bier-mpls-encap-sraft

From: Xuxiaohu <[email-masked]>
Date: Wed, 9 Mar 2016 02:17:42 +0000

From: BIER [mailto:[email-masked]] On Behalf Of Tony Przygienda
Sent: Tuesday, March 01, 2016 1:12 PM
To: David Mozes
Cc: [email-masked]
Subject: Re: [Bier] problem bier-mpls-encap-sraft

David,

1) there was a longish discussion on the list about the 4 bits and the value chosen & the DPI-ECMP problem. I suggest to read the archives. the problem is not specific to BIER. Actually, I recently heard a suggestion that we should provide from IETF side a registry for the values in the 4 bits but it's A-Ds business, not WG level IMO (if there isn't such a registry for 'IP versions' already).

Wouldn’t be better to define a protocol field in the MPLS label stack (e.g., https://tools.ietf.org/html/draft-xu-mpls-payload-protocol-identifier) rather than interfering  in the definition of the 4-bit of the MPLS payload?

Best regards,
Xiaohu

2) The length is present for analytics tools but silicon MUST NOT use it to derive the length but the length is implied in the label. It's simply architectural DRY. If you repeat semantically the length implied in the label, you'll end up with error scenarios you need to provide for. Actually, the draft already mandates that on mismatch the packet SHOULD be discarded (which means silicon doesn't actually need to check it if it wants to go at max. speed).

Generally, sweeping assertions like "using the label as the bier identifier on the packet as well as the bit string length is not a good approach for HW/Silicon supporting" would need a little more elaboration as to what they're based upon ?

thanks

--- tony

On Mon, Feb 29, 2016 at 9:02 PM, David Mozes <[email-masked]<mailto:[email-masked]>> wrote:
Hi * ,
I have problems with the MPLS encap draft  .

I thing using the label as the bier identifier on the packet as well as the bit string length is not a good approach for HW/Silicon supporting  .
This make the support difficult  and very unique,especially to intermedia node that not supporting MPLS  entropy label  and like   to support ECMP by deep looking inside the IP header .
I think we should :

1)      Define some protocol type or control  word  to strictly detect the beir header . Or define the guessing of the first 4 bits as a valid parsing  approach  .

2)      Make the  bits string  length inside the bear header as  mandatory  .

This will help a lot

Your thought  ?
Thx

_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier

--
We’ve heard that a million monkeys at a million keyboards could produce the complete works of Shakespeare; now, thanks to the Internet, we know that is not true.
—Robert Wilensky

---

From: David Mozes <[email-masked]>
Date: Wed, 9 Mar 2016 16:43:35 +0000

Hi ,
I can’t open  the doc  .
From: Xuxiaohu [mailto:[email-masked]]
Sent: Wednesday, March 09, 2016 4:18 AM
To: Tony Przygienda <[email-masked]>; David Mozes <[email-masked]>
Cc: [email-masked]; [email-masked]' <[email-masked]>
Subject: RE: [Bier] problem bier-mpls-encap-sraft

From: BIER [mailto:[email-masked]] On Behalf Of Tony Przygienda
Sent: Tuesday, March 01, 2016 1:12 PM
To: David Mozes
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Bier] problem bier-mpls-encap-sraft

David,

Best regards,
Xiaohu

thanks

--- tony

This will help a lot

Your thought  ?
Thx