Subject: [mpls] working group last call on draft-ietf-mpls-bfd-directed-02.txt

From: Ross Callon <[email-masked]>
Date: Fri, 11 Mar 2016 17:12:57 +0000

Working Group,

This is to initiate a two week working group last call on draft-ietf-mpls-bfd-directed-02.txt.

Please send your comments to the mpls wg mailing list ([email-masked]<mailto:[email-masked]>).

There is one IPR disclosure on draft-mirsky-mpls-bfd-directed
(which was the pre-working group version of draft-ietf-mpls-bfd-directed):
https://datatracker.ietf.org/ipr/2625/
All the authors have stated that they are not aware of any other IPR that relates to this
draft.

This working group last call will end at the end of the day Friday March 25, 2016.

As with any WGLC, working group participants are requested to read the document
and comment. If you feel that the document is ready for publication it is appropriate to
respond to any WGLC with a short and simple email indicating support.

Ross
for the MPLS WG chairs

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 11 Mar 2016 17:34:36 -0000

Ross, thanks for this notice.
 
I need to read the IPR referenced by the disclosure, but pending that, I do not
support this document going forward in its current state.
 
I think it is important for the working group to seek to develop solutions that
either completely unencumbered by IPR or that is available on
free-to-implementers terms. It may turn out that this is not possible with the
disclosed IPR, but I think the WG should try.
 
For the avoidance of doubt: I am not making any comment on the IPR-holder's
rights to impose whatever license they want, and I am not asking them to vary
their terms. 
 
I do not that it would be convenient if the IPR holder updated the disclosure to
show that it applies to the current WG draft.
 
Thanks,
Adrian
 
From: mpls [mailto:[email-masked]] On Behalf Of Ross Callon
Sent: 11 March 2016 17:13
To: [email-masked]
Cc: [email-masked]
Subject: [mpls] working group last call on draft-ietf-mpls-bfd-directed-02.txt
 
Working Group,
 
This is to initiate a two week working group last call on
draft-ietf-mpls-bfd-directed-02.txt. 
 
Please send your comments to the mpls wg mailing list ( <mailto:[email-masked]>
[email-masked]).
 
There is one IPR disclosure on draft-mirsky-mpls-bfd-directed 
(which was the pre-working group version of draft-ietf-mpls-bfd-directed): 
 <https://datatracker.ietf.org/ipr/2625/> https://datatracker.ietf.org/ipr/2625/

All the authors have stated that they are not aware of any other IPR that
relates to this
draft.
 
This working group last call will end at the end of the day Friday March 25,
2016.  
 
As with any WGLC, working group participants are requested to read the document 
and comment. If you feel that the document is ready for publication it is
appropriate to 
respond to any WGLC with a short and simple email indicating support. 
 
Ross
for the MPLS WG chairs

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 11 Mar 2016 17:56:53 -0000

> I do not that it would be convenient if the IPR holder updated the disclosure
to show that it applies to the current WG draft.

s/not/note/

---

From: Ross Callon <[email-masked]>
Date: Fri, 11 Mar 2016 18:52:30 +0000

> I think it is important for the working group to seek to develop solutions that either completely
> unencumbered by IPR or that is available on free-to-implementers terms.

My understanding of the process (which I really *should* know by now, but I am sure someone
will correct me if I get this wrong):

- As a working group, we get to decide by rough consensus of the working group whether or not
we are willing to progress a document, based on whatever criteria we want including whether or
not the technology is available on "free-to-implement terms".

- As a working group, we DO NOT get to decide whether or not any particular IPR is valid and we
should not be making any statements about this (and I note that Adrian did not make any statement
about validity).

Thanks, Ross (as WG co-chair)

From: Adrian Farrel [mailto:[email-masked]]
Sent: Friday, March 11, 2016 12:35 PM
To: Ross Callon; [email-masked]
Cc: [email-masked]
Subject: RE: [mpls] working group last call on draft-ietf-mpls-bfd-directed-02.txt

I need to read the IPR referenced by the disclosure, but pending that, I do not support this document going forward in its current state.

I think it is important for the working group to seek to develop solutions that either completely unencumbered by IPR or that is available on free-to-implementers terms. It may turn out that this is not possible with the disclosed IPR, but I think the WG should try.

For the avoidance of doubt: I am not making any comment on the IPR-holder's rights to impose whatever license they want, and I am not asking them to vary their terms.

I do not that it would be convenient if the IPR holder updated the disclosure to show that it applies to the current WG draft.

Thanks,
Adrian

From: mpls [mailto:[email-masked]] On Behalf Of Ross Callon
Sent: 11 March 2016 17:13
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [mpls] working group last call on draft-ietf-mpls-bfd-directed-02.txt

Working Group,

Ross
for the MPLS WG chairs

---

From: David Allan I <[email-masked]>
Date: Fri, 18 Mar 2016 18:25:36 +0000

Hmmm

Truth in advertising here; IMO my employer's  policy is "disclose early, disclose often and license RAND" as good corporate citizens. The IPR in question was disclosed on the MPLS  list in July of 2015 (I just checked the archive).

If there is a reasonable expectation of an unencumbered alternative then seeking an alternative make sense, but the appropriate disclosure has been out there for 9+ months, and no alternative would appear to be forthcoming. Suddenly seeking one now seems to be just a bit counter productive....

So to me the only real question is "does the WG think this is a problem worth solving". I would think the answer to that is a self-evident "yes"

My 2 cents
Dave

From: mpls [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Friday, March 11, 2016 9:35 AM
To: 'Ross Callon'; [email-masked]
Cc: [email-masked]
Subject: Re: [mpls] working group last call on draft-ietf-mpls-bfd-directed-02.txt

Thanks,
Adrian

Working Group,

Ross
for the MPLS WG chairs

---

From: Ross Callon <[email-masked]>
Date: Mon, 21 Mar 2016 18:37:32 +0000

Please note that this working group last call is still open, and to this point we have only received two responses (from Adrian and Dave Allan).

I would like to encourage others to look at the document and to respond to the WGLC.

Thanks, Ross

From: Ross Callon [mailto:[email-masked]]
Sent: Friday, March 11, 2016 12:13 PM
To: [email-masked]
Cc: [email-masked]; Gregory Mirsky; Jeff Tantsura; Ilya Varlashkin; Mach Chen
Subject: working group last call on draft-ietf-mpls-bfd-directed-02.txt

Working Group,

Ross
for the MPLS WG chairs

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 21 Mar 2016 16:37:33 -0400

Ross,

I just read the draft, and while I don’t have any specific comments on the
text, I do support its publication as an RFC.

Cheers,
Andy

On Mon, Mar 21, 2016 at 2:37 PM, Ross Callon <[email-masked]> wrote:

> Please note that this working group last call is still open, and to this
> point we have only received two responses (from Adrian and Dave Allan).
>
>
>
> *From:* Ross Callon [mailto:[email-masked]]
> *Sent:* Friday, March 11, 2016 12:13 PM
> *To:* [email-masked]
> *Cc:* [email-masked]; Gregory Mirsky; Jeff Tantsura; Ilya
> Varlashkin; Mach Chen
> *Subject:* working group last call on draft-ietf-mpls-bfd-directed-02.txt
>
>
>
> Working Group,
>
>
>
> Please send your comments to the mpls wg mailing list ([email-masked]).
>
>
>
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>
>

---

From: Ross Callon <[email-masked]>
Date: Mon, 28 Mar 2016 00:23:12 +0000

This working group last call has ended. We have failed to reach consensus and therefore the working group last call has failed.

As document shepherd, while at the IETF in Buenos Aires I will attempt to meet with the authors and people who commented on the draft, to see if we can figure out a reasonable way forward. We will keep the WG informed of any progress (or lack thereof). Assuming we can find a reasonable way forward, then the working group last call will need to be repeated before the document can be progressed.

Thanks, Ross
(as document shepherd and WG co-chair).

Working Group,

Ross
for the MPLS WG chairs