Subject: [mpls] [Technical Errata Reported] RFC3209 (4733)

From: RFC Errata System <[email-masked]>
Date: Wed, 6 Jul 2016 02:53:53 -0700 (PDT)

The following errata report has been submitted for RFC3209,
"RSVP-TE: Extensions to RSVP for LSP Tunnels".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=3209&eid=4733

--------------------------------------
Type: Technical
Reported by: Ramakrishna DTV <[email-masked]>

Section: 4.3.2

Original Text
-------------
   To formalize the discussion, we call each group of nodes an abstract
   node.  Thus, we say that an explicit route is a specification of a
   set of abstract nodes to be traversed.  If an abstract node consists
   of only one node, we refer to it as a simple abstract node.

Corrected Text
--------------
   To formalize the discussion, we call each group of nodes an abstract
   node.  Thus, we say that an explicit route is a specification of a
   sequence of abstract nodes to be traversed.  If an abstract node 
   consists of only one node, we refer to it as a simple abstract node.

Notes
-----
s/set/sequence

A set implies ordering of abstract nodes is NOT important.
A sequence implies ordering of abstract nodes IS important.

In the rest of RFC 3209, this distinction is maintained, but not
in this paragraph.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC3209 (draft-ietf-mpls-rsvp-lsp-tunnel-09)
--------------------------------------
Title               : RSVP-TE: Extensions to RSVP for LSP Tunnels
Publication Date    : December 2001
Author(s)           : D. Awduche, L. Berger, D. Gan, T. Li, V. Srinivasan, G. Swallow
Category            : PROPOSED STANDARD
Source              : Multiprotocol Label Switching
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: Alexander Vainshtein <[email-masked]>
Date: Wed, 6 Jul 2016 11:03:06 +0000

Hi all,

>From my POV the comment is obviously correct.

However, I strongly doubt that in the 15 years that have passed after publication of RFC 3209 any implementer of RSVP-TE (or any operator using RSVP-TE) really did not understand that an explicit route is an ordered set of abstract nodes.

May I suggest that it is re-classified from Technical to Editorial and hold for update of RFC 3209 until such time it is progressed to Standard?

Regards,

Sasha

Office: +972-39266302

Cell:      +972-549266302

Email:   [email-masked]

-----Original Message-----
From: mpls [mailto:[email-masked]] On Behalf Of RFC Errata System
Sent: Wednesday, July 06, 2016 12:54 PM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [mpls] [Technical Errata Reported] RFC3209 (4733)

Type: Technical

Reported by: Ramakrishna DTV <[email-masked]<mailto:[email-masked]>>

Section: 4.3.2

Original Text

-------------

Corrected Text

--------------

Notes

-----

s/set/sequence

In the rest of RFC 3209, this distinction is maintained, but not in this paragraph.

Instructions:

-------------

This erratum is currently posted as "Reported". If necessary, please use "Reply All" to discuss whether it should be verified or rejected. When a decision is reached, the verifying party (IESG) can log in to change the status and edit the report, if necessary.

Area                : Routing

Stream              : IETF

Verifying Party     : IESG

_______________________________________________

mpls mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/mpls

---

From: "George Swallow -X (swallow - CLEARPATH WORKFORCE MANAGEMENT INC at Cisco)" <[email-masked]>
Date: Fri, 8 Jul 2016 15:25:12 +0000

I totally agree that this is an improvement.  I don't really see it as an
error.  Since the rest of the document is clear that sequence is important
I doubt that anyone seriously stumbled over this.

Suggest we mark this one "hold for update".

George