Subject: [mpls] Robert Wilton's No Objection on draft-ietf-mpls-spl-terminology-05: (with COMMENT)

From: Robert Wilton via Datatracker <[email-masked]>
Date: Sun, 17 Jan 2021 01:00:21 -0800

Robert Wilton has entered the following ballot position for
draft-ietf-mpls-spl-terminology-05: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-mpls-spl-terminology/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Only a minor editorial comment: I was surprised to see "name space" used instead of "namespace".

---

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 17 Jan 2021 10:46:12 -0000

Hi Robert,

We like to surprise you. It keeps you fresh and on your toes. And it provides a learning opportunity.

"namespace" is a word coined in the computing industry where it seems to be in regular use, but the mainstream dictionaries haven't caught up fully.

For example, https://dictionary.cambridge.org/ https://www.collinsdictionary.com/ https://www.merriam-webster.com/ and https://www.dictionary.com/ (Random House) don't have entries for "namespace".

Best,
Adrian

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 18 Jan 2021 15:29:17 +0000

I use the OED as my definitive source of reference for the English language and it shows first use in 1975

1975    B. C. Goldstein & T. W. Scrutchin in  Proc. 2nd Ann. Symposium on Computer Archit. <> (Assoc. Computing Machinery) 215/1   A local namespace is associated with each i-stream. Through the name space, the i-stream has access to other namespaces.

Interesting in that they cannot make up their minds so it looks like it might have been invented as a typo.

The 1981 entry looks more definitive

1981    R. C. Murray Namespaces in  APL Quote Quad: APL Conf. Proc. <> 12 221/2   Newly created Namespaces allow direct modification in either direction to facilitate the definition and construction of appropriate environments on each side of the Namespace boundary.

- Stewart

> On 17 Jan 2021, at 10:46, Adrian Farrel <[email-masked]> wrote:
> 
> Hi Robert,
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls