Subject: Re: [mpls] MPLS WG poll on making draft-ietf-mpls-rmr

From: Shraddha Hegde <[email-masked]>
Date: Thu, 7 Jan 2021 08:29:46 +0000

Loa,

RMR provides a good solution for the ring topologies
And I support publishing as experimental RFC.

Rgds
Shraddha

Juniper Business Use Only

-----Original Message-----
From: mpls <[email-masked]> On Behalf Of Loa Andersson
Sent: Friday, December 18, 2020 10:38 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: [mpls] MPLS WG poll on making draft-ietf-mpls-rmr

[External Email. Be cautious of content]

Working Group,

This is to start a "two week" poll on publishing draft-ietf-mpls-rmr as an Experimental RFC.

Mid-September the responsible AD sent draft-ietf-mpls-rmr back to the working group. The direct reason was that there did not seem to be any interest by the authors to respond to the IESG review.

The working group chairs took the action start a poll in the working group to see if there were interest (in the wg) to continue progress the document.

There were no other responses, than from the two authors, to this poll, and the wg chairs agree that there are no documented interest to progress the draft in the current format.

The logical action would have been kill the draft.

However, we have been asked id we could make the document Experimental.
Obviously this will generate problems with down refs and code point allocation. But after carefully going through the documents, with some innovative writing it the Shepherds Write-Up, this could be managed.

Please respond to the following questions.

If draft-ietf-mpls-rmr were made an Experimental document

- do you think draft-ietf-mpls-rmr is needed and will actually be
   deployed?

- do you have the cycles to contribute to progress and review the
   document?

- are there interest to progress the document in this fashion?

/Loa
for the MPLS wg chairs

--

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Bronze Dragon Consulting             phone: +46 739 81 21 64

_______________________________________________
mpls mailing list
[email-masked]
https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/mpls__;!!NEt6yMaO-gk!UKr5-LuhYnxpPKnqcH1pPTHgVxZhHsKzkx64xB7FHPLVUKLPLbrOi1bbZ-G8G16D$

---

From: LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>
Date: Thu, 7 Jan 2021 08:50:28 +0000

Hi Loa, all,

I support (as co-author) to progress this draft as experimental.

Regarding the proposed questions:

- do you think draft-ietf-mpls-rmr is needed and will actually be
   deployed?
Answer - draft-ietf-mpls-rmr addresses a specific but largely common topology scenario in current operational networks, which is the ring structure present in backhaul / aggregation networks. Thus, it intends to provide enhancements on the provision, operation and reconfiguration of LSPs there, which can be highly beneficial for operators.

- do you have the cycles to contribute to progress and review the
   document?
Answer - From co-author perspective, the document has addressed all the received comments. If further comments are received, I can commit cycles to address them

- are there interest to progress the document in this fashion?
Answer - From both co-author and operator perspectives, yes.

Apologies for the long time to answer, I was in vacation period.

Best regards

Luis

-----Mensaje original-----
De: Shraddha Hegde <[email-masked]>
Enviado el: jueves, 7 de enero de 2021 9:30
Para: Loa Andersson <[email-masked]>; [email-masked]; [email-masked]
CC: [email-masked]
Asunto: RE: [mpls] MPLS WG poll on making draft-ietf-mpls-rmr

Loa,

RMR provides a good solution for the ring topologies And I support publishing as experimental RFC.

Rgds
Shraddha

-----Original Message-----
From: mpls <[email-masked]> On Behalf Of Loa Andersson
Sent: Friday, December 18, 2020 10:38 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: [mpls] MPLS WG poll on making draft-ietf-mpls-rmr

Working Group,

The working group chairs took the action start a poll in the working group to see if there were interest (in the wg) to continue progress the document

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Kireeti Kompella <[email-masked]>
Date: Tue, 12 Jan 2021 10:14:23 -0800

Hi Loa,

- I believe the technology in this document will be deployed;
- I have the cycles to progress this document;
- there is interest to progress this as Expt.

Kireeti

On Dec 18, 2020, at 18:35, Loa Andersson <[email-masked]> wrote:

> Workig Group,
> 
> When I sent this out I was uncertain on the date to close the poll, I said "two week" poll. I let us get through the holidays and count from January 1st, the du date is Junauary 14, 2021.
> 
> /Loa
> 
> On 18/12/2020 13:07, Loa Andersson wrote:
> Working Group,
> 
> Mid-September the responsible AD sent draft-ietf-mpls-rmr back to the
> working group. The direct reason was that there did not seem to be any
> interest by the authors to respond to the IESG review.
> 
> The working group chairs took the action start a poll in the working
> group to see if there were interest (in the wg) to continue progress the
> document.
> 
> There were no other responses, than from the two authors, to this poll,
> and the wg chairs agree that there are no documented interest to
> progress the draft in the current format.
> 
> Obviously this will generate problems with down refs and code point
> allocation. But after carefully going through the documents, with some
> innovative writing it the Shepherds Write-Up, this could be managed.
>

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 12 Jan 2021 18:32:36 +0000

> On 12 Jan 2021, at 18:14, Kireeti Kompella <[email-masked]> wrote:
> 

I think that it would be interesting to initially  progress this as experimental.

We can re-spin it on ST  if/when experience is gained and if operators start to significantly  deploy.

- Stewart

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 12 Jan 2021 10:40:12 -0800

Hi Loa,

I believe the technology described is going to be deployed.
I don’t have cycles to contribute but can review the document.
I’d support the progress as experimental.

Cheers,
Jeff
On Dec 18, 2020, 6:35 PM -0800, Loa Andersson <[email-masked]>, wrote:
> Workig Group,
>
> When I sent this out I was uncertain on the date to close the poll, I
> said "two week" poll. I let us get through the holidays and count from
> January 1st, the du date is Junauary 14, 2021.
>
> /Loa
>
> https://www.ietf.org/mailman/listinfo/mpls

---

From: Huub van Helvoort <[email-masked]>
Date: Tue, 12 Jan 2021 21:30:32 +0100

Hej Loa,

> - do you think draft-ietf-mpls-rmr is needed and will actually be

I think it is not needed, there is already RFC8227 which is
deployed widely.

> - do you have the cycles to contribute to progress and review the

I don't have and will not seek cycles to progress this document.

> - are there interest to progress the document in this fashion?

No.

Best regards, Huub.

-- 
================================================================
Always remember that you are unique...just like everyone else...

---

From: Vishnu Pavan Beeram <[email-masked]>
Date: Tue, 12 Jan 2021 20:33:27 -0600

I support the progress of this document as "experimental".

I do believe that this work will get deployed and I do have cycles to
contribute/review.

Regards,
-Pavan

---

From: Chandrasekar Ramachandran <[email-masked]>
Date: Wed, 13 Jan 2021 04:09:57 +0000

I think draft-ietf-mpls-rmr is needed and will actually be deployed.
I support the progress of the document as experimental.

Thanks,
Chandra.

>     - are there interest to progress the document in this fashion?

Juniper Public

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 13 Jan 2021 12:06:27 -0000

Hi Loa, all,

>> - do you think draft-ietf-mpls-rmr is needed and will actually be

Hard to know. An even earlier question would be, "Do you think that this draft will find its way into shipping product."

Rings are important in some MPLS networks, and having a solution (possibly this one) would seem a good thing, but the level of excitement on the list would seem to suggest that there isn't a push for the function at the moment.

> - do you have the cycles to contribute to progress and review the

Not really.

> - are there interest to progress the document in this fashion?

I wouldn't object, but I note that moving to Experimental is not just changing a word at the top of the document. 
What is the scope of the experiment?
How is the conclusion of the experiment assessed?
What happens if there is a mix of nodes some of which are not participating in the experiment?

Cheers,
Adrian

---

From: Colby Barth <[email-masked]>
Date: Thu, 14 Jan 2021 08:58:40 -0500

Hi,
 
I support the progress of this document as "experimental”.

I have the availability to contribute and review the document.

I think that this technology will get deployed.
 
Thanks,

--Colby

> On Dec 18, 2020, at 12:07 AM, Loa Andersson <[email-masked]> wrote:
> 
> Working Group,
>

---

From: Di Giglio Andrea <[email-masked]>
Date: Fri, 15 Jan 2021 13:23:27 +0000

Support 

Andrea 

-----Messaggio originale-----
Da: mpls [mailto:[email-masked]] Per conto di Loa Andersson
Inviato: sabato 19 dicembre 2020 03:34
A: [email-masked]; [email-masked]
Cc: [email-masked]
Oggetto: [EXT] [mpls] Resend: MPLS WG poll on making draft-ietf-mpls-rmr an Experimental RFC

Workig Group,

/Loa

This is to start a "two week" poll on publishing draft-ietf-mpls-rmr as
an Experimental RFC.

/Loa
for the MPLS wg chairs

-- 

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie. 

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks. 

Rispetta l'ambiente. Non stampare questa mail se non è necessario.

---

From: Loa Andersson <[email-masked]>
Date: Thu, 21 Jan 2021 14:01:47 +0800

Working Group,

This poll is closed . the chair will need a few days to write down the 
consensus call.

/Loa

--