Subject: [mpls] flag fields in John's prposal

From: Loa Andersson <[email-masked]>
Date: Thu, 6 Jan 2022 22:16:10 +0800

John,

In your current text on the wiki you have one paragraph saying:
   "The NFFs are encoded in a set of one or more LSEs, where each LSE
    consists of a 1 bit continuation field followed by 19 bits of NFFs,
    the BoS field, and 11 bits of NFFs"

This would give us 30 flags per LSE, however I can't see that it works, 
unless you have a method to indicate that the entry after the SPL are 
flag fields, not an LSEs.

If you try to do this by using an SPL value for actions depending on ISD 
and another for actions that depends on PSD, then we have have a very 
tough fight to fight for allocating 25% of the free labels for this purpose.

It seems unlikely that you will get 2 SPLs allocated for this purpose, 
especially since it is proven that one is sufficient.

/Loa
-- 
Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: John E Drake <[email-masked]>
Date: Thu, 6 Jan 2022 14:39:07 +0000

Loa,

Comments inline below.	

Yours Irrespectively,

John

Juniper Business Use Only

> -----Original Message-----
> From: Loa Andersson <[email-masked]>
> Sent: Thursday, January 6, 2022 9:16 AM
> To: John E Drake <[email-masked]>; [email-masked]
> Subject: flag fields in John's prposal
> 
> [External Email. Be cautious of content]
> 
> 
> John,
> 
> This would give us 30 flags per LSE, however I can't see that it works, unless you
> have a method to indicate that the entry after the SPL are flag fields, not an
> LSEs.

[JD]  The SPL identifies what follows as a network action label stack block.  What follows
the SPL is a set of one or more LSEs containing flags.  The continuation field is used to  delimit
the set of LSEs containing flags.  What follows the set of LSEs containing flags is a set of
LSEs containing in-stack ancillary data.  

> 
> If you try to do this by using an SPL value for actions depending on ISD and
> another for actions that depends on PSD, then we have have a very tough fight
> to fight for allocating 25% of the free labels for this purpose.

[JD]  As I have said before the definition of a network action includes whether that action
has ancillary data, what is that ancillary data, and if that ancillary data is in-stack or post-stack.
So, when a P router sees a packet with a network actions label stack block, based upon
which network action flags are set, it knows exactly the structure of the in-stack ancillary
data. 

> 
> It seems unlikely that you will get 2 SPLs allocated for this purpose, especially
> since it is proven that one is sufficient.
> 
> /Loa
> --