Subject: Re: MSDP spec 14

From: David Meyer <[email-masked]>
Date: Thu, 21 Nov 2002 09:41:37 -0800

All, Toreless summarized the answers to these questions very
well. Are there other issues (with Notification or otherwise)?

Thanks,

Dave

On Wed, Nov 20, 2002 at 05:47:15AM -0800, Toerless Eckert wrote:
>> On Wed, Nov 20, 2002 at 07:37:53PM +0800, Guo Feng wrote:
>> > Two questions:
>> >
>> > 1.Why is the notification TLV removed ?
>> 
>> Because it is not supported in all of the existing implementations
>> and operational practice in the current deployed Internets MSDP
>> infrastructure seem to have shown that that is not a mayor loss -
>> aka: the notification TLVs do not seem to be urgently required to
>> interoperate MSDP.
>> 
>> > 2.There are no description about Request and Response TLV Function , will
>> > those two TLVs be obsolete ?
>> 
>> None of the things removed from the spec are obsolete, they are
>> just not part of the MSP spec anymore: We have circled for several years
>> around the approach to make a short term solution as good as possible and
>> did not get anywhere. Now we have changed the goal to only include
>> what can considered to be minimally needed to interoperate MSDP
>> and to provide a base functionality that has shown to be implemented
>> by the majority of implementations available and deployed.
>> 
>> If a vendor wants to provide this or any other function that at one point
>> in time was (or was not) in the MSDP spec, then he simply adds it to his
>> implementation. He only need to figure out then how to keep his implementation
>> interoperable with the base of MSDP which is specified in the MSDP spec.
>> There are lots of possibilities on how to do this.
>> 
>> Cheers
>> 	Toerless
>> >
>> > ----- Original Message -----
>> > From: "David Meyer" <[email-masked]>
>> > To: <[email-masked]>;
>> > <[email-masked]>
>> > Sent: Tuesday, November 19, 2002 5:52 AM
>> > Subject: Re: MSDP spec 14
>> >
>> >
>> > > >> As discussed today in mboned wg:
>> > > >>
>> > > >> http://www.ietf.org/internet-drafts/draft-ietf-msdp-spec-14.txt
>> > > >>
>> > >
>> > > Folks, this is the official start of the WG Last call on this
>> > > document. Comments to the list.
>> > >
>> > > Thanks,
>> > >
>> > > Dave
>> > >
>> > >
>> >
>> >
>> 
>> -- 
>> Thanks
>>    Toerless Eckert
>>

---

From: David Meyer <[email-masked]>
Date: Thu, 21 Nov 2002 09:41:37 -0800

Thanks,

Dave