Subject: Re: [Mud] Review of draft-richardson-mud-qrcode-02

From: Michael Richardson <[email-masked]>
Date: Fri, 24 Dec 2021 12:37:46 -0500

Marco Tiloca <[email-masked]> wrote:
    > On the second point, it may just fit as a short paragraph in Section 6
    > "Privacy Considerations". For instance:

    > "The use of URL shorting services discussed in Section 3.2.4 may result in
    > trading convenience and efficiency with privacy, since the service provider
    > might leverage per-device or per-customer short URLs to track and correlate
    > requests."

I've added this to https://github.com/mcr/mud-qrcode/pull/4

    > Thanks, I guess these points are also covered in the cited
    > mud-acceptable-urls . I think it would be good have them briefly included in
    > this document too, along the same lines in your reply above.

Added above too.

    >> > * I think it would be good to add considerations on the security of the
    >> > (access to the) physical premises, and on the trust required on the network
    >> > operators performing device deployment and QRcode scanning on those
    >> > premises.
    >>
    >> Are you thinking about a situation where the devices are deployed on a
    >> campus, and employees or students could attach new stickers to the device?

    > ==>MT
    > Yes, and to possible active actions from QRcode examiners as hinted in the
    > review at [1].

    > [1]
    > https://datatracker.ietf.org/doc/review-richardson-mud-qrcode-02-iotdir-early-jimenez-2021-11-25/

okay, so I think that I've added text about this already.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Marco Tiloca <[email-masked]>
Date: Fri, 24 Dec 2021 19:48:28 +0100

Hi Michael,

Thanks, it looks good!

Best,
/Marco

-- 
Marco Tiloca
Ph.D., Senior Researcher

Division: Digital System
Department: Computer Science
Unit: Cybersecurity

RISE Research Institutes of Sweden
https://www.ri.se

Phone: +46 (0)70 60 46 501
Isafjordsgatan 22 / Kistagången 16
SE-164 40 Kista (Sweden)