Subject: [multimob] IGMP/MLD on PtP Links

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 3 Sep 2007 12:58:09 -0700 (PDT)

Hello all,
  I remember this has shortly been discussed in the pre-BOF at Chicago. If the link is point-to-point as it is the case for all cellular links 3gpp/2 and WiMAX, 

a) do we need IGMP/MLD on PtP links? 

b) if yes,  should the designs of these protocols be revisited?

Chip in your views here.

Thanks,

Behcet

_______________________________________________
multimob mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/multimob

---

From: John Zwiebel <[email-masked]>
Date: Mon, 3 Sep 2007 13:06:29 -0700

On Sep 3, 2007, at 12:58 PM, Behcet Sarikaya wrote:

>   I remember this has shortly been discussed in the pre-BOF at  
> Chicago. If the link is point-to-point as it is the case for all  
> cellular links 3gpp/2 and WiMAX,
>

assuming a host on one end and a router/switch on the other, you need
something to signal the host's desire to receive multicast.  It doesn't
have to be IGMP/MLD.

> b) if yes,  should the designs of these protocols be revisited?

In what way?

One can already configure the router/switch end for "immediate leave"
meaning no waiting for any reports to overrule a leave.  And explicit
host tracking is available for IGMPv3.

---

From: Joel Jaeggli <[email-masked]>
Date: Mon, 03 Sep 2007 15:33:30 -0700

> something to signal the host's desire to receive multicast.  It doesn't

A host in a ptp situation could use pim, but igmpv3/mldv2 to seem like
they've been blessed with being the host signaling protocol I'm not sure
that being connected over l2tp or pppoe would make a difference.

> ------------------------------------------------------------------------
>

---

From: "Alvaro Fernandez" <[email-masked]>
Date: Tue, 4 Sep 2007 15:18:31 +0200

Hi:
 
John said:

When you say this, are you referring to IGMPv3 RFC 3376 or to "ip igmp explicit-tracking" command in Cisco routers? The Cisco manual do not explain very well this command.
 
" Explicit host tracking"  is a different feature in Cisco Routers or is the normal host tracking explained in RFC 3376?
 
Thanks and regards
Alvaro

________________________________

De: John Zwiebel [mailto:[email-masked]]
Enviado el: lun 03/09/2007 22:06
Para: Behcet Sarikaya
CC: [email-masked]
Asunto: Re: [multimob] IGMP/MLD on PtP Links

	

In what way?

---

From: Marshall Eubanks <[email-masked]>
Date: Tue, 4 Sep 2007 12:39:15 -0400

> something to signal the host's desire to receive multicast.  It  

But it there a good reason why it shouldn't be ? I am sending this  
email from a Laptop attached to a Sprint
EVD0 device. If this supported Multimob, what it is the benefit of  
translating the box's IGMP to some other, yet to be defined protocol ?

It has taken us almost a decade to move from IGMPv2 to v3 and we are  
not entirely there yet. Don't introduce another multicast edge  
protocol unless you are forced to.

Regards
Marshall

---

From: John Zwiebel <[email-masked]>
Date: Tue, 4 Sep 2007 09:47:19 -0700

On Sep 4, 2007, at 9:39 AM, Marshall Eubanks wrote:

>
> But it there a good reason why it shouldn't be ?

What you meant was, "why not use IGMPv3 for multimob".

I couldn't begin to guess, which was why I asked why
Behcet was suggesting IGMP be modified.  ie, what
is it he thinks is broken in IGMP that needs to be fixed.