Subject: [multimob] Request for agenda items

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 7 May 2010 08:43:08 -0700 (PDT)

The chairs have requested a meeting slot for the Maastricht IETF.
If you have items you wish to discuss during the face-to-face meeting,
please send the chairs an email.

For Maastricht, -00 drafts
must be posted by July 5th and revised drafts posted by July 12th.

---

From: <[email-masked]>
Date: Tue, 11 May 2010 10:56:39 +0200

Dear all,
>From the official charter we should have achieved a milestone in 

Apr 2010  Submit a document on how to tune IGMPv3/MLDv2 for mobility, for publication as either Informational or Best Current Practice  

Here we still have no WG draft approved but had a discussion on the tuning and/or optimization issues after Anaheim meeting. According to meeting minutes a cooperation between both draft authors was proposed - have you already achieved progress here? Reason for the question is also to identify which parts of optimization should be seen as protocol change  - so it would fit to future work items (which should also be discussed in Maastricht).
Any ideas and suggestions?

For the agenda I think we additionally have to further discuss improvements of the existing WG draft explaining the use of multicast in PMIPv6 http://datatracker.ietf.org/doc/draft-ietf-multimob-pmipv6-base-solution/ (which has also been due last month) ...

Best regards
Dirk 

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Behcet Sarikaya
Gesendet: Freitag, 7. Mai 2010 17:43
An: [email-masked]
Betreff: [multimob] Request for agenda items

      
_______________________________________________
multimob mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/multimob

---

From: Qin Wu <[email-masked]>
Date: Tue, 11 May 2010 19:49:58 +0800

Hi, chairs:
We are working on updating draft-wu-multimob-igmp-mld-tuning based on the comments received from Anaheim meeting. The progress we have is we re-evaluate different different wireless link models and analyze their impact on IGMP/MLD and also we have discoupled the protocol change from IGMP/MLD tuning operation, especially the change to the host stack is removed. The new version I-D will be ready soon.
As regarding the question on identifying which parts of optimization should be seen as protocol change, the anwer will be addressed later in the separate email.

Regards!
-Qin
----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Sent: Tuesday, May 11, 2010 4:56 PM
Subject: Re: [multimob] Request for agenda items

Dear all,

Best regards
Dirk

---

From: <[email-masked]>
Date: Tue, 11 May 2010 17:23:26 +0200

Hi all,
Forwarding Hitoshis mail below...
So we can expect updated drafts on IGMP/MLD tuning by both Hitoshi and Qin before IETF-78 - sounds great, thanks a lot! 

Regards
Dirk 

-----Ursprüngliche Nachricht-----
Von: Hitoshi Asaeda [mailto:[email-masked]] 
Gesendet: Dienstag, 11. Mai 2010 17:00
An: von Hugo, Dirk
Cc: [email-masked]
Betreff: Re: [multimob] Request for agenda items

Hi Dirk,

There was the discussion that the important thing for igmp/mld tuning
draft is to provide more concrete analysis about various timers. It
requires mathematical or feasible simulation basis analysis.
I and my coleagues have been developing simulation code for such
analytic approach and hope we'd be able to give some improvement for
our draft before the next meeting.

Regards,
--
Hitoshi Asaeda

---

From: "Rahman, Akbar" <[email-masked]>
Date: Tue, 11 May 2010 11:47:01 -0400

Hi Behcet/Stig,

We would like to request a slot at the IETF 78 meeting to discuss our
draft for enhancing multicast operation using the Dedicated Multicast
LMA approach.  Please note that we will have an update of our draft
shortly.  Also, after that update we will contact some of the other
authors working on related multicast enhancements to see if they would
like to merge with our draft (as per the suggestion from Anaheim).

Sincerely,

Akbar/Juan-Carlos/Guang

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Behcet Sarikaya
Sent: Friday, May 07, 2010 11:43 AM
To: [email-masked]
Subject: [multimob] Request for agenda items

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 11 May 2010 08:49:44 -0700 (PDT)

Hi Dirk,
  This is good news.

We would like to see the revised drafts submitted soon rather than later to make good progress on MLD/IGMP base solution charter item.
Simulations may continue and more results can be reported later on.

Regards,
Behcet

----- Original Message ----
> From: "[email-masked]" <[email-masked]>
> To: [email-masked]
> Sent: Tue, May 11, 2010 10:23:26 AM
Forwarding Hitoshis mail below...
So we can expect updated drafts 
> on IGMP/MLD tuning by both Hitoshi and Qin before IETF-78 - sounds great, thanks 
> a lot! 

Regards
Dirk 

-----Ursprüngliche Nachricht-----
Von: 
> Hitoshi Asaeda [mailto:> href="mailto:[email-masked]">[email-masked]] 
Gesendet: 
> Dienstag, 11. Mai 2010 17:00
An: von Hugo, Dirk
Cc: > ymailto="mailto:[email-masked]" 
> href="mailto:[email-masked]">[email-masked]
Betreff: Re: [multimob] 
> Request for agenda items

Hi Dirk,

There was the discussion that 
> the important thing for igmp/mld tuning
draft is to provide more concrete 
> analysis about various timers. It
requires mathematical or feasible 
> simulation basis analysis.
I and my coleagues have been developing simulation 
> code for such
analytic approach and hope we'd be able to give some 
> improvement for
our draft before the next 
> meeting.

Regards,
--
Hitoshi 
> Asaeda
multimob mailing 
> list
> href="mailto:[email-masked]">[email-masked]
> href="https://www.ietf.org/mailman/listinfo/multimob" target=_blank

---

From: Hares Susan <[email-masked]>
Date: Wed, 12 May 2010 07:29:49 -0700

Behcet: 

I'd like to have you play with the routing demons prior to the IETF this
time.

Let's chat about how this can be done. 

Best wishes, 

Sue  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Behcet Sarikaya
Sent: Friday, May 07, 2010 8:43 AM
To: [email-masked]
Subject: [multimob] Request for agenda items

---

From: "Thomas C. Schmidt" <[email-masked]>
Date: Fri, 14 May 2010 17:52:39 +0200

Hi Dirk,

> For the agenda I think we additionally have to further discuss improvements of the existing WG draft explaining the use of multicast in PMIPv6 http://datatracker.ietf.org/doc/draft-ietf-multimob-pm…

I guess the final steps to put in this draft have been discussed in 
Anaheim ... anyway, sorry for the delay ... we're about to update.

Best regards,

Thomas

-- 

Prof. Dr. Thomas C. Schmidt
° Hamburg University of Applied Sciences                   Berliner Tor 7 °
° Dept. Informatik, Internet Technologies Group    20099 Hamburg, Germany °
° http://www.haw-hamburg.de/inet                   Fon: +49-40-42875-8452 °
° http://www.informatik.haw-hamburg.de/~schmidt    Fax: +49-40-42875-8409 °

---

From: "Thomas C. Schmidt" <[email-masked]>
Date: Fri, 14 May 2010 17:56:02 +0200

Hi Behcet,

this is still very early to ask for agenda items. We will have an update 
on 
http://tools.ietf.org/html/draft-schmidt-multimob-fmipv6-pfmipv6-multicast 
(in particular, as pfmipv6 is in RFC editor queue) and would like to 
present this.

There might also be an additional (new) draft ... but we should talk 
about this in June.

Best regards,

Thomas

--

---

From: Qin Wu <[email-masked]>
Date: Tue, 18 May 2010 11:34:10 +0800

Hi, all:
As requested by chairs, we have made a new version of draft-wu-multimob-igmp-mld-tuning(i.e.,01-version) according to the comments recieved from Anaheim meeting. The URL link for this I-D is http://www.ietf.org/internet-drafts/draft-wu-multimob-igmp-mld-tuning-01.txt
The main changes we have are:
a) Remove the report optimization in the section 3.1 based on Gorry and Stig's suggestion.

b) Remove the optimization for link type in the section 3.3 based on Marshall and Suresh, instead, 
add two new sub-sections to discuss how to tune IGMP/MLD behavior in terms of different link type as follows:
4.7.8: Filtering unwanted multicast packets based on link type
4.7.9: Tuning Response Delay according to link type and status

c) Add two new sub-sections in section 3 to discuss
3.1 Comparison analysis between wired and wireless multicast 
3.2  Link models analysis for wireless multicast

d) Add three new sub-sections in section 4.1 to discuss 
4.1.1. How does Explicit tracking work?
4.1.2  How does Report Suppression work?
4.1.3  How does Query Suppression work?

e) All the other changes are editorial changes based on comments from Imed, Gorry, Schmidt, Weesan Lee,William. 
Thank them for bringing me thougtful discussion.

As regarding which parts of optimization should be seen as protocol change, I believe
the Ack mechanism for reliability mentioned in draft-liu-multimob-reliable-igmp-mld-00
and this draft should be taken as protocol extension for optimization.  That is why we remove all
the report optimization part at the host side from this I-D. Also there are some
existing work related to this Ack mechanism e.g.,:
"
Nikaein, N. and Bonnet, C. "Wireless multicasting in an IP environment" In Proceedings of the 5th International Workshop on Mobile Multimedia Communication MoMuc'98 (Berlin, Germany, Oct. 12-14). IEEE Computer Society Press, 1998.
"
I would like to ask all the folks who commented on this draft before to check
whether they feel satisfactory with the content. Comments from the many 
contributors as well as anybody else are highly appreciated. It would be 
great to get a discussion going before the next meeting.

Regards!
-Qin

----- Original Message ----- 
From: "Behcet Sarikaya" <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Sent: Tuesday, May 11, 2010 11:49 PM
Subject: Re: [multimob] Request for agenda items

Hi Dirk,
This is good news.

Regards,
Behcet

----- Original Message ----

Regards
Dirk 

-----Ursprüngliche Nachricht-----
An: von Hugo, Dirk
Betreff: Re: [multimob] 

Hi Dirk,

Regards,
--
Hitoshi