Subject: [multimob] Revised MLD/IGMP Tuning drafts

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 25 Oct 2010 15:35:52 -0700 (PDT)

Just to bring to your attention the two drafts that have been revised:

http://tools.ietf.org/html/draft-wu-multimob-igmp-mld-tuning-03

and 

http://tools.ietf.org/html/draft-asaeda-multimob-igmp-mld-optimization-04

Please post your comments to the list.

---

From: <[email-masked]>
Date: Thu, 28 Oct 2010 12:40:38 +0200

Dear all, 
Please find below some suggestions to the Multimob MLD tuning drafts:

In general IMO both revised drafts have considerably improved. Thanks to the autors for their effort!
 
Qin and Hui give a detailed introduction in wireless and mobile multicast isues which could be shortened a bit (BTW also fixed access bandwidth e.g. DSL in general is asymmetric - however for wireless it could also be a hybrid connection with e.g. broadcast e.g. DVB downlink and individual unicast e.g. WLAN uplink). 
I am not sure whether we need a comparison in detail between MLD/IGMP versions as only IGMPv3/MLDv2 is mentioned in the charter.

Both drafts propose to use Explicit Tracking which can considerably reduce message traffic and speed up leave latency thus saving resources on both network and terminal side. I don't understand why channel changing at receiver side will speed up (3rd para on p.13, Wu et al.)- when a host has sent the Leave it stops listening to the old channel and can send Join to new group and start listening to them ...

Whereas Hitoshi and Yogo propose specific figures for Timers and Counters (unfortunately without a reference to measurements verifying the optimization gain), Qin and Hui propose an adaptive Timer increase which seems to be more elegant - but doesn't this require a protocol change?
'Switching between Unicast and Multicast Queries' is implicitly also proposed by Hitoshi and Yogo ...

Actually I don't see real controversary between both drafts but rather to be complementary to each other - however I am no expert on IGMP/MLD ... 

My overall suggestion is that merging both documents could provide a complete solution to be adopted by the WG.

Further comments, please!
Thanks!

Best regards
Dirk 

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Behcet Sarikaya
Gesendet: Dienstag, 26. Oktober 2010 00:36
An: Thomas C Schmidt; [email-masked]; Alexandru Petrescu; [email-masked]
Betreff: [multimob] Revised MLD/IGMP Tuning drafts

and 

      
_______________________________________________
multimob mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/multimob