Subject: Re: [multipathtcp] Draft agenda for Quebec

From: <[email-masked]>
Date: Tue, 26 Jul 2011 23:54:12 +0100

Hi,

We need note-takers for the meeting tomorrow and preferably also for jabber - Please volunteer!

if anyone has implementation news /update that they'd like to report, please let me know (if you're not here, then it would still be interesting to hear an update via Mark H or me)

thanks
phil/

________________________________
From: Eardley,PL,Philip,DES8 R
Sent: 11 July 2011 10:35
To: [email-masked]
Subject: Draft agenda for Quebec

Draft agenda for MPTCP WG Meeting

Hi,
Here’s the draft agenda.
If you’d like a slot please ask.

It would be great to hear about progress on implementation – Seb, Sowmini, Georg – any updates would be great to hear about.

Thanks

Phil & Yoshifumi

===

WEDNESDAY, July 27, 2011
0900-1130  Morning Session I
204 B                  TSV     mptcp          Multipath TCP WG

Main aim:
Conclude on all protocol issues. So that we can WG last call protocol (& API) docs immediately after IETF.

1.      Agenda bashing, note well, Milestones – Chairs (10mins)
2.      API update – Michael Scharf (5 mins)
3.      Congestion control update – Mark Handley (5 mins)
4.      Protocol update & discussion of open issues – Mark Handley (1 hour?)
5.      (new draft) Enhancements to Improve the Applicability of Multipath TCP to Wireless Access Networks – Georg Hampel (30mins)
6.      Call for news on Implementations - please request a time slot!
7.      Discussion on future of WG - Chairs

Reading:
http://tools.ietf.org/wg/mptcp/draft-ietf-mptcp-multiaddressed/
Email discussion on protocol, http://www.ietf.org/mail-archive/web/multipathtcp/
http://tools.ietf.org/id/draft-hampel-mptcp-applicability-wireless-networks

On Item 7, last time our rough conclusion was:
Once the Charter is finished charter, we will semi-pause while waiting for experiments, usage, applicability, interop testing etc. Other topics of particular interest include: proxy for mobility, alternative congestion control and advanced API.

[draft agenda at 11 July]

---

From: Christoph Paasch <[email-masked]>
Date: Wed, 27 Jul 2011 09:43:11 +0300

Hi,

On Wednesday 27 July 2011 wrote [email-masked]:
> if anyone has implementation news /update that they'd like to report,
> please let me know (if you're not here, then it would still be interesting
> to hear an update via Mark H or me)

since last IETF, several new features have gone into the kernel.

* IPv6-support, done by Jaakko Korkeaniemi.
* Support for the new option-format as of draft v03 (we are still working on 
the security/authentication part)
* handling of ifup/ifdown events
* DSS-checksum
* Many bug fixes and code-cleanup, including a new locking architecture done 
by Sébastien Barré

Our implementation is available on the git-repository at 
http://inl.info.ucl.ac.be/mptcp

Cheers,
Christoph

--
Christoph Paasch
PhD Student

IP Networking Lab --- http://inl.info.ucl.ac.be
MultiPath TCP in the Linux Kernel --- http://inl.info.ucl.ac.be/mptcp
Université Catholique de Louvain

www.rollerbulls.be
--