Subject: [multipathtcp] tsv-dir review of draft-ietf-mptcp-congestion-05

From: <[email-masked]>
Date: Tue, 5 Jul 2011 10:28:33 -0400

I've reviewed this document as part of the transport area directorate's ongoing
effort to review key IETF documents. These comments were written primarily for the
transport area directors, but are copied to the document's authors for their
information and to allow them to address any issues raised. The authors should
consider this review together with any other last-call comments they receive.
Please always CC: [email-masked] if you reply to or forward this review.

Summary:

This draft is on the right track but has open issues, described in the review.

Comments:

This draft specifies the congestion control modifications for multi-path TCP.

Major:

I have one open issue - the first two goals (in the Introduction) are to have multipath
TCP connections behave somewhat like single-path connections in terms of effects on
(fairness to) other traffic.  The algorithm specified accomplishes this solely by
coupling the additive increase functionality across the flows, but allowing each flow
to react to drops and congestion separately (no decrease coupling).  The draft does
not explain why increase coupling along is sufficient to achieve these goals or what
compromise to the goals results from only coupling increases.

Section 5 is a good start on this discussion, but it's not clear about what compromises
to the goals results from increase coupling only.  Section 5 criticizes an alternative
that couples both increases and decreases for failing to achieve Goal 1, but doesn't
say what this approach achieves.  At most a few additional sentences in Section 5 should
suffice to address this concern, and Section 2 should be edited to align with the
changes to Section 5.

Minor:

While the [NSDI] paper is a fine place to reference work published in conferences
and/or journals, RFC 3124 on the Congestion Manager is related IETF work and should
be cited here as an Informative Reference.

idnits 2.12.12 didn't find any nits.

Thanks,
--David
----------------------------------------------------
David L. Black, Distinguished Engineer
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

---

From: <[email-masked]>
Date: Tue, 19 Jul 2011 17:51:25 -0400

Costin,

The proposed -06 version sufficiently clarifies my one open issue.

I agree that the NSDI paper is an important citation and did not intend to
suggest that it be removed.  In addition, your decision to not cite RFC 3124
is ok with me.

Thank you for responding to the review.

Thanks,
--David

> -----Original Message-----
> From: Costin Raiciu [mailto:[email-masked]]
> Sent: Tuesday, July 19, 2011 12:35 PM
> To: Black, David
> Cc: tsv-dir; tsv-area; ietf; m.handley; d.wischik; multipathtcp
> Subject: Re: tsv-dir review of draft-ietf-mptcp-congestion-05
> 
> Hi David,
> 
> Thank you for your review.
> 
> > Major:
> >
> > not explain why increase coupling alone is sufficient to achieve these goals or what
> Our proposal fully achieves goals 1 and 2 - fairness to single path tcp  and improve throughput. It
> does not fully achieve goal three - balancing congestion; fully achieving goal 3 is very difficult,
> and an explanation is attempted in section 5; a reference is given to the NSDI paper for further info.
> 
> We have updated section 5 to make these points clear - they weren't clear enough before.
> 
> > Minor:
> >
> The congestion manager is indeed related work and should be cited in a research paper, but does not
> help understanding the congestion controller presented in this draft. We chose not to cite it
> explicitly.
> 
> We chose to cite the NSDI paper because it describes in detail the design choices that shaped the
> algorithm, and it will help an interested reader understand more about the algorithm.
> The discussion section is itself a short high level summary of those decisions.
> 
> We attach the new version of this draft to this email (we cannot post a new version online of the
> draft because the IETF submission cutoff date has passed). Could you please check the draft and see if
> the issues you raised have been clarified?
> 
> We will post the draft as soon as submissions reopen after the IETF
> 
> Thanks,
> Costin