Subject: [multipathtcp] conflict in the protocol-draft

From: Christoph Paasch <[email-masked]>
Date: Tue, 30 Aug 2011 12:35:54 +0300

Hi all,

there is a conflict in the latest protocol-draft.

At different places in the draft, pro-active acking middleboxes are mentioned 
for the reason of the existence of data_ack's. Especially in section 3.3.6, 
even these middleboxes are the reason for the necessity of a connection-level 
timer.

However, in section 3.5, a subflow is only fully established, if the first 
acked packet includes a data_ack. This, to prevent facing middleboxes that 
remove the mptcp-option exclusively on non-syn packets.
As a pro-active acking middlebox does not include a data_ack in it's ack's, 
the subflow will be torn down as described in section 3.5.Thus, a connection-
level timer is not necessary as described in section 3.3.6.

Cheers,
Christoph

--
Christoph Paasch
PhD Student

IP Networking Lab --- http://inl.info.ucl.ac.be
MultiPath TCP in the Linux Kernel --- http://inl.info.ucl.ac.be/mptcp
Université Catholique de Louvain

www.rollerbulls.be
--

---

From: Yoshifumi Nishida <[email-masked]>
Date: Wed, 31 Aug 2011 02:28:20 -0700

Hi Christoph,

Interesting point. But, what if the path has been changed after the
first data ack?

Thanks,
--
Yoshifumi Nishida
[email-masked]

2011/8/30 Christoph Paasch <[email-masked]>:
> _______________________________________________
> multipathtcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/multipathtcp
>