Subject: [multipathtcp] Question about MPTCP connection establishement and DSS option.

From: Mahesh M <[email-masked]>
Date: Fri, 15 Jun 2012 15:40:03 -0700

Hi All,

This is my first POST here and I have couple of question to ask after reading based draft version 9.

1.       If you have application protocol in which client always sends first data packet, then in TCP with syncookie we can delay allocating any session till we receive first data packet. i.e. even if final ACK in the 3way handshake is dropped we can validate the client even at first data packet.  But, in MPTCP if final ACK in 3 in connection establishment gets dropped we don't get echo back of both client and server keys and first data packet will not have this information. Going by this we have to allocate some session on receiving the SYN packet so that we can remember the clients key and we cannot do stateless connection establishment. Is my understanding correct or just like SYN final ACK is reliable and 1octect in sequence space?

2.       In DSS option, subflow sequence number is relative to the ISN and its 4bytes wide. With this we can specify mapping for only 4GB and for each flow mapping (data transfer) is restricted to 4GB, am I missing something here?

Thanks,
M

---

From: Alan Ford <[email-masked]>
Date: Tue, 19 Jun 2012 08:48:05 +0100

Hi Mahesh,

In answer to your questions:

1. In the case of the client sending first, if the third ACK is lost, then
the first data packet (and thus the first ACK the server receives) will not
have the MP_CAPABLE option and thus the session will have to fall back to
operating as single-path TCP (the server won¹t be sending DSS options in
response).

2. The subflow sequence number is the relative sequence number of the TCP
subflow underlying the MPTCP connection. TCP sequence numbers are only 4
bytes long so this should not cause a problem. A mapping only covers a chunk
of data, no the whole lifetimes of a flow.

Regards,
Alan

On 15/06/2012 23:40, "Mahesh M" <[email-masked]> wrote:

> 1.       If you have application protocol in which client always sends first
> data packet, then in TCP with syncookie we can delay allocating any session
> till we receive first data packet. i.e. even if final ACK in the 3way
> handshake is dropped we can validate the client even at first data packet.
> But, in MPTCP if final ACK in 3 in connection establishment gets dropped we
> don¹t get echo back of both client and server keys and first data packet will
> not have this information. Going by this we have to allocate some session on
> receiving the SYN packet so that we can remember the clients key and we cannot
> do stateless connection establishment. Is my understanding correct or just
> like SYN final ACK is reliable and 1octect in sequence space?
> 
> 2.       In DSS option, subflow sequence number is relative to the ISN and its
> 4bytes wide. With this we can specify mapping for only 4GB and for each flow
> mapping (data transfer) is restricted to 4GB, am I missing something here?
> 
>  
> Thanks,
> M
>  
> 
> 
> _______________________________________________
> multipathtcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/multipathtcp