Subject: [multipathtcp] Number of DSS to store

From: Mahesh M <[email-masked]>
Date: Fri, 29 Jun 2012 11:22:44 -0700

Hi All,

I have a question with regard to DSS option. Can a sender send more than one DSS option before sending data? If yes, how many DSS mapping can sender send before sending the actual data? Is it like receiver has to queue all the mappings if they fit in the advertised window?

Regards,
mahesh

---

From: "Alan Ford (alanford)" <[email-masked]>
Date: Sat, 30 Jun 2012 17:52:47 +0000

Hi Mahesh,

Interesting question. We haven't specified any restriction: I don't think we'd ever envisaged anyone wanting to have more that one DSS per subflow applied at any one time. Could you expand on the use case for such a feature?

I don't understand your second question, though: "Is it like receiver has to queue all the mappings if they fit in the advertised window?". DSS doesn't have anything to do with the advertised window.

Regards,
Alan

From: Mahesh M <[email-masked]<mailto:[email-masked]>>
Date: Fri, 29 Jun 2012 11:22:44 -0700
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [multipathtcp] Number of DSS to store

Hi All,

Regards,
mahesh
_______________________________________________ multipathtcp mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/multipathtcp

---

From: Mahesh M <[email-masked]>
Date: Sat, 30 Jun 2012 11:08:46 -0700

I could not make in the draft where it says explicitly that sender has to send only one DSS option at a time (also DSS can come in ACK only packet), so there is not restriction on the implementation not send more than one DSS at a time. Assume I am using sendfile() to transfer a file and I know how big is my file and can decide on sending range of data sequence between couple of subflows. sender decides to send all the mapping upfront and send multiple 64k chunks for TSO card.

I don't understand your second question,
Assuming my above theory is valid, if the receiver has advertised 2MB window, sender can send 52 DSS mappings upfront before sending any data. i.e I can send only DSS mappings which can fit within the receivers window.

Regards,
Mahesh

From: Alan Ford (alanford) [mailto:[email-masked]]
Sent: Saturday, June 30, 2012 10:53 AM
To: Mahesh M; [email-masked]
Subject: Re: [multipathtcp] Number of DSS to store

Hi Mahesh,

Regards,
Alan

Hi All,

Regards,
mahesh

---

From: "Alan Ford (alanford)" <[email-masked]>
Date: Sat, 30 Jun 2012 18:19:04 +0000

I see. Well, as the draft is written at the moment there is no restriction on you sending all mapping upfront. Furthermore, there is no restriction on the mapping having to fit within the advertised window. So you could, in theory, send the mapping for your whole sendfile() upfront. I don't know if existing implementations would have a problem with that, though. MPTCP is not really intended to be used in this way, however, since doing this defeats the point of responding to congestion signals – dynamically readjusting which data are sent on which subflow according to congestion/throughput.

I don't know if implementors have a view on this, and whether we need to restrict anything in this are?

Regards,
Alan

From: Mahesh M <[email-masked]<mailto:[email-masked]>>
Date: Sat, 30 Jun 2012 11:08:46 -0700
To: Alan Ford <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [multipathtcp] Number of DSS to store

Regards,
Mahesh

From: Alan Ford (alanford) [mailto:[email-masked]]
Sent: Saturday, June 30, 2012 10:53 AM
To: Mahesh M; [email-masked]<mailto:[email-masked]>
Subject: Re: [multipathtcp] Number of DSS to store

Hi Mahesh,

Regards,
Alan

Hi All,

Regards,
mahesh

---

From: Mahesh M <[email-masked]>
Date: Sat, 30 Jun 2012 11:46:00 -0700

This question did not occur to me thinking of use case like sendfile(), it came to my mind thinking of a bad implementation which can send more than one DSS mapping per subflow at a time.

Regards,
Mahesh

From: Alan Ford (alanford) [mailto:[email-masked]]
Sent: Saturday, June 30, 2012 11:19 AM
To: Mahesh M; [email-masked]
Subject: Re: [multipathtcp] Number of DSS to store

I see. Well, as the draft is written at the moment there is no restriction on you sending all mapping upfront. Furthermore, there is no restriction on the mapping having to fit within the advertised window. So you could, in theory, send the mapping for your whole sendfile() upfront. I don't know if existing implementations would have a problem with that, though. MPTCP is not really intended to be used in this way, however, since doing this defeats the point of responding to congestion signals - dynamically readjusting which data are sent on which subflow according to congestion/throughput.

Regards,
Alan

Regards,
Mahesh

Hi Mahesh,

Regards,
Alan

Hi All,

Regards,
mahesh