Subject: [multipathtcp] comments on draft-paasch-mptcp-lowoverhead and draft-paasch-mptcp-ssl

From: Yoshifumi Nishida <[email-masked]>
Date: Thu, 25 Oct 2012 01:51:58 -0700

Hello,

I have read draft-paasch-mptcp-lowoverhead and draft-paasch-mptcp-ssl.
I have the following questions and comments on the drafts.

1: I'm wondering if experimental status might be better for them. Is there
any thoughts on this?

2: How is the relationships between these drafts? Is it totally
independent?

3: In my feeling, it could be dangerous If token is used for high-order
32bit. (draft-paasch-mptcp-lowoverhead)
    We might want to emphasize this point.

4: In section 5 of draft-paasch-mptcp-lowoverhead.
    "if an attacker manages to join an existing connection...".
    Does this mean the attacker steals the token? I just would like to
confirm..

Thanks,
--
Yoshifumi

---

From: Christoph Paasch <[email-masked]>
Date: Thu, 25 Oct 2012 11:25:58 +0200

Hi Yoshifumi,

thanks for your comments. Please find my replies below.

> 1: I'm wondering if experimental status might be better for them. Is there

You are probably right. I can change this for the next version.

> 2: How is the relationships between these drafts? Is it totally

Yes, they are independent from each other. MPTCP v0 or MPTCP v1 (low overhead) 
can use a key provided by the application.

>     We might want to emphasize this point.

What part in the draft are you referring to?
It is the random number that is used for the 32 high-order bits of the IDSN.

Or do you mean that we just should explain why the random number is used, and 
not the token for the high-order bits.

>     Does this mean the attacker steals the token? I just would like to

The attacker might know (through sniffing) the token or guess it and thus can 
add a subflow to the connection.

Cheers,
Christoph

-- 
IP Networking Lab --- http://inl.info.ucl.ac.be
MultiPath TCP in the Linux Kernel --- http://mptcp.info.ucl.ac.be
Université Catholique de Louvain
--

---

From: Yoshifumi Nishida <[email-masked]>
Date: Thu, 25 Oct 2012 03:02:17 -0700

Hello Christoph,

Thank you so much for your clarification.

> not the token for the high-order bits.

Sorry. I was not clear enough. Yes, that's what I meant.
I thought if someone overlooks this part, it might be dangerous.

Thanks,
--
Yoshifumi