Subject: [multipathtcp] q about draft-khalili-mptcp-performance-issues-02

From: Yoshifumi Nishida <[email-masked]>
Date: Tue, 5 Mar 2013 00:11:26 -0800

Hello, I'm personally interested in this and I'm trying to understand
this more deeply.

One thing I concern is Scenario A and B seem to be a bit complex,
while I'm fine with Scenario C.
In A, one traffic for type1 users goes through 2 bottlenecks. In B,
all traffic goes through 2 or 3 bottlenecks.
However, In my intuition, if there's multiple bottlenecks, it might be
a bit tricky situation for end-to-end congestion control as we are not
sure where to archive fair-sharing
I'm wondering if you can create similar scenarios with single
bottleneck or this is the requirement to exhibit the problems you want
to depict.

Thanks,
--
Yoshifumi

---

From: Khalili Ramin <[email-masked]>
Date: Tue, 5 Mar 2013 10:08:35 +0000

Hi Yoshifumi,

In scenarios A and B, we need to have flows go through multiple bottlenecks. 

Note that in these two scenarios, we do not study the fairness. What we show is that by upgrading TCP users to MPTCP users (e.g. upgrading type 1 users to MPTCP in scenario A and upgrading Red users to MPTCP in scenario B), we reduce the aggregate throughput without any benefit for anybody. Hence, using MPTCP with LIA (the current implementation) can lead to an inefficient use of capacity and can hurt users.

The fairness is studied in Scenario C.

Regards,
Ramin.

________________________________________
From: [email-masked] [[email-masked]] on behalf of Yoshifumi Nishida [[email-masked]]
Sent: Tuesday, March 05, 2013 9:11 AM
To: multipathtcp
Subject: [multipathtcp] q about draft-khalili-mptcp-performance-issues-02

Thanks,
--
Yoshifumi
_______________________________________________
multipathtcp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/multipathtcp

---

From: Yoshifumi Nishida <[email-masked]>
Date: Thu, 7 Mar 2013 23:42:16 -0800

Hi Khalili,

Thanks for your response.

> Note that in these two scenarios, we do not study the fairness. What we show is that by upgrading TCP users to MPTCP users (e.g. upgrading type 1 users to MPTCP in scenario A and upgrading Red user…

OK. I'm just trying to think if I can extract some kind of rule sets
from the scenarios.
For example, I'm thinking that the minimal rule sets for scenario A
may be something like this.

   1) subflows of mptcp connections shares 1 bottleneck link (B1)
   2) one of subflows shares another bottleneck (B2) with other TCP flows
   3) mptcp data traffic goes though B2 must go through B1 after B2.
   4) as number of mptcp connections increases, the problem gets worse.

Is this correct? Please correct me if I'm doing something wrong.

Thanks,
--
Yoshifumi

---

From: Khalili Ramin <[email-masked]>
Date: Fri, 8 Mar 2013 14:59:23 +0000

Yes, you very well understand the problem. 

If subflows belonging to an MPTCP connection share the same bottleneck, and if some of these subflows cross some other bottlenecks in the network, then using MPTCP can hurt everybody. As you mentioned, the problem can get worse when the number of MPTCP connections increases. 

Regards,
Ramin.
 
________________________________________
From: Yoshifumi Nishida [[email-masked]]
Sent: Friday, March 08, 2013 8:42 AM
To: Khalili Ramin
Cc: multipathtcp
Subject: Re: [multipathtcp] q about draft-khalili-mptcp-performance-issues-02

Hi Khalili,

Thanks,
--
Yoshifumi