Subject: [multipathtcp] TR: I-D Action: draft-boucadair-mptcp-symmetric-02.txt

From: <[email-masked]>
Date: Thu, 12 Mar 2015 15:50:24 +0000

Dear all,

We submitted this short I-D.

Comments are welcome. 

Cheers,
Med

> -----Message d'origine-----
> De : I-D-Announce [mailto:[email-masked]] De la part de
> [email-masked]
> Envoyé : lundi 9 mars 2015 13:36
> À : [email-masked]
> Objet : I-D Action: draft-boucadair-mptcp-symmetric-02.txt
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> 
> 
>         Title           : An Extension to MPTCP for Symmetrical Sub-Flow
> Management
>         Authors         : Mohamed Boucadair
>                           Christian Jacquenet
> 	Filename        : draft-boucadair-mptcp-symmetric-02.txt
> 	Pages           : 7
> 	Date            : 2015-03-09
> 
> Abstract:
>    This document specifies a MPTCP extension that allows to achieve
>    symmetrical subflow management.  In particular, this extension allows
>    both endpoints to add new subflows whenever needed without waiting
>    for the endpoint which initiated the first subflow to add new ones.
> 
>    This document updates RFC 6824.
> 
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-boucadair-mptcp-symmetric/
> 
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-boucadair-mptcp-symmetric-02
> 
> A diff from the previous version is available at:
> http://www.ietf.org/rfcdiff?url2=draft-boucadair-mptcp-symmetric-02
> 
> 
> Please note that it may take a couple of minutes from the time of
> submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Yoshifumi Nishida <[email-masked]>
Date: Tue, 24 Mar 2015 23:58:04 -0700

Hi Med,

I have read the draft. I agree with the motivation of the draft, but I'm
not very sure if we need to extend or develop an option yet.
My comments are below...

1: I think you will need to use ADD_ADDR2 instead of ADD_ADDR in future
versions as ADD_ADDR will be deprecated.

2: mptcp cannot guarantee if it can receive incoming flows as it depends on
external mechanisms.
    So, I'm not very sure how much the check flag can be useful.

3: From the same reason above, I'm also not very sure about the lifetime
info, either.
    Also, even if an endpoint tries to use a staled address for a new
subflow, I think it will fail since the peer won't be able to send back a
proper token.

Thanks,
--
Yoshi

On Thu, Mar 12, 2015 at 8:50 AM, <[email-masked]> wrote:

> multipathtcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/multipathtcp
>