Subject: [multipathtcp] Collection of MPTCP proxy scenarios.

From: "Weixinpeng (Jackie)" <[email-masked]>
Date: Mon, 27 Apr 2015 08:20:48 +0000

Hi all,
MPTCP proxy aims to provide additional deployment support for MPTCP protocol, and the functions provided
by MPTCP proxy could involve several different aspects such as supporting establishment of MPTCP connection between
MPTCP host and traditional TCP host, aggregating of subflows to one point for security reasons,...

I am trying to figure out as many MPTCP proxy deployment scenarios as possible to have a more deep understanding
of how MPTCP proxy should work. As an example, here are some potential scenarios:
(1) MPTCP proxy in operator's network. The operator could deploy MPTCP proxy to assist MPTCP-capable UE to communicate
with TCP server on Internet using MPTCP.
(2) MPTCP proxy in enterprise network. Enterprise network could ask all the traffic pass through security check point for security reasons,
in this case, all the subflows belong to a MPTCP connection should be aggregated at the same point.
Besides, some existing documents such as draft-deng-mptcp-proxy-01 and draft-lopez-mptcp-middlebox-00 also provide some related discussion.

So if you know some additional MPTCP proxy deployment scenarios especially the ones that have some special requirements, It will be appreciated if you could
share it here. Or if you have any other considerations on the MPTCP proxy topic, we can also discuss it here.

Thanks!

Regards,
-Xinpeng

---

From: Lukasz Budzisz <[email-masked]>
Date: Mon, 27 Apr 2015 10:23:54 +0200

Dear Xinpeng,
you may have a look at the draft we presented in the IETF Paris meeting:
https://tools.ietf.org/html/draft-ayar-transparent-sca-proxy-00
Best regards,
Lukasz

On 27/04/15 10:20, Weixinpeng (Jackie) wrote:
> by MPTCP proxy could involve several different aspects such as 
> supporting establishment of MPTCP connection between
>
> MPTCP host and traditional TCP host, aggregating of subflows to one 
> point for security reasons,…
>
> I am trying to figure out as many MPTCP proxy deployment scenarios as 
> possible to have a more deep understanding
>
> (1) MPTCP proxy in operator’s network. The operator could deploy MPTCP 
> proxy to assist MPTCP-capable UE to communicate
>
> (2) MPTCP proxy in enterprise network. Enterprise network could ask 
> all the traffic pass through security check point for security reasons,
>
> Besides, some existing documents such as draft-deng-mptcp-proxy-01 and 
> draft-lopez-mptcp-middlebox-00 also provide some related discussion.
>
> So if you know some additional MPTCP proxy deployment scenarios 
> especially the ones that have some special requirements, It will be 
> appreciated if you could
>
> share it here. Or if you have any other considerations on the MPTCP 
> proxy topic, we can also discuss it here.
>
> Thanks!
>
> Regards,
>
> -Xinpeng
>
>
>
> _______________________________________________
> multipathtcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/multipathtcp

---

From: "Weixinpeng (Jackie)" <[email-masked]>
Date: Wed, 29 Apr 2015 03:13:36 +0000

Hi Lukasz,
         Thanks for your information.
         I have read through the document, and find it an interesting solution, but I think the solution in the document is
about how to transmit traditional TCP traffic through multipath, and it is a bit of different from MPTCP protocol.
         Thanks.
Regards,
Xinpeng

From: Lukasz Budzisz [mailto:[email-masked]]
Sent: Monday, April 27, 2015 4:26 PM
To: Weixinpeng (Jackie)
Subject: Re: [multipathtcp] Collection of MPTCP proxy scenarios.

Dear Xinpeng,

------------------------------------------

Łukasz Budzisz, Ph.D.

Research Fellow

Technische Universität Berlin (TU Berlin)

Telecommunication Networks Group

Tel: +49 30 314 23836

------------------------------------------
On 27/04/15 10:20, Weixinpeng (Jackie) wrote:
Hi all,
MPTCP proxy aims to provide additional deployment support for MPTCP protocol, and the functions provided
by MPTCP proxy could involve several different aspects such as supporting establishment of MPTCP connection between
MPTCP host and traditional TCP host, aggregating of subflows to one point for security reasons,…

(1) MPTCP proxy in operator’s network. The operator could deploy MPTCP proxy to assist MPTCP-capable UE to communicate

Thanks!

Regards,
-Xinpeng

[email-masked]<mailto:[email-masked]>

---

From: Jordan Melzer <[email-masked]>
Date: Thu, 30 Apr 2015 11:12:54 -0600

Hi Xinpeng,

I have used a back-to-back MPTCP proxy setup to allow TCP to multipath over a segment of network.  My use case is allowing a home router to use more than one Internet connection.  The home router would have one MPTCP proxy and the ISP would have another.  The home devices would not need to run MPTCP, nor would any Internet servers.  The advantage of MPTCP proxies here is that the different network connections coming into the home need not have deterministic capacities, and the system supports smooth failover as well as aggregation.  DSL, LTE, cable, and WiFi (eg, from a neighbouring home) are all candidate technologies to be aggregated.

The challenge in this configuration is for the proxy to not prevent a native MPTCP device from running an end-to-end MPTCP connection.  The default proxy one gets by running a TCP proxy, eg HAPROXY, on a machine running an MPTCP kernel doesn’t avoid proxying MP_JOINs from sessions it doesn’t know about and doesn’t keep the keys the same on both sides of the connection, preventing an MPTCP capable home client from successfully doing an MP_JOIN using a path that doesn’t go through the home proxy.

One could probably modify HAPROXY to do this behaviour or make nftables rules that make MPTCP traffic bypass the proxies altogether.

I am not entirely satisfied that this kind of setup is a great idea, but the use case of bonding different connections together without changing anything at the ends of the network could be compelling.

Jordan

From: multipathtcp [mailto:[email-masked]] On Behalf Of Weixinpeng (Jackie)
Sent: April 28, 2015 11:14 PM
To: [email-masked]; [email-masked]
Subject: Re: [multipathtcp] Collection of MPTCP proxy scenarios.

Hi Lukasz,

Dear Xinpeng,

Łukasz Budzisz, Ph.D.

Research Fellow

Tel: +49 30 314 23836

Thanks!

Regards,
-Xinpeng