Subject: Re: [multipathtcp] New draft for optimizing MPTCP subflows

From: Olivier Bonaventure <[email-masked]>
Date: Wed, 15 Apr 2015 12:03:11 +0200

Hello,
>
> We have proposed a new draft for optimizing MPTCP subflows using Traceflow.
>
> Name:           draft-aravind-mptcp-optimized-subflows
>
> Revision:       00
>
> Title:          Optimized Multipath TCP subflows using Traceflow
>

I read the document and was very surprise by your choice of a Layer-2 
protocol to distribute the information about the path. This makes sense 
in some datacenters that are based on layer2 switches, but does not 
apply to all possible use cases.

There are other network scenarions where it could be useful for hosts 
that use Multipath TCP to select the path (or a part of) that will be 
followed by their subflows. I was wondering whether we should not start 
by listing all these use cases and then evaluate what are the existing 
protocols that could be used to create/select those paths.

Olivier

-- 
INL, ICTEAM, UCLouvain, Belgium, http://inl.info.ucl.ac.be

---

From: <[email-masked]>
Date: Thu, 23 Apr 2015 12:51:42 +0530

Hi Olivier,

Thanks a lot for the review comments. 

Actually, the choice of Layer-2 protocol was only due to the sole fact that the packets have to be processed by the Layer-2 switches as well in addition to other various devices in the network.

The original Traceflow proposal was using UDP protocol and hence, may not be processed by the Layer-2 switches in network. 

And hence, this is not actually a strict condition and we may use the most appropriate protocol to disperse the packets in the network. 

Kindly let us know your views and comments. 

Thanks,
S. Aravind Prasad
________________________________________
From: Olivier Bonaventure [[email-masked]]
Sent: Wednesday, April 15, 2015 3:33 PM
To: Sridharan, Aravind; [email-masked]
Subject: Re: [multipathtcp] New draft for optimizing MPTCP subflows

Hello,

Olivier