Subject: [multipathtcp] several comments on draft-paasch-mptcp-syncookies-02

From: Yoshifumi Nishida <[email-masked]>
Date: Tue, 12 Jan 2016 00:25:01 -0800

Hello,

I've read syscoockies-02 draft. I think it looks good, but I would like to
clarify the following points.

1: Page 7:
     An indication for the client that the server received the key is when
the server issues a DATA_ACK...

  -> It seems that the server needs to send DATA_ACK if it receives
MP_CAPABLE for this. However, in my understanding, RFC6824bis doesn't
mandate to send DATA_ACK.
      If this is mandatory, I guess we'll need to mention it explicitly.

2: Page 7:
    This mechanism of sending the MP_CAPABLE with a DATA_ACK until the
server acknowledge it....

   -> Do you mean "This mechanism of sending MP_CAPABLE until the arrival
of  DATA_ACK from sender"?

3: Page 8: Section 3.1.2
    However, the client receiving this data send by...

    -> Is there a case where we cannot put MP_CAPABLE and DATA_ACK together?

4: Page 8: Section 3.1.3

    -> Don't we need to describe what we should do if the server doesn't
this version?

5: Section 3.2

   It should respond with a Data ACK set to...
    -> I think we should mention which tcp-ack num is used here. it'll be X?

6: Page 1: Title

   It seems to me that the title indicate that it is only for stateless
webservers.
   If this draft will be merged into 6824bis, it might not be a problem.
   However, if this draft will be a separate draft and will be the standard
mechanism for mptcp session establishment, I personally would like to think
about changing the title.

Thanks.
--
Yoshi

---

From: Alan Ford <[email-masked]>
Date: Tue, 12 Jan 2016 16:27:28 +0000

Hi Yoshi,

I believe most of these points are addressed by the tailored wording now
introduced in the latest 6824bis draft. If anything there does not make
sense please let us know!

Cheers,
Alan

On 12 January 2016 at 08:25, Yoshifumi Nishida <[email-masked]>
wrote:

>    However, if this draft will be a separate draft and will be the
> standard mechanism for mptcp session establishment, I personally would like
> to think about changing the title.
>
> Thanks.
> --
> Yoshi
>
> _______________________________________________
> multipathtcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/multipathtcp
>
>

---

From: Yoshifumi Nishida <[email-masked]>
Date: Wed, 13 Jan 2016 00:29:03 -0800

Hi Alan,

I see. The new 6824bis has a similar handshake mechanism in syn cookie
draft.
I will check it later. Thanks for the updates.
---
Yoshi

On Tue, Jan 12, 2016 at 8:27 AM, Alan Ford <[email-masked]> wrote:

>> I've read syscoockies-02 draft. I think it looks good, but I would like
>> to clarify the following points.
>>
>> 1: Page 7:
>>      An indication for the client that the server received the key is
>> when the server issues a DATA_ACK...
>>