Subject: Re: [multipathtcp] [Technical Errata Reported] RFC7430 (4565)

From: Yoshifumi Nishida <[email-masked]>
Date: Sun, 3 Jan 2016 21:43:03 -0800

Hi,
This might already be taken care of, but just in case...

I personally think this errata is correct (although it can look an
editorial error)
I think we will need confirmations from authors.

Thanks,
--
Yoshi

On Mon, Dec 14, 2015 at 7:45 AM, RFC Errata System <
[email-masked]> wrote:

> The following errata report has been submitted for RFC7430,
> "Analysis of Residual Threats and Possible Fixes for Multipath TCP
> (MPTCP)".
>
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata_search.php?rfc=7430&eid=4565
>
> --------------------------------------
> Type: Technical
> Reported by: Fabrizio Demaria <[email-masked]>
>
> Section: 6
>
> Original Text
> -------------
>    Summary of the attack:
>
>       Type of attack: An attacker that can intercept the SYN/JOIN
>       message can alter the source address being added.
>
>       Type of attacker: partial-time on-path eavesdropper
>
>    Description:
>
>    The attacker is present along the path when the SYN/JOIN exchange
>    takes place.  This allows the attacker to add any new address it
>    wants to by simply substituting the source address of the SYN/JOIN
>    packet for one it chooses.  This vulnerability was readily identified
>    when designing the MPTCP security solution [RFC6181], and the threat
>    was considered acceptable.
>
> Corrected Text
> --------------
>    Summary of the attack:
>
>       Type of attack: An attacker that can intercept the SYN/JOIN
>       message can alter the source address being added.
>
>       Type of attacker: partial-time on-path active attacker
>
>    Description:
>
>    The attacker is present along the path when the SYN/JOIN exchange
>    takes place.  This allows the attacker to add any new address it
>    wants to by simply substituting the source address of the SYN/JOIN
>    packet for one it chooses.  This vulnerability was readily identified
>    when designing the MPTCP security solution [RFC6181], and the threat
>    was considered acceptable.
>
> Notes
> -----
> As noted in section 1, an active attacker is able to change, discard, or
> delay some of the packets of the MPTCP session. This coincide with the
> description of the SYN/JOIN attack in section 6.
>
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party (IESG)
> can log in to change the status and edit the report, if necessary.
>
> --------------------------------------
> RFC7430 (draft-ietf-mptcp-attacks-04)
> --------------------------------------
> Title               : Analysis of Residual Threats and Possible Fixes for
> Multipath TCP (MPTCP)
> Publication Date    : July 2015
> Author(s)           : M. Bagnulo, C. Paasch, F. Gont, O. Bonaventure, C.
> Raiciu
> Category            : INFORMATIONAL
> Source              : Multipath TCP
> Area                : Transport
> Stream              : IETF
> Verifying Party     : IESG
>
>

---

From: marcelo bagnulo <[email-masked]>
Date: Mon, 4 Jan 2016 12:06:35 +0100

Hi,

I understand the only change is to change the type of attacker from 
eavesdropper to active, correct?
If so, I agree.

Regards, marcelo

El 04/01/16 a las 06:43, Yoshifumi Nishida escribió:
> On Mon, Dec 14, 2015 at 7:45 AM, RFC Errata System 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Reported by: Fabrizio Demaria <[email-masked]
>     <mailto:[email-masked]>>
>
>     Section: 6
>
>     Original Text
>     -------------
>        Summary of the attack:
>
>     As noted in section 1, an active attacker is able to change,
>     discard, or delay some of the packets of the MPTCP session. This
>     coincide with the description of the SYN/JOIN attack in section 6.
>
>     Instructions:
>     -------------
>     Title               : Analysis of Residual Threats and Possible
>     Fixes for Multipath TCP (MPTCP)
>     Author(s)           : M. Bagnulo, C. Paasch, F. Gont, O.
>     Bonaventure, C. Raiciu
>     Category            : INFORMATIONAL
>     Source              : Multipath TCP
>     Area                : Transport
>     Stream              : IETF
>     Verifying Party     : IESG
>
>