Subject: [multipathtcp] MPTCP Proxy Current Best Practices

From: "Sargent, Matthew T. (GRC-LCA0)[Peerless Technologies]" <[email-masked]>
Date: Thu, 2 Jun 2016 19:35:03 +0000

Hello all,

I was wondering if anyone on the list has experience deploying an MPTCP
proxy and would be willing to discuss the current best practices/proxy
deployment options? I have been looking through the mptcp-dev and
multipathtcp mailing lists at discussions revolving around MPTCP proxies
and it seems like the two general strategies seem to be setting up a SOCKS
proxy or using the mptcp-proxy code released by Bell Labs
http://www.ietf.org/mail-archive/web/multipathtcp/current/msg01934.html.

Are there other options or more up-to-date code to use? The Bell Labs code
is several years old, and I was unsure if using the code is still a viable
option at this point or not. Is a SOCKS proxy the go to option? If so, how
does an MPTCP capable SOCKS proxy setup differ from setting up a regular
TCP SOCKS proxy?

Best,
Matt

---

From: Jordan Melzer <[email-masked]>
Date: Thu, 2 Jun 2016 14:08:29 -0600

Hi Matthew,

As long as your OS kernel supports MPTCP, any proxy works as a TCP to MPTCP proxy.

Eg, if you're on Linux using the UCL MPTCP implementation and you turn on HAProxy as a TCP proxy, it becomes an MPTCP / TCP proxy.  The same should be true of Dante or OpenSSH or whatever else you want to try out.

As there are commercial implementations from a range of vendors that come with support etc., I don't think it would be fair to say there is one best practice!

It's worth noting that the default proxy will also terminate existing MPTCP sessions and convert them to MPTCP, so if this is not a "feature" you want, you may have to work harder.

Apologies if this is off-topic for the list.

Regards,
Jordan

-----Original Message-----
From: multipathtcp [mailto:[email-masked]] On Behalf Of Sargent, Matthew T. (GRC-LCA0)[Peerless Technologies]
Sent: June 2, 2016 03:35 PM
To: [email-masked]
Subject: [multipathtcp] MPTCP Proxy Current Best Practices

Hello all,

I was wondering if anyone on the list has experience deploying an MPTCP proxy and would be willing to discuss the current best practices/proxy deployment options? I have been looking through the mptcp-dev and multipathtcp mailing lists at discussions revolving around MPTCP proxies and it seems like the two general strategies seem to be setting up a SOCKS proxy or using the mptcp-proxy code released by Bell Labs http://www.ietf.org/mail-archive/web/multipathtcp/current/msg01934.html.

Are there other options or more up-to-date code to use? The Bell Labs code is several years old, and I was unsure if using the code is still a viable option at this point or not. Is a SOCKS proxy the go to option? If so, how does an MPTCP capable SOCKS proxy setup differ from setting up a regular TCP SOCKS proxy?

Best,
Matt

_______________________________________________
multipathtcp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/multipathtcp