Subject: [multipathtcp] MPTCP is not detecting second interface and not adding subflow to the connection

From: Gangadhar Akula <[email-masked]>
Date: Wed, 22 Nov 2017 10:17:24 +0530

Hello Team MPTCP,

Good Morning/Evening,

I have been researching on MPTCP for a while and I did setup MPTCP for LEDE
environment, I'm facing the following problem.

Setup:

MPTCP servers: multipath-tcp.org, using it as test MPTCP server / one more
server setup on AWS with MPTCP support.

MPTCP client: APU2 board, LEDE-MPTCP image flashed.
I have APU2 board which supports x86_64 image deployment, which has three
interfaces.
Compiled LEDE from https://github.com/spyff/lede-mptcp
The board has 2 WAN interfaces and 1 LAN interface.
I have tested each interface, using curl --interface option for MPTCP
support, both interfaces and paths support MPTCP, individually.
As a verification strategy captured traffic on client box using tcpdump for
destination multipath-tcp.org and viewed MPTCP handshake and data transfer
on Wireshark.

Test method:

Opened three SSH sessions of the APU2-LEDE box and fired tcpdump on both
interfaces to the destination.
Then used curl on the other SSH session to download the file.
tcpdump -vv -i eth0 src  multipath-tcp.org or dst multipath-tcp.org -w
mptcp_eth0.pcap
tcpdump -vv -i eth1 src  multipath-tcp.org or dst multipath-tcp.org -w
mptcp_eth1.pcap
curl -vvv -O http://multipath-tcp.org/snapshots/mptcp_2016_04_11.tar.gz

The problem here is only one interface is getting used, and another
interface is not getting detected.
I can see packet transfer on eth0  but on eth1 0 packets transferred.

I have tried DHCP and Static network, both have the same, with and without
routing tables the same.
If I change metrics, packets are transferred through, lowest metric
interface always, another interface will not be in use at all.
I tried using MPTCP options and not using MPTCP options on interface
configuration, still the same.
I tried master branch from the LEDE-MPTCP project, still the same.

MPTCP should use both the interfaces simultaneously to download the file,
which I achieved using UBUNTU setup, but with LEDE I'm facing this issue.

Please find attached files and let me know if I have to make any changes to
configuration or do something else.

APU2 board network configuration

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fdc9:c642:4709::/48'
        option multipath 'enable'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth2'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.137.147'
        option netmask '255.255.255.0'
        option gateway '192.168.137.1'
        option broadcast '192.168.137.255'
        option dns '8.8.8.8'
        option metric '1'
        option multipath 'on'

config interface 'wan2'
        option ifname 'eth1'
        option proto 'static'
        option ipaddr '192.168.1.110'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'
        option broadcast '192.168.1.255'
        option dns '8.8.8.8'
        option metric '2'
        option multipath 'on'

Firewall configuration
config defaults
option syn_flood 1
option input ACCEPT
option output ACCEPT
option forward REJECT
# Uncomment this line to disable ipv6 rules
# option disable_ipv6 1

config zone
option name lan
list   network 'lan'
option input ACCEPT
option output ACCEPT
option forward ACCEPT

config zone
option name wan
list   network 'wan'
list   network 'wan2'
option input REJECT
option output ACCEPT
option forward REJECT
option masq 1
option mtu_fix 1

config forwarding
option src lan
option dest wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
option name Allow-DHCP-Renew
option src wan
option proto udp
option dest_port 68
option target ACCEPT
option family ipv4

# Allow IPv4 ping
config rule
option name Allow-Ping
option src wan
option proto icmp
option icmp_type echo-request
option family ipv4
option target ACCEPT

config rule
option name Allow-IGMP
option src wan
option proto igmp
option family ipv4
option target ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
option name Allow-DHCPv6
option src wan
option proto udp
option src_ip fc00::/6
option dest_ip fc00::/6
option dest_port 546
option family ipv6
option target ACCEPT

config rule
option name Allow-MLD
option src wan
option proto icmp
option src_ip fe80::/10
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family ipv6
option target ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
option name Allow-ICMPv6-Input
option src wan
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
list icmp_type router-solicitation
list icmp_type neighbour-solicitation
list icmp_type router-advertisement
list icmp_type neighbour-advertisement
option limit 1000/sec
option family ipv6
option target ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
option name Allow-ICMPv6-Forward
option src wan
option dest *
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
option limit 1000/sec
option family ipv6
option target ACCEPT

config rule
option name Allow-IPSec-ESP
option src wan
option dest lan
option proto esp
option target ACCEPT

config rule
option name Allow-ISAKMP
option src wan
option dest lan
option dest_port 500
option proto udp
option target ACCEPT

# include a file with users custom iptables rules
config include
option path /etc/firewall.user

Best Regards,
Gangadhar Akula

---

From: Christoph Paasch <[email-masked]>
Date: Sun, 26 Nov 2017 18:32:08 -0800

+ mptcp-dev and moving the IETF-list to BCC

Hello,

> destination multipath-tcp.org and viewed MPTCP handshake and data transfer

did you configure policy-routing as defined in
https://multipath-tcp.org/pmwiki.php/Users/ConfigureRouting ?

You can check that with "ip rule show" and then "ip route show [table]".

I don't know about the LEDE configuration language and what it does exactly
under the hoods. Benjamin Herion (CCed) might know more.

Christoph

> _______________________________________________
> multipathtcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/multipathtcp