Subject: Re: DNSEXT WGLC: Unknown types support

From: Kevin Darcy <[email-masked]>
Date: Wed, 21 Aug 2002 16:56:35 -0400

Ólafur Guðmundsson wrote:

> Extending the Domain Name System with new Resource Record types
> currently requires changes to name server software.  This document
> specifies the changes necessary to allow future DNS implementations
> to handle new RR types transparently.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-dnsext-unknown-rrs-03.txt
>
> This draft is slated to be published as informational, if you disagree with
> that please state why in your response.
>
> The Last call completes on August 29'th 2002.

I still think there should be an exception to the ban on RDATA label
compression for the specific case where the RR type is only to be used between
co-operating clients and servers (e.g. through EDNS OPTION control or
whatever): in this case, the client can reasonably be expected to understand
the RDATA structure and there is no good reason for the benefits of label
compression to be forfeited.

However, no-one on the WG seems to share my opinion on this, so I only state
it for the record.

- Kevin

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: [email-masked] (Andreas Gustafsson)
Date: Mon, 19 Aug 2002 11:14:13 -0700 (PDT)

[ post by non-subscriber.  with the massive amount of spam, it is easy to
  miss and therefore delete mis-posts.  so fix subscription addresses! ]

> that please state why in your response.

I would think it needs to be standards track because it specifies
changes to a standards stack protocol (specifically, changes to the
the DNSSEC RR canonicalization rules defined in RFC2535).
-- 
Andreas Gustafsson, [email-masked]

---

From: Ólafur Guðmundsson<[email-masked]>
Date: Wed, 21 Aug 2002 09:11:13 -0400

>the DNSSEC RR canonicalization rules defined in RFC2535).

You are right, the document is standards track!

         Olafur

---

From: Rob Austein <[email-masked]>
Date: Wed, 21 Aug 2002 10:26:05 -0400

> the DNSSEC RR canonicalization rules defined in RFC2535).

I agree with Andreas.  This draft modifies the downcasing rule used
when computing DNSSEC signatures, so it has to be standards track.

Side question related to this point: do folks feel that the draft goes
into enough detail on this point?  I found it a bit terse, but failed
to come up with anything useful when Andreas quite reasonably asked me
to suggest better text.  If I'm the only person who thinks there's an
issue here, I'll drop it, since presumably this point will be
addressed in the grand unified DNSSEC rewrite anyway.