Subject: Re: DNSEXT WGLC: Unknown types support

From: [email-masked]
Date: Thu, 22 Aug 2002 08:17:24 +1000

> Ólafur Guðmundsson wrote:
> 
> > Extending the Domain Name System with new Resource Record types
> > currently requires changes to name server software.  This document
> > specifies the changes necessary to allow future DNS implementations
> > to handle new RR types transparently.
> >
> > A URL for this Internet-Draft is:
> > http://www.ietf.org/internet-drafts/draft-ietf-dnsext-unknown-rrs-03.txt
> >
> > This draft is slated to be published as informational, if you disagree with
> > that please state why in your response.
> >
> > The Last call completes on August 29'th 2002.
> 
> I still think there should be an exception to the ban on RDATA label
> compression for the specific case where the RR type is only to be used betwee
> n
> co-operating clients and servers (e.g. through EDNS OPTION control or
> whatever): in this case, the client can reasonably be expected to understand
> the RDATA structure and there is no good reason for the benefits of label
> compression to be forfeited.
> 
> However, no-one on the WG seems to share my opinion on this, so I only state
> it for the record.
> 
> 
> - Kevin

	Kevin there are trade offs occuring here.  There is no "right"
	answer that will fit everyones needs.

	compression vs dnssec vs case preservation vs opaque data

	The current trade off gets you
		
		dnssec + case preservation + opaque data

	Mark

> 
> 
> 
> 
> --
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/namedroppers/>
> 
--
Mark Andrews, Internet Software Consortium
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Scott Seligman <[email-masked]>
Date: Thu, 22 Aug 2002 19:37:53 -0700

[ post by non-subscriber.  with the massive amount of spam, it is easy to
  miss and therefore delete mis-posts.  so fix subscription addresses! ]

Rob Austein <[email-masked]> writes:
>
> I agree with Andreas.  This draft modifies the downcasing rule...
> 
> Side question related to this point: do folks feel that the draft goes
> into enough detail on this point?  I found it a bit terse, but failed
> to come up with anything useful when Andreas quite reasonably asked me
> to suggest better text.

While this is probably beyond the scope of the current discussion,
the downcasing rule in RFC 2535 says:  "all domain name letters
are set to lower case".  How does this work for a label that includes
non-ASCII octets?

The RFC uses  \200.z.foo.example  as an example domain name.
Suppose it had used this instead:

	\200\167\115\199.foo.example

The octet \115 in there happens to be in the range of ASCII, 
although from context one might guess that it may not represent the
character "S".  Would the above be mapped to:

	\200\167s\199.foo.example

Although it's not clear what someone would intend with such a
domain name, it's a good bet that they did not intend this.

Scott Seligman
Java Security, Networking, and Naming
Sun Microsystems