Subject: Minutes of the Wednesday, April 23 LLMNR conference call

From: Bernard Aboba <[email-masked]>
Date: Wed, 23 Apr 2003 11:21:18 -0700 (PDT)

Minutes of the Wednesday, April 23 LLMNR conference call

Attendees: Bernard Aboba, Olafur G., Christian Huitema

The focus of today's LLMNR conference call was Issue 33,
sending of LLMNR PTR queries via unicast.  In general,
the feelings about the proposed change were positive,
since this simplifies the protocol.  However, some
concerns were raised.

It was noted that using TCP for unicast queries would
make it harder to spoof unicast LLMNR queries and
responses to those queries. Also setting TTL=1 on
unicast queries and responses to those queries would
help ensure that they travel only over the local link.

To address those concerns, two new issues were opened
up. Issue 34 deals with use of TCP for unicast
queries, and Issue 35 deals with setting TTL=1.

Proposed resolutions to Issues 33, 34 and 35 will be
posted to the DNSEXT WG mailing list for discussion.
Assuming that the response is positive, then the
changes can be made.  Since the proposed resolution
to Issue 33 depends on resolutions for Issues 34 and
35, until Issues 34 and 35 are positively resolved,
then Issue 33 cannot be accepted.

With the addition of unicast PTR queries, the
similarities of LLMNR to the ICMPv6 node information query
become even greater.  This is an issue that needs to
be taken up by the IESG.  However, it was noted that
LLMNR can be implemented in user mode whereas the
ICMPv6 information query needs to be implemented in
kernel mode.  Also, use of TCP for unicast query
makes LLMNR less vulnerable to spoofing, which has
been brought up as an issue with the ICMPv6 node
information query.

The LLMNR issues list is available at:

http://www.drizzle.com/~aboba/DNSEXT/llmnrissues.html

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: [email-masked]
Date: Thu, 24 Apr 2003 11:26:19 +0900

>been brought up as an issue with the ICMPv6 node

	assuming that the OS kernel implements the current IPv6 raw socket
	standard, it is possible to implement ICMPv6 node information query
	client/server in the userland.

itojun