Subject: Re: Revision to resolution of Issue 28

From: Aidan Williams <[email-masked]>
Date: Wed, 16 Apr 2003 14:47:33 +1000

Bernard Aboba wrote:
>>Why does the proposed text start talking about "reachable"
>>and "unreachable" rather than "on link"?
> 
> See the discussion under Issue 28 on the LLMNR issues list:
> http://www.drizzle.com/~aboba/DNSEXT/llmnrissues.html
> 
> The question is whether it is possible to know that a prefix is "on link".
> With IPv6 this seems possible, but it is not clear for IPv4.
> 

I think I found what you are referring to under
   Issue 21: PTR Queries

Issue 21 winds up recommending:

   "[4] A sender SHOULD only send LLMNR queries for PTR RRs
   that represent addresses reachable through the link
   over which LLMNR is used."

"Reachable" in the proposed resolution for 28 seems different
in that it doesn't include the "through the link over which
LLMNR is used" part..  but I think that is what is desired.

How about:

   "A sender SHOULD prefer RRs including addresses known to
   be [directly] reachable through the link over which LLMNR
   is used."

- aidan

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Mika Liljeberg <[email-masked]>
Date: 16 Apr 2003 09:10:19 +0300

Aidan,

The change was made because there is no easy way for an application (=
LLMNR resolver) to check whether a particular address is on-link. Not on
any operating system I know, anyway. There's no difference between IPv4
and IPv6 in this respect.

[On-link determination would become trivial, by the way, if we only
allowed LLMNR to only advertise link-local addresses].

	MikaL