Subject: Re: What is "service name" in SRV records?

From: Derek Atkins <[email-masked]>
Date: 12 May 2003 11:28:49 -0400

Erik Nordmark <[email-masked]> writes:

> RFC 2782 says
>    Currently, the translation from service name to port number happens
>    at the client, often using a file such as /etc/services.
> 
> I've been assuming that "service name" was the same as "keyword" in
> http://www.iana.org/assignments/port-numbers
> but the keywords are not unique within the registry.
> 
> Somebody else found
> http://www.iana.org/assignments/service-names
> which has unique service names.
> 
> What is the correct answer?

I think it refers to the former (assignments/port-numbers).  As for
the keyword uniqueness, the only duplicate I saw in a cursory glance
of the file was compressnet, which was asiggned both ports 2 and 3.  I
didn't notice any other duplicates through about 4500 (which is where
I stopped looking).

>   Erik

-derek

-- 
       Derek Atkins
       Computer and Internet Security Consultant
       [email-masked]             www.ihtfp.com

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: "Eric A. Hall" <[email-masked]>
Date: Mon, 12 May 2003 11:55:17 -0500

> What is the correct answer?

No service name is valid for use with SRV until it has been documented in
a specification which has credible authority over that service. EG,
neither _whois._tcp.domain.dom nor _nicname._tcp.domain.dom are meaningful
until one or the other has been explicitly declared as meaningful within
the context of using SRV RRs to locate the servers associated with a
specific service.

Once an authoritative specification has been written, the service name is
whatever the specification defines it to be. Whether or not that name has
been used anywhere else is simply a matter of convenience.

-- 
Eric A. Hall                                        http://www.ehsco.com/
Internet Core Protocols          http://www.oreilly.com/catalog/coreprot/