Subject: Re: wcard-clarify's change

From: "D. J. Bernstein" <[email-masked]>
Date: 29 Sep 2003 03:20:49 -0000

Paul Vixie writes, paraphrasing VeriSign:
> "users are free to block sitefinder if they want, we're
> only doing it as a service to the internet community."

Spammers say ``Users are free to delete our messages if they want.''

They nevertheless work around every _automated_ anti-spam mechanism as
soon as the mechanism becomes popular---making the mechanism useless.

That's exactly what VeriSign is going to do to your ``delegation-only''
mechanism if that mechanism becomes popular. They will, of course,
continue saying that users are free to block sitefinder.

---D. J. Bernstein, Associate Professor, Department of Mathematics,
Statistics, and Computer Science, University of Illinois at Chicago

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Masataka Ohta <[email-masked]>
Date: Mon, 29 Sep 2003 21:04:19 +0859 ()

Paul;

> > You can do it better (the web server can know the domain name
> > desired) with
> > 
> > >    *.gn.    ns	no-domain-ns0.psg.com.
> > >    *.gn.    ns	no-domain-ns1.psg.com.
> > >    *.lr.    ns	no-domain-ns0.psg.com.
> > >    *.lr.    ns	no-domain-ns1.psg.com.
> > >    *.ng.    ns	no-domain-ns0.psg.com.
> > >    *.ng.    ns	no-domain-ns1.psg.com.
> 
> not with bind you won't.

Haven't you read draft-ietf-dnsext-wcard-clarify-01.txt stating:

   6.2 NS RR's at a Wild Card Domain Name

   Is it not a protocol error to have a NS RR owned by a wild card domian name,
   complimentary to the case of a SOA RR.  However, for this to work, an
   implementation has to know how to synthesize a zone.

?

> perhaps there is software somewhere that
> misreads and misimplements 1034 in that way, but this once, bind isn't
> it.

Hmmm.

> it's dimly possible that dname is supposed to work like this, but
> not NS.

Can we obsolete dname?

						Masataka Ohta