Subject: Re: wcard-clarify's change

From: [email-masked]
Date: Mon, 29 Sep 2003 09:03:56 +1000

> a useful application of wildcard cnames was just pointed out to me.
> 
> i often get folk asking me 
>   o is foo.{gn,lr,ng,...} taken?
>   o if not, how do i register it?
> 
> and i could simply do
>    *.gn.    cname	no-domain.psg.com.
>    *.lr.    cname	no-domain.psg.com.
>    *.ng.    cname	no-domain.psg.com.
>    ...
> 
> and use a name-based virtual server to tell them the name is not in
> use and point them to the forms and procedures to register in the
> domain(s).
> 
> otoh, admittedly, i could use up an ip address, and not use a
> name-based virtual server.  but this is still a valid use of
> 
> randy

	One would hope as technical contact for those tld's that
	you would actually dissuade this use.

> --
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/namedroppers/>
--
Mark Andrews, Internet Software Consortium
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Randy Bush <[email-masked]>
Date: Sun, 28 Sep 2003 16:09:29 -0700

> you would actually dissuade this use.

perhaps you would care to go beyond hope into technical or social
reasons why this is damaging to the internet?

randy

---

From: Masataka Ohta <[email-masked]>
Date: Mon, 29 Sep 2003 08:56:09 +0859 ()

Randy;

> use and point them to the forms and procedures to register in the

You can do it better (the web server can know the domain name
desired) with

>    *.gn.    ns	no-domain-ns0.psg.com.
>    *.gn.    ns	no-domain-ns1.psg.com.
>    *.lr.    ns	no-domain-ns0.psg.com.
>    *.lr.    ns	no-domain-ns1.psg.com.
>    *.ng.    ns	no-domain-ns0.psg.com.
>    *.ng.    ns	no-domain-ns1.psg.com.

which is why delegation-only of BIND does not work.

							Masataka Ohta