Subject: Re: Issue: Add a new QTYPE

From: bill <[email-masked]>
Date: Wed, 19 Nov 2003 01:13:26 -0800 (PST)

two comments:

	there is not enough functional distinction laid out in the arguments
	to justify a new QTYPE, they are both QUERY's but for different address
	classes.

	there already exists an RR with type "DS" and overloading memnonics
	has never been a good idea.

> This is a multi-part message in MIME format.
> 
> ------_=_NextPart_001_01C3AE42.37AD8229
> Content-Type: text/plain;
> 	charset="gb2312"
> Content-Transfer-Encoding: quoted-printable
> 
> 
> > issue: Propose to add a QTYPE to support dual-stack host.
> >=20
> > name: Renxiang Yan
> > email: [email-masked]
> > date:   2003-11-18
> > Type: T
> > Priority: F
> >=20
> >      Currently, the DNS resolver libraries on  a dual-stack host have =
> to initiates two DNS query=20
> > for a specific host, one with QTYPE AAAA(or A6), the other with QTYPE =
> A. The disadvantages are:=20
> >      1. increasing the delay in communication.
> >      2. waste network bandwidth.
> >=20
> >     Also, while DNS resolver libraries get two record, it have to =
> decision to filter or order DNS results,
> > and this process  have not been specified.=20
> >=20
> >     I suppose in this mail to:
> >     1. add a new QTYPE ( which could be named "DS", means Dual Stack") =
> to indicate both AAAA (A6)=20
> > and A record. DNS resolver libraries can initiate just one DNS query =
> to get both IPv4 and IPv6 DNS
> > record from DNS server.
> >    2.  To promote the IPv6 deployment, DNS results for a dual-stack =
> host returned by DNS resolver
> > is suggested to be ordered in IPv6-IPv4.
> >=20
> > R.G.
> > Renxiang Yan
> >=20
> 
> ------_=_NextPart_001_01C3AE42.37AD8229
> Content-Type: text/html;
> 	charset="gb2312"
> Content-Transfer-Encoding: quoted-printable
> 
> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
> <HTML>
> <HEAD>
> <META HTTP-EQUIV=3D"Content-Type" CONTENT=3D"text/html; =
> charset=3Dgb2312">
> <META NAME=3D"Generator" CONTENT=3D"MS Exchange Server version =
> 6.0.6249.1">
> <TITLE>Issue: Add a new QTYPE</TITLE>
> </HEAD>
> <BODY>
> <!-- Converted from text/rtf format -->
> <BR>
> 
> <P><SPAN LANG=3D"zh-cn"><FONT SIZE=3D2 FACE=3D"Arial">issue: Propose to =
> add a QTYPE to support dual-stack host.</FONT></SPAN>
> </P>
> 
> <P><SPAN LANG=3D"zh-cn"><FONT SIZE=3D2 FACE=3D"Arial">name: Renxiang =
> Yan</FONT></SPAN>
> 
> <BR><SPAN LANG=3D"zh-cn"><FONT SIZE=3D2 FACE=3D"Arial">email: =
> [email-masked]</FONT></SPAN>
> 
> <BR><SPAN LANG=3D"zh-cn"><FONT SIZE=3D2 FACE=3D"Arial">date:&nbsp;&nbsp; =
> 2003-11-18</FONT></SPAN>
> 
> <BR><SPAN LANG=3D"zh-cn"><FONT SIZE=3D2 FACE=3D"Arial">Type: =
> T</FONT></SPAN>
> 
> <BR><SPAN LANG=3D"zh-cn"><FONT SIZE=3D2 FACE=3D"Arial">Priority: =
> F</FONT></SPAN>
> </P>
> 
> <P><SPAN LANG=3D"zh-cn"><FONT SIZE=3D2 =
> FACE=3D"Arial">&nbsp;&nbsp;&nbsp;&nbsp; Currently, the DNS resolver =
> libraries on&nbsp; a dual-stack host have to initiates two DNS query =
> </FONT></SPAN>
> 
> <BR><SPAN LANG=3D"zh-cn"><FONT SIZE=3D2 FACE=3D"Arial">for a specific =
> host, one with QTYPE AAAA(or A6), the other with QTYPE A. The =
> disadvantages are: </FONT></SPAN>
> 
> <BR><SPAN LANG=3D"zh-cn"><FONT SIZE=3D2 =
> FACE=3D"Arial">&nbsp;&nbsp;&nbsp;&nbsp; 1. increasing the delay in =
> communication.</FONT></SPAN>
> 
> <BR><SPAN LANG=3D"zh-cn"><FONT SIZE=3D2 =
> FACE=3D"Arial">&nbsp;&nbsp;&nbsp;&nbsp; 2. waste network =
> bandwidth.</FONT></SPAN>
> </P>
> 
> <P><SPAN LANG=3D"zh-cn"><FONT SIZE=3D2 FACE=3D"Arial">&nbsp;&nbsp;&nbsp; =
> Also, while DNS resolver libraries get two record, it have to decision =
> to filter or order DNS results,</FONT></SPAN>
> 
> <BR><SPAN LANG=3D"zh-cn"><FONT SIZE=3D2 FACE=3D"Arial">and this =
> process&nbsp; have not been specified. </FONT></SPAN>
> </P>
> 
> <P><SPAN LANG=3D"zh-cn"><FONT SIZE=3D2 FACE=3D"Arial">&nbsp;&nbsp;&nbsp; =
> I suppose in this mail to:</FONT></SPAN>
> 
> <BR><SPAN LANG=3D"zh-cn"><FONT SIZE=3D2 =
> FACE=3D"Arial">&nbsp;&nbsp;&nbsp; 1. add a new QTYPE ( which could be =
> named &quot;DS&quot;, means Dual Stack&quot;) to indicate both AAAA (A6) =
> </FONT></SPAN>
> 
> <BR><SPAN LANG=3D"zh-cn"><FONT SIZE=3D2 FACE=3D"Arial">and A record. DNS =
> resolver libraries can initiate just one DNS query to get both IPv4 and =
> IPv6 DNS</FONT></SPAN>
> 
> <BR><SPAN LANG=3D"zh-cn"><FONT SIZE=3D2 FACE=3D"Arial">record from DNS =
> server.</FONT></SPAN>
> 
> <BR><SPAN LANG=3D"zh-cn"><FONT SIZE=3D2 FACE=3D"Arial">&nbsp;&nbsp; =
> 2.&nbsp; To promote the IPv6 deployment, DNS results for a dual-stack =
> host returned by DNS resolver</FONT></SPAN>
> 
> <BR><SPAN LANG=3D"zh-cn"><FONT SIZE=3D2 FACE=3D"Arial">is suggested to =
> be ordered in IPv6-IPv4.</FONT></SPAN>
> </P>
> 
> <P><SPAN LANG=3D"zh-cn"><FONT SIZE=3D2 FACE=3D"Arial">R.G.</FONT></SPAN>
> 
> <BR><SPAN LANG=3D"zh-cn"><FONT SIZE=3D2 FACE=3D"Arial">Renxiang =
> Yan</FONT></SPAN>
> </P>
> 
> </BODY>
> </HTML>
> ------_=_NextPart_001_01C3AE42.37AD8229--
> 
> --
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/namedroppers/>
> 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: "D. J. Bernstein" <[email-masked]>
Date: 21 Nov 2003 20:22:24 -0000

This circle of problems would never have occurred if IPv6 addresses had
simply been returned as 16-byte A records.

---D. J. Bernstein, Associate Professor, Department of Mathematics,
Statistics, and Computer Science, University of Illinois at Chicago