Subject: Re: draft-ietf-dnsext-dnssec-intro-09: EDNS0 issue

From: Masataka Ohta <[email-masked]>
Date: Mon, 08 Mar 2004 14:58:13 +0900

Paul;

>>	messages over UDP MUST NOT be larger than 4000

> it can't be a MUST NOT or it modifies the EDNS0 spec, which is out of scope.

I meant

	DNSSEC entities MUST NOT send messages larger than 4000
	over UDP

Can it be within the scope of DNSSEC?

> perhaps we should reissue EDNS0 with a recommendation like 4*EPMTU (where E
> is for Estimated) but this isn't the time or place to make that change.

If EDNS0 is to be changed (in the future, of course), reference
to PMTUD should be clarified (removed entirely), because EDNS0
seemingly assumes fragmentation is always enabled, which means
there is no room for PMTUD, which means, with IPv6, packets must
be fragmented at the source.

Or, if you think some form of PMTUD should be performed, it should
be documented (though I think PMTUD practically impossible).

> so perhaps an advisory statement like "Note: advertising a buffer size larger
> than EPMTU could lead to unfortunate overaggressive IP fragmentation" would
> be enough to tell the dnssec implementor crowd -- who is likely to be the
> first real stress-testers of EDNS0's buffer size extension -- what they need
> to know, without actually amending the EDNS0 specification by side effect.

:-)

							Masataka Ohta

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Masataka Ohta <[email-masked]>
Date: Sat, 13 Mar 2004 08:27:07 +0900

Paul;

>>>no, that really would force tcp, which really would be worse than ip-frag.
>>
>>If message size is 1400B or so, it is definitely so.
>>
>>If message size is 4200B or so, it can still be a valid argument.
>>
>>However, if message size is 64000B, TCP is far better than IP-frag.

> yes, that's true.  the crossover is probably closer to 4*PMTU.

Given 1280B of IPv6 minimum MTU, shouldn't message size limitation
be somewhere around 3600 or 4800, but not 4000?

						Masagtaka Ohta

---

From: Masataka Ohta <[email-masked]>
Date: Sat, 13 Mar 2004 08:48:52 +0900

> be somewhere around 3600 or 4800, but not 4000?

My guess is that current specification of 4000B expects
3 frags over IPv4 that it should be 3600B for IPv6.

						Masataka Ohta

---

From: Masataka Ohta <[email-masked]>
Date: Mon, 08 Mar 2004 14:58:13 +0900

Paul;

I meant

:-)

							Masataka Ohta

---

From: Masataka Ohta <[email-masked]>
Date: Sat, 13 Mar 2004 08:27:07 +0900

Paul;

						Masagtaka Ohta

---

From: Masataka Ohta <[email-masked]>
Date: Sat, 13 Mar 2004 08:48:52 +0900

Masataka Ohta