Subject: Re: draft-ietf-dnsext-dnssec-intro-09: EDNS0 issue

From: "Scott Rose" <[email-masked]>
Date: Mon, 8 Mar 2004 09:59:49 -0500

----- Original Message ----- 
From: "Paul Vixie" <[email-masked]>

> > > it can't be a MUST NOT or it modifies the EDNS0 spec, which is out
> > > of scope.
> >
> > I meant
> >
> > DNSSEC entities MUST NOT send messages larger than 4000
> > over UDP
> >
> > Can it be within the scope of DNSSEC?
>
> then it would be within scope for this docset, but extremely controversial
> since it places a requirement more stringent than EDNS0.  far better to
make
> it advisory and avoid the fight.
>

It would also be an arbitrary limit based on current underlying network
layers.  The 4000 byte limit is not really a bound by DNS (with DNSSEC) or
EDNS0.  It would best not be made a strict constraint that might be made
obsolete by non-DNS factors.  I agree with Paul in that it would be better
to be an advisory statement, but not necessary to the specification.

Scott

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Masataka Ohta <[email-masked]>
Date: Tue, 09 Mar 2004 08:02:38 +0900

Scott Rose;

> EDNS0.

512 byte limit is a bound not by DNS but by the current underlying
network and transport layers.

So?

> but not necessary to the specification.

It is necessary that DNS message size has a limit in the specification.

							Masataka Ohta

PS

The proper limit bound by minimum reassembly buffer size, maximum
IP header length and UDP header length is 508.

---

From: "Scott Rose" <[email-masked]>
Date: Mon, 8 Mar 2004 09:59:49 -0500

----- Original Message ----- 

make

Scott

---

From: Masataka Ohta <[email-masked]>
Date: Tue, 09 Mar 2004 08:02:38 +0900

Scott Rose;

So?

							Masataka Ohta

PS