Subject: Re: draft-ietf-dnsext-dnssec-intro-09: EDNS0 issue

From: Mark Andrews <[email-masked]>
Date: Tue, 09 Mar 2004 11:23:43 +1100

[ Moderators note: Post by non-subscriber.  With the massive amount of
   spam, it is easy to miss and therefore delete relevant posts 
   by non-subsrcibers. Please fix your subscription addresses. ]

> Mark Andrews;
> 
> > 	Why are we arguing about the minimums that have to be
> > 	supported by the architecure?
> 
> Because the minimums of the infrastructure are maximums of DNS.

	We are talking about EDNS.  Nobody is thinking about changing
	the DNS UDP message size.  The DNS is constained in this way,
	EDNS is not.

	EDNS and DNS are *different* protocols which share a port and
	message format.

	EDNS has a UDP request size limit of 512 bytes (inherited
	from DNS) unless you have reason to believe a larger request
	can be handled. e.g. you have just made a request and have
	been told that a bigger request can be handled.

	EDNS has a *negotiated* response size limit.  This is IP
	stack dependent and will usually be *bigger* than the
	infrastructure minimums.  It can also be smaller the the
	infrastructure minimums.  e.g. you have a IPv6 firewall
	which is rejecting DNS packets > 512 bytes so you set the
	EDNS UDP size advertised to 512.  The advertised EDNS UDP
	size is less than the minimum supported by the IPv6.

	DNS has a UDP request and response size limit of 512 bytes.
	
> > 	For example, named has a upper bound on the size of the
> > 	EDNS/UDP response it will send.
> 
> And, it should be specified.

	Why.  This is a *implemtation* limit not a *protocol* limit.
	RFC 2671 already has guidance for seting this limit.
> 							Masataka Ohta
--
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Mark Andrews <[email-masked]>
Date: Tue, 09 Mar 2004 11:23:43 +1100