Subject: Re: 2929bis RRTYPE Allocation for the ENUM Branch Location Record

From: Otmar Lendl <[email-masked]>
Date: Wed, 3 Jan 2007 09:43:36 +0100

Update:

On 2006/12/11 13:12, Otmar Lendl <[email-masked]> wrote:
> --------------------------------------------------------------------
> 
> 	  DNS RRTYPE PARAMETER ALLOCATION TEMPLATE
> 
> Date: 
> 
>   2006/12/11
> 
> Originator: 
> 
>   Otmar Lendl <[email-masked]>, +43 1 5056416 33
> 
> Specification: 
> 
>   http://tools.ietf.org/html/draft-ietf-enum-branch-location-record-01

Based on internal feedback, I've rewritten the explanatory text. It now
should be clearer what parts of the DDDS algorithm are amended and
thus how the EBL fits into the overall ENUM protocol. 

No changes have been made to the actual specification.

The current version can be found at:

http://tools.ietf.org/html/draft-ietf-enum-branch-location-record-02

> Any feedback, both regarding the protocol part, as well as the language
> of draft-ietf-enum-branch-location-record-01 is very much welcome. The
> ENUM WG will put this draft up for last call soon, so I'd prefer to make
> any changes as soon as possible.

The draft is now in WGLC state (till Jan. 15th). 

Once again, any feedback is welcome.

/ol
-- 
< Otmar Lendl ([email-masked]) | nic.at Systems Engineer >

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Ólafur Guðmundsson /DNSEXT co-chair <[email-masked]>
Date: Wed, 17 Jan 2007 11:12:06 -0500

The public comment period has passed, our AD has appointed a
DNS Expert: Edward Lewis. Thank you Ed for being willing to take this on.

The working group chairs now pass the token to the expert to review the
template request and make sure it adheres to the RFC2929bis template, and
render his decision if this RR type request should be sent to IANA for
formal allocation.

In addition the expert is requested to report on the template
and rfc2929bis rules reporting any issues he detected. In particular
the WG is interested in knowing if the rules in RFC2929bis are
sufficient/overarching/unclear/etc.

This report will be used by our AD to judge if any changes in
RFC2929bis RR type allocation process are needed before RFC2929bis
is published.

Ed, you have 2 weeks to render your decision, which is binding.
Expert review due: January 31'th 23:59 UTC

WG: if you have any issues with this request send it to the mailing list
and/or expert ASAP, once the expert issues his ruling it is too late.

The notes below are part of the process evaluation and how to
reflect what this chair has noticed.

Process note #1: WG had no public feedback on the template and its Internet
draft, editors updated the draft since the original request was sent to
namedroppers. Editors please send out an message stating if you got
any private comments as a result of posting the request, no need to say
who or what.

Process note #2: Reading RFC2929bis
IANA in the general case only sees approved requests, it is not
explicitly stated WHO forwards the positive decision by the expert to IANA.
In the general case this should be the DNS expert.
As the expert has not been formally appointed to IANA for this
experiment the chairs of the working group will communicate with IANA.

Process note #3: As far as I can tell there is no appeal of the DNS Expert
decision possible, but the requester can resubmit an updated request.

         Olafur

---

From: "Eastlake III Donald-LDE008" <[email-masked]>
Date: Tue, 23 Jan 2007 12:41:35 -0500

Hi,

I have received no private comments on the current version of the 2929bis draft since it was posted. If I do, I'll forward them to this list (or at least the gist of them if the commenter has privacy concerns).

While there is no explicit provision for appealing the decision of the Expert, since they are appointed by the IESG you could always go to the IESG and try to get the Expert replaced. This is the normal thing with the powerful single administrator model. 

Donald

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ólafur Guðmundsson /DNSEXT co-chair
Sent: Wednesday, January 17, 2007 11:12 AM
To: [email-masked]
Cc: Otmar Lendl; Edward Lewis
Subject: Re: 2929bis RRTYPE Allocation for the ENUM Branch Location Record

The public comment period has passed, our AD has appointed a DNS Expert: Edward Lewis. Thank you Ed for being willing to take this on.

The working group chairs now pass the token to the expert to review the template request and make sure it adheres to the RFC2929bis template, and render his decision if this RR type request should be sent to IANA for formal allocation.

In addition the expert is requested to report on the template and rfc2929bis rules reporting any issues he detected. In particular the WG is interested in knowing if the rules in RFC2929bis are sufficient/overarching/unclear/etc.

This report will be used by our AD to judge if any changes in RFC2929bis RR type allocation process are needed before RFC2929bis is published.

WG: if you have any issues with this request send it to the mailing list and/or expert ASAP, once the expert issues his ruling it is too late.

The notes below are part of the process evaluation and how to reflect what this chair has noticed.

Process note #1: WG had no public feedback on the template and its Internet draft, editors updated the draft since the original request was sent to namedroppers. Editors please send out an message stating if you got any private comments as a result of posting the request, no need to say who or what.

Process note #2: Reading RFC2929bis
IANA in the general case only sees approved requests, it is not explicitly stated WHO forwards the positive decision by the expert to IANA.
In the general case this should be the DNS expert.
As the expert has not been formally appointed to IANA for this experiment the chairs of the working group will communicate with IANA.

Process note #3: As far as I can tell there is no appeal of the DNS Expert decision possible, but the requester can resubmit an updated request.

         Olafur

At 03:43 03/01/2007, Otmar Lendl wrote:

>should be clearer what parts of the DDDS algorithm are amended and thus 
>how the EBL fits into the overall ENUM protocol.
>
> > Any feedback, both regarding the protocol part, as well as the 
> > language of draft-ietf-enum-branch-location-record-01 is very much 
> > welcome. The ENUM WG will put this draft up for last call soon, so 
> > I'd prefer to make any changes as soon as possible.
>

--
to unsubscribe send a message to [email-masked] with the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>