Subject: [dnsext] CDN BOF Re: Uploaded: edns-client-subnet-00

From: Olafur Gudmundsson <[email-masked]>
Date: Sat, 26 Mar 2011 05:17:01 -0400

<chair-hat=on>

On 17/02/2011 3:26 PM, Wilmer van der Gaast wrote:
> On 9 February 2011 13:01, Wilmer van der Gaast<[email-masked]>  wrote:
>> Also, since the release of the last draft we have:
>>
<snip>

There are also some drafts related to the "CDN" problem in general that 
have been published lately and there is going to be a BOF (see below) on 
the topic in Prague. I'm not sure exactly how this draft will play with 
that proposed work, update appreciated by someone that has read all the 
drafts.

> Transport
>
> CDNI - Content Distribution Network Interconnection
>
> Description: There is an emerging requirement for interconnecting content delivery networks (CDNs) so they can interoperate as an open content delivery infrastructure for the end-to-end delivery of content from Content Service Providers (CSPs) to end users. This BOF is to discuss the proposed development of IETF standards to facilitate such CDN interconnection. These standards might include protocols for 1) exchange of metadata between CDNs, 2) exchange of transaction logs & monitoring information, 3) exchange of request-routing information, 4) exchange of policies & capabilities, and 5) content management/flushing.
> BoF Chairs: TBD
> BOF Proponents: Francois Le Faucheur ( [email-masked]), Ben Niven-Jenkins ( [email-masked]), Emile Stephan ( [email-masked])
> People expected: 50
> Length of session: 90-120 minutes
> Conflicts to avoid: DECADE, NFSv4, STORM, ALTO, TSVWG, TSVAREA, APPSAREA, httpbis
> WebEX: Yes
> Responsible AD: David Harrington'
> Goal: Charter a WG
> Agenda:  agenda
> Drafts:  draft-jenkins-cdni-problem-statement,  draft-watson-cdni-use-cases,  draft-bertrand-cdni-use-cases,  draft-lefaucheur-cdni-requirements
> Draft Charter: TBD
> Mailing List:  [email-masked]
> Mailing List Archive:  http://www.ietf.org/mail-archive/web/cdni/
> Status: Approved

here are links to documents:

http://tools.ietf.org/html/draft-jenkins-cdni-problem-statement
http://tools.ietf.org/html/draft-lefaucheur-cdni-requirements
http://tools.ietf.org/html/draft-bertrand-cdni-use-cases
http://tools.ietf.org/html/draft-watson-cdni-use-cases

Olafur

Ps: New feature of the tools website is that draft name w/o version 
number will bring up the latest version.
_______________________________________________
dnsext mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dnsext

---

From: Benjamin Niven-Jenkins <[email-masked]>
Date: Sat, 26 Mar 2011 14:59:41 +0000

Olafur, Colleagues,

On 26 Mar 2011, at 09:17, Olafur Gudmundsson wrote:

> There are also some drafts related to the "CDN" problem in general that have been published lately and there is going to be a BOF (see below) on the topic in Prague. I'm not sure exactly how this draft will play with that proposed work, update appreciated by someone that has read all the drafts.
> 

The edns-client-subnet draft is complementary but not directly related to the CDNI BoF.

edns-client-subnet provides a mechanism to pass the subnet of the client through to the authoritative DNS server to allow that server to return more targetted responses. It could be useful, for example, for CDNs deployed within ISP networks where the CDN caches are deployed closer to the end users than the DNS infrastructure therefore enabling cache selection to be performed based on the client's subnet rather than the client's DNS server's subnet.

The CDNI BoF is about interconnecting CDNs so that, for example, a CDN with a limited geographical footprint can "hand over" delivery to a different CDN for end users outside of its footprint.

HTH
Ben (CDNI BoF protagonist & co-author draft-jenkins-cdni-problem-statement)

> Ps: New feature of the tools website is that draft name w/o version number will bring up the latest version.