Subject: [dnsext] FW: New Version Notification for draft-jiang-dnsext-a6-to-historic-00.txt

From: Sheng Jiang <[email-masked]>
Date: Tue, 20 Sep 2011 06:15:42 +0000

Following the discussion on mail list, here is the text that proposes to move A6 to Historic status.

This document provides a summary of issues and discusses the current usage status of A6 DNS records and moves the A6 specifications to Historic status, providing clarity to implementers and operators.

Comments are welcome.

Sheng, David and Brian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, September 20, 2011 1:06 PM
> To: Sheng Jiang
> Cc: [email-masked]; [email-masked]; Sheng Jiang
> Subject: New Version Notification for draft-jiang-dnsext-a6-to-
> historic-00.txt
> 
> A new version of I-D, draft-jiang-dnsext-a6-to-historic-00.txt has been
> successfully submitted by Sheng Jiang and posted to the IETF repository.
> 
> Filename:	 draft-jiang-dnsext-a6-to-historic
> Revision:	 00
> Title:		 Moving A6 to Historic Status
> Creation date:	 2011-09-20
> WG ID:		 Individual Submission
> Number of pages: 8
> 
> Abstract:
>    This document provides a summary of issues and discusses the current
>    usage status of A6 DNS records and moves the A6 specifications to
>    Historic status, providing clarity to implementers and operators.
> 
> 
> 
> 
> The IETF Secretariat
_______________________________________________
dnsext mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dnsext

---

From: Joe Abley <[email-masked]>
Date: Tue, 20 Sep 2011 08:44:18 -0400

> This document provides a summary of issues and discusses the current usage status of A6 DNS records and moves the A6 specifications to Historic status, providing clarity to implementers and operato…

I find this document extremely pleasing, and am enthusiastic about its publication.

Joe

---

From: Mark Andrews <[email-masked]>
Date: Wed, 21 Sep 2011 01:38:03 +1000

There is no discussion about A6 and DNSSEC.  Type 38 is permanently tainted w.r.t. DNSSEC.

Mark

In message <[email-masked]>, Sheng Jiang
 writes:
> This document provides a summary of issues and discusses the current usage status of A6 DNS rec
> ords and moves the A6 specifications to Historic status, providing clarity to implementers and 
> operators.
> 
> Comments are welcome.
> 
> Sheng, David and Brian
> 
-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]
_______________________________________________
dnsext mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dnsext

---

From: David Conrad <[email-masked]>
Date: Tue, 20 Sep 2011 08:50:11 -0700

Mark,

> There is no discussion about A6 and DNSSEC.  Type 38 is permanently tainted w.r.t. DNSSEC.

Sorry, could you expand on this a bit?  I'm not sure I understand.

Regards,
-drc

---

From: Mark Andrews <[email-masked]>
Date: Wed, 21 Sep 2011 02:11:00 +1000

In message <[email-masked]>, David Conrad
 writes:
> > There is no discussion about A6 and DNSSEC.  Type 38 is permanently =
> tainted w.r.t. DNSSEC.
> 

A6 has a compressed domainname.  To reuse 38 you need to upgrade
every validator in the world.

---

From: Tony Finch <[email-masked]>
Date: Wed, 21 Sep 2011 11:24:03 +0100

> every validator in the world.

The plan is not to remove the assignment of type 38 to A6, but to mark it
obsolete like types 3 (MD) and 4 (MF) etc.

Tony.
-- 
f.anthony.n.finch  <[email-masked]>  http://dotat.at/
Thames, Dover: Southwest veering west 5 to 7. Moderate, occasionally rough.
Rain then showers. Good, occasionally poor.
_______________________________________________
dnsext mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dnsext

---

From: Mark Andrews <[email-masked]>
Date: Thu, 22 Sep 2011 04:01:34 +1000

In message <[email-masked].>, [email-masked] writes:
> On Wed, Sep 21, 2011 at 02:11:00AM +1000, Mark Andrews wrote:
> > 
> 	Does this document call out for the reuse of Type 38?
> 
> 	I find that idea to be unacceptable at this point in time.  There is
> 	no call whatsoever to start recycling code points for RR Types.
> 
> //bill

If there is a A6 record in a signed zone and it is returned (* or
TYPE38 query or as additional) validation of the result will fail
as the validator will no longer understand TYPE38 as this document
is calling for the removal of support of TYPE38 from new products.

At the very least if we are going to make thing break we should
identify all the know failure modes.

In reality there is very little cost to supporting A6 in validators
and nameservers as a record type and doing is all that is required
to prevent breakages if will are willing to put up with breaking
delegations to zones that are only server by servers with A6 records.

Saying that A6 records SHOULD NOT be used to identify IPv6 hosts
and A6 records SHOULD NOT cause additional section processing and
that getaddrinfo(), or similar, SHOULD NOT lookup A6 records really
should be enough for this document.

Mark

---

From: Edward Lewis <[email-masked]>
Date: Wed, 21 Sep 2011 14:40:06 -0400

>delegations to zones that are only server by servers with A6 records.

Except that the A6 record itself is potentially a DOS tool, one of 
the reasons why it was moved off the standards track.  "Breaking" the 
A6 record is a good thing.

A6 has already been busted from standards track to experimental for a 
couple of reasons.  It's not like retiring an integral, well-used and 
studied element of the protocol.

-- 
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Edward Lewis
NeuStar                    You can leave a voice message at +1-571-434-5468

Vote for the word of the day:
"Papa"razzi - father that constantly takes photos of the baby
Corpureaucracy - The institution of corporate "red tape"
_______________________________________________
dnsext mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dnsext

---

From: Mark Andrews <[email-masked]>
Date: Thu, 22 Sep 2011 04:42:40 +1000

> A6 record is a good thing.

Only if you do the additional processing.

---

From: Dick Franks <[email-masked]>
Date: Tue, 27 Sep 2011 15:40:04 +0100

The central premise of this I-D is that production deployment of A6
lies somewhere between negligible and non-existent.

If this assertion holds, any arguments about negative consequences are
really arguments applicable to  RFC3597 unknown record types in
general which would be better advanced elsewhere.

Further A6-specific arguments need to be supported by evidence that
the central premise is erroneous.

Challenge: Can anyone cite an A6 record, in production use, in the
wild, having a domain name in its RDATA? I will summarise any
responses received in next 7 days and post to this list.

--Dick

---

From: Jim Reid <[email-masked]>
Date: Tue, 27 Sep 2011 19:30:28 +0100

> general which would be better advanced elsewhere.

Not really. A6 is special because of its potential for involvement in  
DNS metadata. Misguided or obsolete resolvers may well attempt to use  
this currently experimental RRtype to construct an IPv6 address for  
the RDATA in an NS record. They wouldn't (need to try to) do that for  
other "unknown" record types. The problem is not the implementations  
that no longer support A6: it's the ones that still do and need to be  
fixed. IMO moving A6 to Historic is a necessary and overdue step on  
that path.

> wild, having a domain name in its RDATA?

Evidence of absence is not absence of evidence.
_______________________________________________
dnsext mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dnsext