Subject: Re: (NAT) Re: Host-NAT terminology

From: "Mike Borella" <[email-masked]>
Date: Wed, 13 Jan 1999 09:18:31 -0600

Actually, HostNAT allows assignment of more than just IP addresses
and ports.  Binding IDs and lease times can be assigned as well,
and for security, you need to send other information.  If it sounds
like DHCP, that's because it *is* a lot like DHCP.  See my comments
last week about "going and getting stuff" protocols.

-Mike

Brian E Carpenter <[email-masked]> on 01/13/99 09:00:30 AM

To:   Pyda Srisuresh <[email-masked]>
cc:   Mike Borella/MW/US/3Com, [email-masked]
Subject:  Re: (NAT) Re: Host-NAT terminology

Or stick to NAPA... network address and PORT allocation.
Actually that's neat, as it parallels NAPT.

Whatever, as long as the acronym describes the function.

  Brian

Pyda Srisuresh wrote:
>
> Hmm... Network Address and parameter Allocation (NAPA) sounds like DHCP.
> Unlike DHCP, Host-NAT (I will use this term until we find a replacement)
> does not involve Parameter allocation(other than IP address and port).
> Besides, I think, the name ought to capture the fact that the address
> pertains to an external realm.
>
> The following names (and acronyms) come to mind. I dont know if we will
> have any TM type conflicts on acronyms.
>
>         o External Realm Address Use (ERA) and
>                         External Realm Address and Port Use (ERAP)
>
>         o Realm Specific Address Use (RSA)
>                         Realm Specific Address and Port Use (RSAP)
>
> What do you think?
>
> cheers,
> suresh
>
> >
> > How about Network Address and Parameter Allocation?  It
> > even has a cool acronym for those into wine.
> >
> > -Mike
> >
> >
> >
> >
> >
> > Lloyd Wood <[email-masked]> on 01/11/99 02:48:42 PM
> >
> > Please respond to Lloyd Wood <[email-masked]>
> >
> > To:   Gabriel Montenegro <[email-masked]>
> > cc:   [email-masked] (Mike Borella/MW/US/3Com)
> > Subject:  Re: (NAT) Re: Host-NAT terminology
> >
> >
> >
> >
> > On Mon, 11 Jan 1999, Gabriel Montenegro wrote:
> >
> > > hnat/dnat or nar are no longer transparent to the application.
> > >[..]
> > > essentially, a node in one address space temporarily acquires a
virtual
> > presence
> > > in another address space (which may imply more than just obtaining or
> > > reusing an address). so how about: virtual dynamic presence (or some
> > such)?
> >
> > "ghost addressing"? where the projections of the hosts in other
> > realms are viewed as ghosts?
> >
> > L.
> >
> > ghosts might be translucent, but not transparent.
> >
> > <[email-masked]>PGP<http://www.ee.surrey.ac.uk/Personal/L.Wood/>
> >
> >
> > -
> > To unsubscribe, email [email-masked]' with
> > 'unsubscribe nat' in the body of the message.
> >
> >
> >
> >
> >
> >
> >
> > -
> > To unsubscribe, email [email-masked]' with
> > 'unsubscribe nat' in the body of the message.
> >
>
> -
> To unsubscribe, email [email-masked]' with
> 'unsubscribe nat' in the body of the message.

-
To unsubscribe, email [email-masked]' with
'unsubscribe nat' in the body of the message.

---

From: Pyda Srisuresh <[email-masked]>
Date: Wed, 13 Jan 1999 12:40:17 -0800 (PST)

There is no realm change with DHCP. With Host-NAT, there is.
A node is not required to have an IP address for a DHCP session. 
A node is expected to have already had an IP address (private) for
a Host-NAT session. 

Host-NAT is not just "going and getting stuff". Host-NAT facilitates
realm transition.

cheers,
suresh

-

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 14 Jan 1999 09:30:40 +0000

That is true. My problem is that there is no network address
translation involved. My brain can't handle calling it
NAT when it isn't NAT. 

   Brian

-