Subject: [NAT] draft-kuniaki-nats-00.txt

From: Kuniaki Kondo <[email-masked]>
Date: Fri, 29 Jun 2001 16:32:23 +0900

Folks,

I applied new draft that is draft-kuniaki-nats-00.txt, few weeks ago.
http://www.ietf.org/internet-drafts/draft-kuniaki-nats-00.txt

In this draft, I proposed to enhance NAT.
This enhanced NAT can be access from a host placed at global area
to a host placed behind NAT by using Sub-Address.

If you have some commnets, please tell me it.

Thank you.

--
Kuniaki Kondo
[email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 29 Jun 2001 09:30:23 -0500

Kuniaki,

A proposal to use an IPv4 option as an address extension was discussed
in an IETF BOF in 1994 (Seattle). It did not consider NATs as such
because they were very little used then (oh, happy days!). However it
was rejected, really for three reasons
1) it is in practice impossible to deploy any new IPv4 option
2) the host changes required looked very expensive
3) it was felt strategically better to proceed with IPng

You can find the meeting minutes etc at 
http://www.ietf.cnri.reston.va.us/proceedings/94mar/ipng/aeiou.html

draft-carpenter-aeiou-00.txt is a little harder to find :-)

Anyway, I don't think the basic arguments have changed in 7 years. 

Regards
   Brian Carpenter

> If you have some commnets, please tell me it.

_______________________________________________
nat mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/nat