Subject: Re: (NAT) Discovering a NAT gateway

From: Pyda Srisuresh <[email-masked]>
Date: Sun, 8 Jul 2001 22:54:00 -0700 (PDT)

--- "Iyer, Prakash" <[email-masked]> wrote:
> 
> Has the NAT WG ever discussed mechanisms to discover a NAT gateway en route 
> and query the gateway for its external IP address. The Midcom WG does appear
> to be the place to attempt to do this; I am looking for earlier attempts to
> solve this
> problem.
> 
Neither the NAT WG nor the MIDCOM WG has discovery in their charter.
So, no work done in that direction in either of these work groups.

However, I believe, the IPSec-over-NAT drafts (in IPsec WG) do discuss
discovering a NAT node enroute.

> Thanks in advance.
> -Prakash Iyer
> Intel Arch Labs

cheers,
suresh

__________________________________________________
Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail
http://personal.mail.yahoo.com/
-
To unsubscribe, email [email-masked]' with
'unsubscribe nat' in the body of the message.
List archive: <URL:http://www.portmasters.com/archives/>

---

From: gabriel montenegro <[email-masked]>
Date: Mon, 09 Jul 2001 12:55:12 +0200

> So, no work done in that direction in either of these work groups.

maybe not in the context of nat boxes, but rsip (also within nat WG)
does discuss locating gateways by two methods (dhcp or sip).

see section 3.5 of
http://www.normos.org/ietf/draft/draft-ietf-nat-rsip-framework-05.txt

-gabriel

-