Subject: [NAT] RE: Regarding NAT MIB draft. <draft-ietf-natmib-nat-03>

From: "Rohit Rohit" <[email-masked]>
Date: Mon, 18 Feb 2002 08:28:52 -0800

I guess this discussion is quite useful hence forwarding this 
to the NAT mailing list.

Thanks
Rohit

-----Original Message-----
From: Pyda Srisuresh [mailto:[email-masked]]
Sent: Monday, February 18, 2002 8:13 AM
To: Rajendra Prasad; Rohit Rohit
Cc: [email-masked]; [email-masked]; [email-masked];
[email-masked]
Subject: Re: Regarding NAT MIB draft. <draft-ietf-natmib-nat-03>

--- Rajendra  Prasad <[email-masked]> wrote:
> 
> Hi Rohit,
> 
>  We define an Outbound Address Map for Basic NAT. NAPT and Bi-Directional
> NAT... An Inbound Address Map is defined for Twice NAT. So, an Address Map
> can either be Outbound or Inbound.. I am  not able visualize the scenario
> where an Address Map can be both Inbound and Outbound.
> 

Address map can be "both" (i.e., inbound and outbound) for a 
bi-directional-NAT. The direction of the map simply refers to the 
session direction in which the map is applicable. 

No matter which address map is used (inbound-address-map or 
outbound-address-map, static or dynamic), the address-bind and the
associated translation nature is fixed. I.e., SrcSddress is translated 
on the outbound packets. DestAddress is translated in translated on the
inbound packets.

As I mentioned in a different thread, the current MIB draft does not
support twice-NAT.

> Thanks
> B.Rajendra Prasad

regards,
suresh

> 
>  On Fri, 15 Feb 2002 Rohit Rohit wrote :
> > Hi Rajendra, 
> > 
> >   natConfAddrMapName is a set of addressMaps as 
> >   natConfAddrMapTable has tow indexes :-> INDEX   { 
> > natConfAddrMapName, natConfAddrMapIndex }.
> > 
> >   natConfAddrMapDirection refers to the direction.
> > 
> >   natConfAddrMapDirection OBJECT-TYPE
> >     SYNTAX  INTEGER {
> >                 inbound (1),
> >                 outbound (2),
> >                 both (3)
> >             }
> > 
> >   So one natConfAddrMapConfigName can specify the 
> > config for Twice NAT.
> > 
> >   Do let me know if i answered your question.
> > 
> >   Thanks
> >   Rohit
> >  
> > 
> > -----Original Message-----
> > From: Rajendra Prasad [mailto:[email-masked]]
> > Sent: Thursday, February 14, 2002 4:41 AM
> > To: Rohit Rohit; [email-masked]; [email-masked]; 
> > [email-masked];
> > [email-masked]
> > Subject: Regarding NAT MIB draft. 
> > <draft-ietf-natmib-nat-03>
> > 
> > 
> > 
> > Hi,
> >   
> >  I want a small clarification on natConfTable in the 
> > latest version of NAT MIB
> > 
> >  When Twice NAT is enabled on an interface, BasicNAT 
> > must be enabled on that interface.
> > 
> > Since natConfigInterfaceIndex is used to index the 
> > natConfTable, I can have only one 
> > natConfAddrMapConfigName. But for using NAT and Twice 
> > NAT on an interface of a Router, I need to use two 
> > different Local Address Ranges and Global Address Ranges
> > 
> > How can I configure this using the MIB?
> > 
> > And Now I have to configure Static mapping for this Two 
> > Address Mapppings as Twice NAT requires static mappings 
> > for the DNS servers. How do I go about configuring 
> > this.?
> > 
> > Please do clarify me on this.
> > 
> > Thanks and regards
> > B. Rajendra Prasad 
> > 
>  
> 

=====

__________________________________________________
Do You Yahoo!?
Yahoo! Sports - Coverage of the 2002 Olympic Games
http://sports.yahoo.com

_______________________________________________
nat mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nat

---

From: "Rohit Rohit" <[email-masked]>
Date: Mon, 18 Feb 2002 08:28:52 -0800

Thanks
Rohit

-----Original Message-----
From: Pyda Srisuresh [mailto:[email-masked]]
Sent: Monday, February 18, 2002 8:13 AM
To: Rajendra Prasad; Rohit Rohit
Cc: [email-masked]; [email-masked]; [email-masked];
[email-masked]

regards,
suresh

=====