Subject: [NAT] Clarification required

From: "Sam K. Sankoorikal" <[email-masked]>
Date: Fri, 29 Nov 2002 18:15:15 +0530

Hi Rajiv,
       
        There is a clarification in the NAT-MIB which I need. Should not 
the natConfMapEntryType be read-only? If the row of  natConfAddrMapTable 
is created by SNMP then the row is Static; however if the row is created 
by the NAT protocol dynamically then the entry is dynamic. It is not 
possible to set the value to dynamic and create the entry. Please let me 
know your opinion.

Thanks and Regards,
Sam.
-- 
  Sam K. Sankoorikal.
  Home Net Solutions <http://www.wipro.com/homenet> ,
  Wipro Technologies <http://www.wipro.com>
  Ganapa Complex,
  #53/1 Hosur Rd Madivala,
  Bangalore, India 560068
  PBX:     +91 80 5502001 extn 3114
  [email-masked]

---

From: "Sam K. Sankoorikal" <[email-masked]>
Date: Fri, 29 Nov 2002 20:55:36 +0530

Rajiv,

        My query continues below:

Rajiv Raghunarayan wrote:

>Hi Sam,
>
>The natConfAddrMapTable only represents the NAT configuration. The entry
>
If the natConfAddrMapTable only represents the existing configuration, 
doesn't this mean that the entire table will be a read-only table. (i.e) 
there would not be the possibility for a row to be added or deleted. But 
this seems difficult to follow. Can you please describe how a typical 
mapping would be added statically and the result on the different 
configuration table. Should not the configuration tables be used for 
configuring NAT.

Here is a scenario I could describe:

This table can be used to create a range of Addrmap by specifying the 
bare minimum information required; viz the Range of Local, Global, 
Ports, Protocol. following these inputs the static mappings over the 
range could be created.

>
>in the Bind tables is created either 'statically' or 'dynamically', and
>this property is represented by natConfMapEntryType.
>
>Hope this clarifies.
>
>-Rajiv.
>
>On Fri, 29 Nov 2002, Sam K. Sankoorikal wrote:
>
>>Hi Rajiv,
>>

---

From: "Sam K. Sankoorikal" <[email-masked]>
Date: Fri, 29 Nov 2002 20:55:36 +0530

Rajiv,

---

From: Rajiv Raghunarayan <[email-masked]>
Date: Fri, 29 Nov 2002 18:44:18 +0530 (IST)

Hi Sam,

Hope this clarifies.

-Rajiv.

> possible to set the value to dynamic and create the entry. Please let me

_______________________________________________
nat mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nat

---

From: Rajiv Raghunarayan <[email-masked]>
Date: Fri, 29 Nov 2002 18:44:18 +0530 (IST)

Hi Sam,

Hope this clarifies.

-Rajiv.

---

From: Rajiv Raghunarayan <[email-masked]>
Date: Sat, 30 Nov 2002 00:45:23 +0530

Hi Sam,

My comments inline..

> If the natConfAddrMapTable only represents the existing configuration,

In addition to representing existing configuration (or configuration
done via a non-SNMP mechanism), the natConfAddrMapTable can also
be used to configure a NAT mapping. Section 4.3 of the draft,
"Configuration via the MIB", gives more details regarding this.

> Ports, Protocol. following these inputs the static mappings over the

Yep. This is precisely the reason why this table has read-create
access.

-Rajiv.

---

From: Rajiv Raghunarayan <[email-masked]>
Date: Sat, 30 Nov 2002 00:45:23 +0530

Hi Sam,

My comments inline..

-Rajiv.