Subject: [NAT] Clarification required

From: "Sam K. Sankoorikal" <[email-masked]>
Date: Fri, 29 Nov 2002 18:15:15 +0530

Hi Rajiv,
       
        There is a clarification in the NAT-MIB which I need. Should not 
the natConfMapEntryType be read-only? If the row of  natConfAddrMapTable 
is created by SNMP then the row is Static; however if the row is created 
by the NAT protocol dynamically then the entry is dynamic. It is not 
possible to set the value to dynamic and create the entry. Please let me 
know your opinion.

Thanks and Regards,
Sam.
-- 
  Sam K. Sankoorikal.
  Home Net Solutions <http://www.wipro.com/homenet> ,
  Wipro Technologies <http://www.wipro.com>
  Ganapa Complex,
  #53/1 Hosur Rd Madivala,
  Bangalore, India 560068
  PBX:     +91 80 5502001 extn 3114
  [email-masked]

---

From: "Rohit Rohit" <[email-masked]>
Date: Fri, 29 Nov 2002 19:18:17 -0800

Hi Sam, 
 
IMHO, Statis and dynamic refers to Static Address assignment and Dynamic Address assignment.
 
Static Address assignment

   In the case of static address assignment, there is one-to-one address
   mapping for hosts between a private network address and an external
   network address for the lifetime of NAT operation.  Static address
   assignment ensures that NAT does not have to administer address
   management with session flows.

Dynamic Address assignment

   In this case, external addresses are assigned to private network
   hosts or vice versa, dynamically based on usage requirements and
   session flow determined heuristically by NAT. When the last session
   using an address binding is terminated, NAT would free the binding so
   that the global address could be recycled for later use. The exact
   nature of address assignment is specific to individual NAT
   implementations.

Thanks
Rohit

-----Original Message-----
From: Sam K. Sankoorikal [mailto:[email-masked]]
Sent: Friday, November 29, 2002 4:45 AM
To: [email-masked]; [email-masked]
Cc: Hemanth Rajasekhar
Subject: [NAT] Clarification required

Hi Rajiv,
        
        There is a clarification in the NAT-MIB which I need. Should not the natConfMapEntryType be read-only? If the row of  natConfAddrMapTable is created by SNMP then the row is Static; however if the row is created by the NAT protocol dynamically then the entry is dynamic. It is not possible to set the value to dynamic and create the entry. Please let me know your opinion.

Thanks and Regards,
Sam.

-- 

  	  Sam K. Sankoorikal.
   Home  <http://www.wipro.com/homenet> Net Solutions ,
  Wipro  <http://www.wipro.com> Technologies
  Ganapa Complex,
  #53/1 Hosur Rd Madivala,
  Bangalore, India 560068
  PBX:     +91 80 5502001 extn 3114
  [email-masked]

---

From: "Rohit Rohit" <[email-masked]>
Date: Fri, 29 Nov 2002 19:18:17 -0800

Hi Sam, 

Thanks
Rohit

-----Original Message-----
From: Sam K. Sankoorikal [mailto:[email-masked]]
Sent: Friday, November 29, 2002 4:45 AM
To: [email-masked]; [email-masked]
Cc: Hemanth Rajasekhar
Subject: [NAT] Clarification required

Hi Rajiv,

Thanks and Regards,
Sam.

-- 

  	  Sam K. Sankoorikal.

---

From: "Sam K. Sankoorikal" <[email-masked]>
Date: Sat, 30 Nov 2002 16:42:04 +0530

Hi Rajiv,

??? ??? Good Day!

??? ??? I have gone through section 4.3 of the NAT-MIB . I quote the 
section:

"  -  Setting  the natConfStatus to 'active'(1) will enable
      nat on the interface. Note that the associated entries in the
      natConfAddrMapTable and natConfProtTable (if any) must also
      be made active.

   -  The Address Bind and Address-Port Table will have the entries 
      created due to this nat configuration. A Management Station may
      also, if deemed necessary, create entries Address Bind or a 
      Address-Port Bind entry and link those entries to the appropriate
      address map configured. "

The above section does not tell us the values to be set in case you 
needed to create an entry in the natConfAddrMapTable. ie what value 
would I have to set natConfAddrMapEntryType to go on and create an entry

NatConfAddrMapEntry ::= SEQUENCE {
    natConfAddrMapName             SnmpAdminString,
    natConfAddrMapIndex            Integer32,
    natConfAddrMapEntryType        INTEGER,
    natConfAddrMapDirection        INTEGER,
    natConfLocalAddrType           InetAddressType,
    natConfLocalAddrFrom           InetAddress,
    natConfLocalAddrTo             InetAddress,
    natConfLocalPortFrom           Integer32,
    natConfLocalPortTo             Integer32,
    natConfGlobalAddrType          InetAddressType,
    natConfGlobalAddrFrom          InetAddress,
    natConfGlobalAddrTo            InetAddress,
    natConfGlobalPortFrom          Integer32,
    natConfGlobalPortTo            Integer32,
    natConfProtocol                BITS,
    natConfAddrMapStorageType      StorageType,
    natConfAddrMapStatus           RowStatus
}

natConfAddrMapEntryType OBJECT-TYPE
    SYNTAX  INTEGER {
                static (1),
                dynamic (2)
            }
    MAX-ACCESS  read-create
    STATUS      current
    DESCRIPTION
            "This config parameter can be used to set up static 
             or dynamic address maps."
    ::= { natConfAddrMapEntry 3 }

I also quote Rohits' input:

?? In the case of static address assignment, there is one-to-one address
?? mapping for hosts between a private network address and an external
?? network address for the lifetime of NAT operation.? Static address
?? assignment ensures that NAT does not have to administer address
?? management with session flows.

?? In this case, external addresses are assigned to private network
?? hosts or vice versa, dynamically based on usage requirements and
?? session flow determined heuristically by NAT. When the last session
?? using an address binding is terminated, NAT would free the binding so
?? that the global address could be recycled for later use. The exact
?? nature of address assignment is specific to individual NAT
?? imp
lementations.?

(The functionality has been described. More could be added on how we would configure the same)

Based on the above definition of dynamic NAT it seems that the 
NatConfAddrMapEntry 's? which are dynamic are created on the fly, on a 
need basis by the NAT module/protocol and can't be exactly specified as 
dynamic and created by a user through SNMP. However if we wanted to 
configure a Static NAT entry then that configuration could be created by 
the user by specifying other [Direction, Addresses, Ports, protocols] 
OID value other than the natConfAddrMapEntryType. This value will be 
derived. Hence I think it would be clearer if the 
natConfAddrMapEntryType were given a max access of read-only. This is 
something which cannot be specified by the user. To tell more about the 
dynamic entries I think by enabling NAT on an interface and running a 
network application using NAT, then dynamic NAT entries would be 
created. The same could be repeated for NAPT.

natConfAddrMapEntryType OBJECT-TYPE
    SYNTAX  INTEGER {
                static (1),
                dynamic (2)
            }
    MAX-ACCESS  *read-only*

Thanks and Regards,
Sam.

-- 
? Sam K. Sankoorikal.
??Home Net Solutions <http://www.wipro.com/homenet> ,
? Wipro Technologies <http://www.wipro.com>
? Ganapa Complex,
? #53/1 Hosur Rd Madivala,
? Bangalore, India 560068
? PBX:???? +91 80 5502001 extn 3114
? [email-masked]