Subject: [Nea] NEA extensibility points

From: Randy Turner <[email-masked]>
Date: Wed, 5 Aug 2009 09:47:47 -0700

Hi List,

The PA-TNC document is clear on how attributes types are relative to  
the vendor-ID value used in a message.

The PA-TNC document also mentions a registry for PA-subtypes.  What I  
wanted to make sure is that other organizations could establish an SMI  
value and register NEW PA subtypes that are relative to the  
organization-specific SMI.

Are there any limitations or constraints on creating new PA subtypes  
under a specific SMI ?

Thanks!
Randy

---

From: Stephen Hanna <[email-masked]>
Date: Wed, 5 Aug 2009 13:55:07 -0400

The PA Subtype registry is created in the PB-TNC spec.
Look there for information about how that registry
will be managed.

To answer your question, any organization can get an
SMI Private Enterprise Number (PEN) from IANA and then
create new PA Subtypes of any kind and for any purpose
that will be used with that organization's SMI PEN.

For example, my employer Juniper has an SMI PEN of 2636.
We could define a PA Subtype for Power Supply Firmware
(or something else that we came up with). Let's say that
we decided to make that PA Subtype 27, when used with
our SMI PEN of 2636. No problem. Now we can send around
PB-PA messages with that PA Subtype and SMI PEN.

An organization that defines a new PA Subtype is not
required to register their PA Subtype with IANA. They
can keep it to themselves. But if they want to register
their PA Subtype values with IANA, they can do so. They
just need to send a spec for their PA Subtype value to
IANA which will trigger the Expert Review process
described in sectin 6.1 of PB-TNC. Of course, this
process won't be ready to go until PB-TNC becomes
an RFC (real soon now, I hope! ;-).

I hope that helps.

Thanks,

Steve

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Randy Turner
> Sent: Wednesday, August 05, 2009 12:48 PM
> To: NEA
> Subject: [Nea] NEA extensibility points
> 
> Hi List,
> 
> _______________________________________________
> Nea mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nea
>

---

From: Randy Turner <[email-masked]>
Date: Wed, 5 Aug 2009 11:27:23 -0700

Thanks for the reply Steve....

So IANA will keep a registry of SMI-specific attributes and PA- 
subtypes for SMI values OTHER than IETF (SMI=0)?

Also, does the expert review process only occur if we're registering  
additional values as standard IETF types(SMI=0), or
does the expert review process occur regardless of which SMI we're  
registering under?

Thanks!!
Randy

---

From: Stephen Hanna <[email-masked]>
Date: Thu, 6 Aug 2009 09:26:17 -0400

Yes, the plan is for IANA to keep one registry for PA Subtypes
and include in that registry both values with SMI PEN = 0 and
values with SMI PEN != 0. The Designated Expert process will
be used for all of these values but the criteria to be used
by the Designated Expert are less stringent when PEN != 0.

All this information is in the IANA Considerations section
of PB-TNC, BTW. Please let me know if you found that section
less than clear.

Thanks,

Steve

> From: Randy Turner [mailto:[email-masked]] 
> Sent: Wednesday, August 05, 2009 2:27 PM
> To: Stephen Hanna
> Cc: NEA
> Subject: Re: [Nea] NEA extensibility points
> 
>